(address . guix-patches@gnu.org)(name . John Doe)(address . dftxbs3e@free.fr)
* gnu/packages/syncthing.scm (syncthing): Update to 1.12.0.
[source]: Do not delete bundled dependencies, maintaining the
syncthing package without them is too much trouble. Syncthing's upstream
seems committed to including only Free Software in their releases.
[arguments]: Modify build phase to run build.go without any argument
otherwise nothing would get built. This causes binaries to be written
into a bin/ directory, adjust delete-file statement accordingly. Also
adjust install phase to look for all binaries but syncthing in a bin/
subdirectory.
* gnu/packages/syncthing.scm: Remove go-github-com-jackpal-go-nat-pmp,
go-github-com-audriusbutkevicius-recli,
go-github-com-bkaradzic-go-lz4, go-github-com-calmh-du,
go-github-com-calmh-xdr, go-github-com-d4l3k-messagediff,
go-github-com-gobwas-glob, go-github-com-golang-groupcache-lru,
go-github-com-golang-snappy, go-github-com-jackpal-gateway,
go-github-com-lib-pq, go-github-com-oschwald-geoip2-golang,
go-github-com-oschwald-maxminddb-golang, go-github-com-stathat-go,
go-github-com-rcrowley-go-metrics, go-github-com-sasha-s-go-deadlock,
go-github-com-syndtr-goleveldb, go-github-com-thejerf-suture,
go-github-com-vitrun-qart, go-github-com-chmduquesne-rollinghash,
go-github-com-petermattis-goid, go-github-com-kballard-go-shellquote,
go-github-com-syncthing-notify, go-github-com-beorn7-perks-quantile,
go-github-com-prometheus-client-model,
go-github-com-matttproud-golang-protobuf-extensions-pbutil,
go-github-com-prometheus-common, go-github-com-prometheus-procfs,
go-github-com-prometheus-client-golang,
go-github-com-go-asn1-ber-asn1-ber, go-github-com-go-ldap-ldap,
go-github-com-flynn-archive-go-shlex,
go-github-com-audriusbutkevicius-pfilter, go-github-com-ccding-go-stun,
and go-github-com-cespare-xxhash variables.
---
gnu/packages/syncthing.scm | 987 +------------------------------------
1 file changed, 11 insertions(+), 976 deletions(-)
Toggle diff (405 lines)
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 7e479a0d39..0937e2bcff 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -43,7 +43,7 @@
(define-public syncthing
(package
(name "syncthing")
- (version "1.5.0")
+ (version "1.12.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/syncthing/syncthing"
@@ -51,68 +51,12 @@
"/syncthing-source-v" version ".tar.gz"))
(sha256
(base32
- "1394b8y4nllihnjngc0kjpdy7pvyh6v1h09hkn8rdmwxpsdkqkjb"))
- (modules '((guix build utils)))
- ;; Delete bundled ("vendored") free software source code.
- (snippet '(begin
- (delete-file-recursively "vendor")
- #t))))
+ "0a8s7xmaiqg8j7zmwqr7gw6kip0lh42yig9gmnk51c2r3ic5f2zv"))))
(build-system go-build-system)
;; The primary Syncthing executable goes to "out", while the auxiliary
;; server programs and utility tools go to "utils". This reduces the size
;; of "out" by ~80 MiB.
(outputs '("out" "utils"))
- ;; When updating Syncthing, check 'go.mod' in the source distribution to
- ;; ensure we are using the correct versions of these dependencies.
- (inputs
- `(("go-github-com-jackpal-go-nat-pmp"
- ,go-github-com-jackpal-go-nat-pmp)
- ("go-github-com-bkaradzic-go-lz4" ,go-github-com-bkaradzic-go-lz4)
- ("go-github-com-calmh-xdr" ,go-github-com-calmh-xdr)
- ("go-github-com-chmduquesne-rollinghash"
- ,go-github-com-chmduquesne-rollinghash)
- ("go-github-com-gobwas-glob" ,go-github-com-gobwas-glob)
- ("go-github-com-golang-groupcache-lru"
- ,go-github-com-golang-groupcache-lru)
- ("go-github-com-jackpal-gateway" ,go-github-com-jackpal-gateway)
- ("go-github-com-kballard-go-shellquote"
- ,go-github-com-kballard-go-shellquote)
- ("go-github-com-lib-pq" ,go-github-com-lib-pq)
- ("go-github-com-minio-sha256-simd" ,go-github-com-minio-sha256-simd)
- ("go-github-com-oschwald-geoip2-golang"
- ,go-github-com-oschwald-geoip2-golang)
- ("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
- ("go-github-com-rcrowley-go-metrics" ,go-github-com-rcrowley-go-metrics)
- ("go-github-com-sasha-s-go-deadlock" ,go-github-com-sasha-s-go-deadlock)
- ("go-github-com-syncthing-notify" ,go-github-com-syncthing-notify)
- ("go-github-com-syndtr-goleveldb" ,go-github-com-syndtr-goleveldb)
- ("go-github-com-thejerf-suture" ,go-github-com-thejerf-suture)
- ("go-golang-org-x-time" ,go-golang-org-x-time)
- ("go-github-com-go-ldap-ldap" ,go-github-com-go-ldap-ldap)
- ("go-github-com-gogo-protobuf" ,go-github-com-gogo-protobuf)
- ("go-github-com-shirou-gopsutil" ,go-github-com-shirou-gopsutil)
- ("go-github-com-prometheus-client-golang"
- ,go-github-com-prometheus-client-golang)
- ("go-golang-org-x-net" ,go-golang-org-x-net)
- ("go-golang-org-x-text" ,go-golang-org-x-text)
- ("go-github-com-audriusbutkevicius-recli"
- ,go-github-com-audriusbutkevicius-recli)
- ("go-github-com-urfave-cli" ,go-github-com-urfave-cli)
- ("go-github-com-vitrun-qart" ,go-github-com-vitrun-qart)
- ("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
- ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
- ("go-github-com-flynn-archive-go-shlex"
- ,go-github-com-flynn-archive-go-shlex)
- ("go-github-com-getsentry-raven-go" ,go-github-com-getsentry-raven-go)
- ("go-github-com-maruel-panicparse" ,go-github-com-maruel-panicparse)
- ("go-github-com-ccding-go-stun" ,go-github-com-ccding-go-stun)
- ("go-github-com-audriusbutkevicius-pfilter" ,go-github-com-audriusbutkevicius-pfilter)
- ("go-github-com-lucas-clemente-quic-go" ,go-github-com-lucas-clemente-quic-go)
- ("go-github-com-willf-bloom" ,go-github-com-willf-bloom)
-
- ;; For tests.
- ("go-github-com-d4l3k-messagediff" ,go-github-com-d4l3k-messagediff)))
-
(arguments
`(#:modules ((srfi srfi-26) ; for cut
(guix build utils)
@@ -135,8 +79,8 @@
;; updater and to build the utilities is to "build all" and then
;; "build syncthing" again with -no-upgrade.
;; https://github.com/syncthing/syncthing/issues/6118
- (invoke "go" "run" "build.go" "build" "all")
- (delete-file "syncthing")
+ (invoke "go" "run" "build.go")
+ (delete-file "bin/syncthing")
(invoke "go" "run" "build.go" "-no-upgrade" "build" "syncthing"))))
(replace 'check
@@ -150,12 +94,13 @@
(utils (assoc-ref outputs "utils")))
(with-directory-excursion "src/github.com/syncthing/syncthing"
(install-file "syncthing" (string-append out "/bin"))
- (for-each (cut install-file <> (string-append utils "/bin/"))
- '("stcli" "stcompdirs" "stcrashreceiver"
- "stdisco" "stdiscosrv" "stevents" "stfileinfo"
- "stfinddevice" "stfindignored" "stgenfiles"
- "stindex" "strelaypoolsrv" "strelaysrv" "stsigtool"
- "stvanity" "stwatchfile" "uraggregate" "ursrv"))
+ (with-directory-excursion "bin"
+ (for-each (cut install-file <> (string-append utils "/bin/"))
+ '("stcli" "stcompdirs" "stcrashreceiver"
+ "stdisco" "stdiscosrv" "stevents" "stfileinfo"
+ "stfinddevice" "stfindignored" "stgenfiles"
+ "stindex" "strelaypoolsrv" "strelaysrv" "stsigtool"
+ "stvanity" "stwatchfile" "uraggregate" "ursrv")))
#t))))
(add-after 'install 'install-docs
@@ -251,913 +196,3 @@ notification area icon for Syncthing. Supported Syncthing features:
@item Editing daemon settings
@end itemize\n")
(license gpl2)))
-
-(define-public go-github-com-jackpal-go-nat-pmp
- (package
- (name "go-github-com-jackpal-go-nat-pmp")
- (version "1.0.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jackpal/go-nat-pmp")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1p2yrzfbkazc9nisr2iqjwzhb6q16zj6finyxxn2ikk7iiighl1g"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/jackpal/go-nat-pmp"))
- (synopsis "Port mapping and discovery of external IP address")
- (description "This package provides a Go client for the NAT-PMP internet
-protocol for port mapping and discovering the external IP address of a
-firewall.")
- (home-page "https://github.com/jackpal/go-nat-pmp")
- (license asl2.0)))
-
-(define-public go-github-com-audriusbutkevicius-recli
- (package
- (name "go-github-com-audriusbutkevicius-recli")
- (version "0.0.5")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/AudriusButkevicius/recli")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1m1xna1kb78pkmr1lfmvvnpk9j7c4x71j3a7c6vj7zpzc4srpsmf"))))
- (build-system go-build-system)
- (inputs
- `(("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
- ("go-github-com-urfave-cli" ,go-github-com-urfave-cli)))
- (arguments
- `(#:import-path "github.com/AudriusButkevicius/recli"))
- (synopsis "Reflection-based CLI generator")
- (description "For a given struct, @code{recli} builds a set of
-@code{urfave/cli} commands which allows you to modify it from the command line.
-It is useful for generating command line clients for your application
-configuration that is stored in a Go struct.")
- (home-page "https://github.com/AudriusButkevicius/recli")
- (license mpl2.0)))
-
-(define-public go-github-com-bkaradzic-go-lz4
- (let ((commit "7224d8d8f27ef618c0a95f1ae69dbb0488abc33a")
- (revision "0"))
- (package
- (name "go-github-com-bkaradzic-go-lz4")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bkaradzic/go-lz4")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "10lmya17vdqg2pvqni0p73iahni48s1v11ya9a0hcz4jh5vw4dkb"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/bkaradzic/go-lz4"))
- (synopsis "LZ4 compression algorithm")
- (description "This package provides @code{go-lz4}, a Go implementation of
-the LZ4 compression algorithm.")
- (home-page "https://github.com/bkaradzic/go-lz4")
- (license bsd-2))))
-
-(define-public go-github-com-calmh-du
- (package
- (name "go-github-com-calmh-du")
- (version "1.0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/calmh/du")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0qb3a6y3p9nkyn3s66k6zcm16y8n8578qh23ddj14cxf2scrr2n2"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/calmh/du"))
- (synopsis "Get total and available disk space of a given volume")
- (description "This is a Go implementation of `du`. It provides disk usage
-information, such as how much storage space is available, free, and used.")
- (home-page "https://github.com/calmh/du")
- (license public-domain)))
-
-(define-public go-github-com-calmh-xdr
- (package
- (name "go-github-com-calmh-xdr")
- (version "1.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/calmh/xdr")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "072wqdncz3nd4a3zkhvzzx1y3in1lm29wfvl0d8wrnqs5pyqh0mh"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/calmh/xdr"))
- (synopsis "XDR marshalling and unmarshalling")
- (description "XDR is an External Data Representation (XDR)
-marshalling and unmarshalling library in Go. It uses code generation and not
-reflection.")
- (home-page "https://github.com/calmh/xdr")
- (license expat)))
-
-(define-public go-github-com-d4l3k-messagediff
- (package
- (name "go-github-com-d4l3k-messagediff")
- (version "1.2.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/d4l3k/messagediff")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "104hl8x57ciaz7mzafg1vp9qggxcyfm8hsv9bmlihbz9ml3nyr8v"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/d4l3k/messagediff"))
- (synopsis "Diff arbitrary Go structs")
- (description "Messagediff is a library for calculating diffs of arbitrary
-structs in the Go programming language.")
- (home-page "https://github.com/d4l3k/messagediff")
- (license expat)))
-
-(define-public go-github-com-gobwas-glob
- (package
- (name "go-github-com-gobwas-glob")
- (version "0.2.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gobwas/glob")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0jxk1x806zn5x86342s72dq2qy64ksb3zrvrlgir2avjhwb18n6z"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/gobwas/glob"))
- (synopsis "Go globbing library")
- (description "This package provides a Go implementation of globs.")
- (home-page "https://github.com/gobwas/glob")
- (license expat)))
-
-
-(define-public go-github-com-golang-groupcache-lru
- (let ((commit "869f871628b6baa9cfbc11732cdf6546b17c1298")
- (revision "2"))
- (package
- (name "go-github-com-golang-groupcache-lru")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/golang/groupcache")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0r4nk8129bvx50qb4xzjaay39b2h6k7cbdqqzdlanmc82ygczsbw"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/golang/groupcache/lru"
- #:unpack-path "github.com/golang/groupcache"))
- (synopsis "Groupcache is a caching and cache-filling library")
- (description "Groupcache is a caching and cache-filling library, intended
-as a replacement for memcached in many cases. It provides a data loading
-mechanism with caching and de-duplication that works across a set of peer
-processes.")
- (home-page "https://github.com/golang/groupcache")
- (license asl2.0))))
-
-(define-public go-github-com-golang-snappy
- (let ((commit "553a641470496b2327abcac10b36396bd98e45c9")
- (revision "0"))
- (package
- (name "go-github-com-golang-snappy")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/golang/snappy")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0kssxnih1l722hx9219c7javganjqkqhvl3i0hp0hif6xm6chvqk"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/golang/snappy"))
- (synopsis "Snappy compression format in the Go programming language")
- (description "This package provides a Go implementation of the Snappy
-compression format.")
- (home-page "https://github.com/golang/snappy")
- (license bsd-3))))
-
-(define-public go-github-com-jackpal-gateway
- (package
- (name "go-github-com-jackpal-gateway")
- (version "1.0.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jackpal/gateway")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1yms2dw4dnz4cvj9vhwh6193d50jhvn5awsp2g3a4lcc3sjrgd6m"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/jackpal/gateway"))
- (synopsis "Discover the address of a LAN gateway")
- (description "@code{gateway} is a Go library for discovering the IP
-address of the default LAN gateway.")
- (home-page "https://github.com/jackpal/gateway")
- (license bsd-3)))
-
-(define-public go-github-com-lib-pq
- (package
- (name "go-github-com-lib-pq")
- (version "1.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lib/pq")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "08j1smm6rassdssdks4yh9aspa1dv1g5nvwimmknspvhx8a7waqz"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/lib/pq"
- ;; The tests seem to fail without access to the network or a running
- ;; Postgres instance.
- #:tests? #f))
- (synopsis "Golang Postgres driver for Go's database/sql")
- (description "This package provides a pure Go Postgres driver for Go's
-database/sql package.")
- (home-page "https://github.com/lib/pq")
- (license expat)))
-
-(define-public go-github-com-oschwald-geoip2-golang
- (package
- (name "go-github-com-oschwald-geoip2-golang")
- (version "1.4.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/oschwald/geoip2-golang")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1jj4rbdpy87rbl79czg5hs5dyn6xlbnk0bnvyzi71dsxan57nixw"))))
- (build-system go-build-system)
- (propagated-inputs
- `(("go-github-com-oschwald-maxminddb-golang"
- ,go-github-com-oschwald-maxminddb-golang)
- ("go-golang-org-x-sys" ,go-golang-org-x-sys)))
- (arguments
- `(#:import-path "github.com/oschwald/geoip2-golang"
- #:tests? #f)) ; Requires some unpackaged software and test data
- (synopsis "MaxMind GeoIP2 reader")
- (description "This package provides a library for reading MaxMind
-GeoLite2 and GeoIP2 databases in Go.")
-
This message was truncated. Download the full message here.