[PATCH] gnu: rpm: Update to 4.16.1.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Brielmaier
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 4 years ago
(address . guix-patches@gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20201227165826.7375-1-vincent.legoll@gmail.com
* gnu/packages/package-management.scm (rpm): Update to 4.16.1.2.
(inputs): Add libgcrypt.
---
gnu/packages/package-management.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (40 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 6b0d3493d0..20a331f391 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -680,7 +681,7 @@ features of Stow with some extensions.")
(define-public rpm
(package
(name "rpm")
- (version "4.14.2.1")
+ (version "4.16.1.2")
(source (origin
(method url-fetch)
(uri (string-append "http://ftp.rpm.org/releases/rpm-"
@@ -688,7 +689,7 @@ features of Stow with some extensions.")
version ".tar.bz2"))
(sha256
(base32
- "1nmck2fq9h85fgs3zhh6w1avlw5y16cbz5khd459ry3jfd5w4f8i"))))
+ "1k6ank2aad7r503w12m6m494mxr6iccj52wqhwbc94pwxsf34mw3"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-external-db" ;use the system's bdb
@@ -712,6 +713,7 @@ features of Stow with some extensions.")
("nss" ,nss)
("nspr" ,nspr)
("libarchive" ,libarchive)
+ ("libgcrypt" ,libgcrypt)
("file" ,file)
("bzip2" ,bzip2)
("zlib" ,zlib)
--
2.29.2
Jonathan Brielmaier wrote 4 years ago
d73228a8-5b57-f609-0694-b44d09ac664f@web.de
Pushed as 81b53caf2af37d51bb0b2f99f30938db9ba2e729.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45471@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45471
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help