[PATCH] gnu: redis: Update to 6.0.9.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 4 years ago
(address . guix-patches@gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20201227164945.10190-1-vincent.legoll@gmail.com
* gnu/packages/databases.scm (redis): Update to 6.0.9.
---
gnu/packages/databases.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d60fdfff17..327834ca73 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2129,14 +2129,14 @@ similar to BerkeleyDB, LevelDB, etc.")
(define-public redis
(package
(name "redis")
- (version "5.0.7")
+ (version "6.0.9")
(source (origin
(method url-fetch)
(uri (string-append "http://download.redis.io/releases/redis-"
version".tar.gz"))
(sha256
(base32
- "0ax8sf3vw0yadr41kzc04917scrg5wir1d94zmbz00b8pzm79nv1"))))
+ "1pc6gyiylrcazlc559dp5mxqj733pk9qabnirw4ry3k23kwdqayw"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; tests related to master/slave and replication fail
--
2.29.2
Efraim Flashner wrote 4 years ago
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 45470@debbugs.gnu.org)
X+n9efaHt3Ujcgkj@3900XT
I see there are a number of bundled libraries, included jemalloc,
linenoise and lua. Can we unbundle them? And is there some subset of the
tests we can run?

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl/p/XkACgkQQarn3Mo9
g1GykA/+NHC8TqCXt8LG4+L+eWI1CZceGesDxTUg8CPe8dNcxv2PTJEXo1CCFpGh
b6kHOy1l54ulBVvhQFTX392BfU4PALWSy02Bc3DfXzR1RFJu5qhOtWeKW+kIyx9m
CVyIwFJg4flhKwqqdZvn4Bs9HSJtz4/N3QOJM/pFsrt/T7MDggOY0ftTZ11RFJGK
qvld0hi1XnVHK7qe77Hd9TdgQhFzun4iAN/f3IlH416tAhMk1hkZ2QXf/RilrLYA
/EQPkx5acW7UVChev6Bz3fjJ+uH6X5hMpMN+WzccfKDTZnQT0dgUL4O5K393HHNe
8uheDwBvL3Ps0tiomt8KvZRo9YDPAu5WhljcF0fh9PIznvzlnMh+SmwF5LtYP2Y3
Nz0ogRrrR2SVX7NLOolfP5zvnRjZNZfYcAoqgmUhGLB7PhoKG+oqHvQT458+2Db7
AWyx37RpwkuuvFo1WZQmFd/qBp3TYa6hiSo5gof68NtJOTJ5Bgwlin92ao4aB7pI
ASBsl1xSXGIOZHYg9Ir5hfLjRNtCYhDbnJcYMZKzNezBWKcDJ4kolU5qTM6StMOm
2kMMRwQpZG6delgA0VFtL48ZrUzsn1xBWar+hQC8zacughAPKOt4HzymHo0zIqOx
wGqBgDNwjc7zJVLwsCrWpRmi0g6XvEh7kvMjKHolmMgeHgTy52w=
=MZeH
-----END PGP SIGNATURE-----


Vincent Legoll wrote 4 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 45470@debbugs.gnu.org)
CAEwRq=ro67AGxhSS9q8qeBz2YA5-Wuxh58pFLHy0H7YOXDfAvQ@mail.gmail.com
On Mon, Dec 28, 2020 at 4:45 PM Efraim Flashner <efraim@flashner.co.il> wrote:
Toggle quote (4 lines)
> I see there are a number of bundled libraries, included jemalloc,
> linenoise and lua. Can we unbundle them? And is there some subset of the
> tests we can run?

I'll have a look

--
Vincent Legoll
Vincent Legoll wrote 4 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 45470@debbugs.gnu.org)
CAEwRq=o0Jk5tMPmz+KqudsK9Q1tju=MDk1g611xdM4ujrNQezg@mail.gmail.com
On Mon, Dec 28, 2020 at 4:47 PM Vincent Legoll <vincent.legoll@gmail.com> wrote:
Toggle quote (6 lines)
> > I see there are a number of bundled libraries, included jemalloc,
> > linenoise and lua. Can we unbundle them? And is there some subset of the
> > tests we can run?
>
> I'll have a look

The jemalloc can already be deleted as it is not used (libc malloc is).

The testsuite can be run succesfully minus the 4 ones that I disabled.

Lua is really entangled in the Makefile.

I tried to use guix's linenoise, but wasn't able to make it build.

Hiredis should be updated carefully, so I'll let redis people handle
that.

Updated patchset following...

--
Vincent Legoll
Vincent Legoll wrote 4 years ago
[PATCH 1/2] gnu: redis: Update to 6.0.9.
(address . 45470@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20201228184525.21537-1-vincent.legoll@gmail.com
* gnu/packages/databases.scm (redis): Update to 6.0.9.
---
gnu/packages/databases.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index d60fdfff17..919ec160e7 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -45,6 +45,7 @@
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2129,14 +2130,14 @@ similar to BerkeleyDB, LevelDB, etc.")
(define-public redis
(package
(name "redis")
- (version "5.0.7")
+ (version "6.0.9")
(source (origin
(method url-fetch)
(uri (string-append "http://download.redis.io/releases/redis-"
version".tar.gz"))
(sha256
(base32
- "0ax8sf3vw0yadr41kzc04917scrg5wir1d94zmbz00b8pzm79nv1"))))
+ "1pc6gyiylrcazlc559dp5mxqj733pk9qabnirw4ry3k23kwdqayw"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; tests related to master/slave and replication fail
--
2.29.2
Vincent Legoll wrote 4 years ago
[PATCH 2/2] gnu: redis: Unbundle jemalloc & reinstate most of the tests
(address . 45470@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20201228184525.21537-2-vincent.legoll@gmail.com
* gnu/packages/databases.scm (redis)[source]: Delete bundled jemalloc.
[native-inputs]: Add procps & tcl for the tests. [arguments]: substitute
the right tclsh binary & disable failing tests.
---
gnu/packages/databases.scm | 26 ++++++++++++++++++++++----
1 file changed, 22 insertions(+), 4 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 919ec160e7..a58b4189f8 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2137,12 +2137,30 @@ similar to BerkeleyDB, LevelDB, etc.")
version".tar.gz"))
(sha256
(base32
- "1pc6gyiylrcazlc559dp5mxqj733pk9qabnirw4ry3k23kwdqayw"))))
+ "1pc6gyiylrcazlc559dp5mxqj733pk9qabnirw4ry3k23kwdqayw"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Delete bundled jemalloc, as the package will use the libc one
+ '(begin (delete-file-recursively "deps/jemalloc")
+ #t))))
(build-system gnu-build-system)
+ (native-inputs `(("procps" ,procps) ; for tests
+ ("tcl" ,tcl))) ; for tests
(arguments
- '(#:tests? #f ; tests related to master/slave and replication fail
- #:phases (modify-phases %standard-phases
- (delete 'configure))
+ '(#:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'tclsh
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "runtest"
+ (("^TCLSH=.*")
+ (string-append "TCLSH="
+ (assoc-ref inputs "tcl") "/bin/tclsh")))
+ ; Disable failing tests
+ (substitute* "tests/test_helper.tcl"
+ ((" integration/replication[^-]") "")
+ ((" integration/replication-4") "")
+ ((" integration/replication-psync") ""))
+ #t)))
#:make-flags `("CC=gcc"
"MALLOC=libc"
"LDFLAGS=-ldl"
--
2.29.2
Efraim Flashner wrote 4 years ago
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 45470-done@debbugs.gnu.org)
X+rvQyWClJickrmK@3900XT
Looks great. Patches pushed!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl/q70MACgkQQarn3Mo9
g1G6TxAApImduCAK9aXD43iC2eUODptoH7tJzI3cf8YlXUZsbFw0ASXvoa7hUo8H
0S+Sq1s75YJj8OPLsDIGyVHwXJTI6qqVkOcQNNqs3g1XIuaLFjUihMPMfs+d8ygw
hGyu3nVKfhb5mMtiIhLz81ZkF7oe2fLLJ9WAk58W5VHGzuG7PoOCHcIofQYIeVQU
qqy/Nh0iTyoASS4zhmwyOo9QVJaWYLR/cCGKsVE4RVoQ6oR8gUPr88TLQluEpvAd
Y+Cv95xUBnojRZagggjeXqTDNWpA0yYV1YXYmA1bj/xuAEVwr14wXPYXKHfEaYm2
K5SGLQ2dxPyDRupZ1Ozol7ZeXRpf2y9uRpHWBb7/U00bfIlo3zHybQBKVZY5fq+W
1RqMcrzAyTO75RXGqEejauZa52HcyKNSruD86hGCjV08uereQNLS/xAzG2MXQkNf
cYpiGizX/HkrXBlHGwFtS4rX35bh4++it7mETS49WBOADdOQIDCtq9Hu1TuxtoVQ
y2nDhQT68u8eE9RLbNpMleGtnLc+T8ZNu4YwBVVWRKK5tWsDhV0CMamy5l8YHhf/
uKOJv62Pt5rShWUrjC48Yux/VMw5tWiomeVCuMH/HaThpyf1Rj367X0A/JZNI1B/
GfjUcLJw3mixDCuNsLjgojcmjGr3cVo/w0EBoQw1RZWNwt1IW1M=
=Qetw
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45470@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45470
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help