(address . bug-guix@gnu.org)
I update Guix yesterday and org-mode doesn't load anymore.
The debug trace is this:
Debugger entered--Lisp error: (error "Invalid version syntax: ‘’ (must
start with a number)")
signal(error ("Invalid version syntax: ‘’ (must start with a number)"))
error("Invalid version syntax: `%s' (must start with a number)" "")
version-to-list("")
version<("" "9.0")
#f(compiled-function () #<bytecode 0x5c3b49>)()
funcall(#f(compiled-function () #<bytecode 0x5c3b49>))
(lambda nil (funcall '#f(compiled-function () #<bytecode 0x5c3b49>)))()
eval-after-load-helper("/home/marinus/.guix-profile/share/emacs/site-lisp/org.elc")
run-hook-with-args(eval-after-load-helper
"/home/marinus/.guix-profile/share/emacs/site-lisp/org.elc")
do-after-load-evaluation("/home/marinus/.guix-profile/share/emacs/site-lisp/org.elc")
require(org)
byte-code("\300\301!\210\300\302!\210\300\303!\210\300\304!\210\300\305!\210\300\306!\210\307\310\311\312\313\314%\210\315\316\317\320\313\310\321\322&\7\210\315\323\324\325\313\310\321..."
[require elfeed org dash s cl-lib xml custom-declare-group elfeed-org
nil "Configure the Elfeed RSS reader with an Orgmode fi..." :group comm
custom-declare-variable rmh-elfeed-org-tree-id "elfeed" "The tag or ID
property on the trees containing the..." :type string
rmh-elfeed-org-ignore-tag "ignore" "The tag on the feed trees that will
be ignored." rmh-elfeed-org-auto-ignore-invalid-feeds "Tag feeds to
ignore them when a feed could not loa..." bool rmh-elfeed-org-files
(list "~/.emacs.d/elfeed.org") "The files where we look to find trees
with the `rm..." (repeat (file :tag "org-mode file"))] 8)
require(elfeed-org)
eval-buffer(#<buffer *load*> nil "/home/marinus/.emacs" nil t) ;
Reading at buffer position 39
load-with-code-conversion("/home/marinus/.emacs"
"/home/marinus/.emacs" t t)
load("~/.emacs" noerror nomessage)
startup--load-user-init-file(#f(compiled-function () #<bytecode
0x5c3f71>) #f(compiled-function () #<bytecode 0x5c3f85>) t)
command-line()
normal-top-level()
Everytime I try to open a org file I get the same error. I noticed that
after I removed the elfeed-org requirement to see if that was the problem.
Emacs commit is this:
/gnu/store/lhw3zwhzra0w5l8a4jw8fvm58i75xyl8-emacs-27.1
Guix System config is this:
Generation 15 Dec 26 2020 15:25:17 (current)
guix 4969b51
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: 4969b51d175497bfcc354c91803e9d70542b7113
My .emacs file has nothing besides this:
;;Elfeed config
(require 'elfeed-org)
(setq rmh-elfeed-org-files (list "~/.emacs.d/elfeed.org"))
Marinus