[PATCH 0/1] Merry Ruby release day!

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Ryan Prior
Owner
unassigned
Submitted by
Ryan Prior
Severity
normal

Debbugs page

Ryan Prior wrote 4 years ago
(address . guix-patches@gnu.org)
20201225175346.20798-1-rprior@protonmail.com
Hi Guix! Hope you're all staying warm and jolly. Ruby made its big 3.0 release today, and as a special gift to us, it inherits the exact same build system from Ruby 2.7. Enjoy the weekend and happy hacking!

Ryan Prior (1):
gnu: ruby: Add 3.0.

gnu/packages/ruby.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

--
2.29.2
Ryan Prior wrote 4 years ago
[PATCH 1/1] gnu: ruby: Add 3.0.
(address . 45434@debbugs.gnu.org)
20201225175712.21090-1-rprior@protonmail.com
* gnu/packages/ruby.scm (ruby): Add 3.0.
---
gnu/packages/ruby.scm | 14 ++++++++++++++
1 file changed, 14 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1befecfa12..971b2b2d77 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -187,6 +187,20 @@ a focus on simplicity and productivity.")
(native-inputs
`(("autoconf" ,autoconf)))))
+(define-public ruby-3.0
+ (package
+ (inherit ruby-2.7)
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
+ (version-major+minor version)
+ "/ruby-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1cbcixwnr0y8q0lg67wjgplp06kjd6p6hjjh680csv3v0bpsxgv8"))))))
+
(define-public ruby-2.5
(package
(inherit ruby)
--
2.29.2
Christopher Baines wrote 4 years ago
(name . Ryan Prior)(address . rprior@protonmail.com)(address . 45434-done@debbugs.gnu.org)
87mtxwa1gg.fsf@cbaines.net
Ryan Prior via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (31 lines)
> * gnu/packages/ruby.scm (ruby): Add 3.0.
> ---
> gnu/packages/ruby.scm | 14 ++++++++++++++
> 1 file changed, 14 insertions(+)
>
> diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
> index 1befecfa12..971b2b2d77 100644
> --- a/gnu/packages/ruby.scm
> +++ b/gnu/packages/ruby.scm
> @@ -187,6 +187,20 @@ a focus on simplicity and productivity.")
> (native-inputs
> `(("autoconf" ,autoconf)))))
>
> +(define-public ruby-3.0
> + (package
> + (inherit ruby-2.7)
> + (version "3.0.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
> + (version-major+minor version)
> + "/ruby-" version ".tar.xz"))
> + (sha256
> + (base32
> + "1cbcixwnr0y8q0lg67wjgplp06kjd6p6hjjh680csv3v0bpsxgv8"))))))
> +
> (define-public ruby-2.5
> (package
> (inherit ruby)

Thanks, I've tweaked the commit message, and pushed to master as
03c51c04430405fe405a3640e6a4d1d248b702fc.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/rex9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfWRQ/+MAH1yxDwBQoRx93E1ZzvpbPvo2dlULtY
xwTW3H9sZgUEnQy97fD4OOEBNAV5OmkTNLsbaYMXKODCNl9pGKLMjDAhqzxD88zL
anRyaGZJZKpkyY6UY7lT9IIUb0d5NirToEnReq7HI8YjNVXfTMuhA1vnXV7WY7lW
+K48gXF4msotyeVZ4JRgq/jRGWInAX+VYG/mSONqhJqn+Z/iGCjQnRmTKipS/gWT
5yXYB2udt91LnCRKVDsQz8YvzQnWb/wVotyE8NZ0JUe6HrAi5rDjLwq+F7eM5G8S
YY1r8CdKYzOxsmMMxDa3rV5ABb0M4qOud+md9kaMTziDEWwp1KdNfqxPcBxUqW3Z
2bsjB/lgXAOS+mA1UkX7nUSGQnbY985PNPl/rOxOh6+OoN87yv9OV1OzKx1bbO6J
Wd1g5BXSyzCOOL5hBlpA89p6x2YoKGGPMcRj/UrzlGCTKUa9Wrquuz3yjSlXB9/w
3DnPQTO5VaMBKTEygEqrSjwK2RkO8C+B348xZiXBXVYnl1tLfar7+C1LoDPk1Ed/
aIF+M3OMvnYCyPaCfTK84FJOafwy1MpUOiVyuTMoUDygLOJ4EAs8kl6nD+lSl9s4
ejdfrtyd4CJfGHzmF2YCN4H+zassYjZovZw16p6MzvF+J5MV1wxF37snKQlrCVUW
zIlaRPl6H48=
=Puhx
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45434@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45434
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help