[PATCH] gnu: kiwix-desktop: Fix program start.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201225163614.17984-1-mike@rohleder.de

* gnu/packages/web.scm (kiwix-desktop)[arguments]: Add phase to wrap
QTWEBENGINEPROCESS_PATH.
---
gnu/packages/web.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8d7dfe2804..7486eb7f5b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7981,7 +7981,17 @@ It contains the code shared by all Kiwix ports.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "kiwix-desktop.pro"
(("webenginewidgets" all) (string-append all " printsupport")))
- #t)))))
+ #t))
+ (add-after 'install 'wrap-qt-process-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/kiwix-desktop"))
+ (qt-process-path (string-append
+ (assoc-ref inputs "qtwebengine")
+ "/lib/qt5/libexec/QtWebEngineProcess")))
+ (wrap-program bin
+ `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
+ #t))))))
(inputs
`(("curl" ,curl)
("icu4c" ,icu4c)
--
2.29.2
Leo Prikler wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)
3815859d39110ee91c1938482e18415645cfacc8.camel@student.tugraz.at
Pushed, thanks!

Small hint, if you want to use pure environments, don't forget
to expose environment variables such as DISPLAY and XAUTHORITY.

Regards,
Leo

Am Freitag, den 25.12.2020, 17:36 +0100 schrieb Michael Rohleder:
Toggle quote (35 lines)
>
> * gnu/packages/web.scm (kiwix-desktop)[arguments]: Add phase to wrap
> QTWEBENGINEPROCESS_PATH.
> ---
> gnu/packages/web.scm | 12 +++++++++++-
> 1 file changed, 11 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index 8d7dfe2804..7486eb7f5b 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -7981,7 +7981,17 @@ It contains the code shared by all Kiwix
> ports.")
> (lambda* (#:key inputs #:allow-other-keys)
> (substitute* "kiwix-desktop.pro"
> (("webenginewidgets" all) (string-append all "
> printsupport")))
> - #t)))))
> + #t))
> + (add-after 'install 'wrap-qt-process-path
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (bin (string-append out "/bin/kiwix-desktop"))
> + (qt-process-path (string-append
> + (assoc-ref inputs
> "qtwebengine")
> + "/lib/qt5/libexec/QtWebEngineP
> rocess")))
> + (wrap-program bin
> + `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
> + #t))))))
> (inputs
> `(("curl" ,curl)
> ("icu4c" ,icu4c)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45431@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45431
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help