(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
Fixes https://bugs.gnu.org/45404.
* gnu/packages/web.scm (kiwix-desktop)[arguments]: Add phase to wrap
QTWEBENGINEPROCESS_PATH.
---
gnu/packages/web.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)
Toggle diff (25 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 8d7dfe2804..7486eb7f5b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7981,7 +7981,17 @@ It contains the code shared by all Kiwix ports.")
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "kiwix-desktop.pro"
(("webenginewidgets" all) (string-append all " printsupport")))
- #t)))))
+ #t))
+ (add-after 'install 'wrap-qt-process-path
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin/kiwix-desktop"))
+ (qt-process-path (string-append
+ (assoc-ref inputs "qtwebengine")
+ "/lib/qt5/libexec/QtWebEngineProcess")))
+ (wrap-program bin
+ `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
+ #t))))))
(inputs
`(("curl" ,curl)
("icu4c" ,icu4c)
--
2.29.2