ZFS package not compiling on recent kernel

  • Open
  • quality assurance status badge
Details
One participant
  • raid5atemyhomework
Owner
unassigned
Submitted by
raid5atemyhomework
Severity
normal
R
R
raid5atemyhomework wrote on 24 Dec 2020 01:53
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
jtYDKvkF5nsDoYCHggN-Is9lOA1_iOiCLpfNZ5NWdXt7Yd6Wq8qrA6EqzXE6P-1EFFqekIHxJSXtIOytr9IVB4CbLO759dyZvZ-OJH-v-z4=@protonmail.com
Installing `zfs` results in the following errors:

```
In file included from /tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/include/sys/dmu.h:848:0,
from /tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/include/sys/spa.h:44,
from /tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/include/sys/spa_impl.h:35,
from /tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/module/zfs/vdev_disk.c:30:
/tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/module/zfs/vdev_disk.c: In function 'vdev_disk_open':
/tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/include/linux/blkdev_compat.h:378:37: error: implicit declaration of function 'check_disk_change'; did you mean 'bdev_disk_changed'? [-Werror=implicit-function-declaration]
#define vdev_bdev_reread_part(bdev) check_disk_change(bdev)
^
/tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/module/zfs/vdev_disk.c:218:17: note: in expansion of macro 'vdev_bdev_reread_part'
int error = vdev_bdev_reread_part(bdev);
^~~~~~~~~~~~~~~~~~~~~
/tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/module/zfs/vdev_disk.c: In function 'vdev_blkg_tryget':
/tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/module/zfs/vdev_disk.c:506:37: error: 'struct percpu_ref' has no member named 'count'
rc = atomic_long_inc_not_zero(&ref->count);
^~
cc1: some warnings being treated as errors
```

This is using kernel 5.10.2 I believe:

```
linux-libre-5.10.2 76.4MiB

linux-libre-module-builder-5.10.2 17.4MiB
```
R
R
raid5atemyhomework wrote on 24 Dec 2020 02:34
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
_C8q2iRFNa-JKQdaUkYYEfcMWR9ykyfSHWqEON86VKmfDNgLQnouWUsZaslh_SjbiYqARjJCj2vgx_YpO8iRMvgf3qnI2W4lx3X7X6h_THE=@protonmail.com
Looking at recent zfs release note: https://github.com/openzfs/zfs/releases/tag/zfs-0.8.5and https://github.com/openzfs/zfs/releases/tag/zfs-0.8.6

Toggle quote (2 lines)
> * Compatible with 2.6.32 - 5.9 Linux kernels

zfs-0.8.6 includes a few "Linux 5.10 compat" but is still not rated for 5.10.

Would it be possible to fix this by adding `#:linux ,linux-libre-5.9` to the `arguments` field of the `zfs` package?

Of course, it does require that we use a specific linux version.
R
R
raid5atemyhomework wrote on 24 Dec 2020 02:36
ZFS package not compiling on recent kernel
(name . 45401@debbugs.gnu.org)(address . 45401@debbugs.gnu.org)
S7qCynUGkczVR22TlFwGRs0F022fPHTWucfZz5ngqj5nGVZYHZLvaCU2LhGRdd1XFSvtSY0UGGMCKUueeBeVFfs5NeRL1g_wJTYU3WTIw_o=@protonmail.com
Looking at recent zfs release note: https://github.com/openzfs/zfs/releases/tag/zfs-0.8.5and https://github.com/openzfs/zfs/releases/tag/zfs-0.8.6

Toggle quote (2 lines)
> * Compatible with 2.6.32 - 5.9 Linux kernels

zfs-0.8.6 includes a few "Linux 5.10 compat" but is still not rated for 5.10.

Would it be possible to fix this by adding `#:linux ,linux-libre-5.9` to the `arguments` field of the `zfs` package?

Of course, it does require that we use a specific linux version.
?