(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
Installing `zfs` results in the following errors:
```
In file included from /tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/include/sys/dmu.h:848:0,
from /tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/include/sys/spa.h:44,
from /tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/include/sys/spa_impl.h:35,
from /tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/module/zfs/vdev_disk.c:30:
/tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/module/zfs/vdev_disk.c: In function 'vdev_disk_open':
/tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/include/linux/blkdev_compat.h:378:37: error: implicit declaration of function 'check_disk_change'; did you mean 'bdev_disk_changed'? [-Werror=implicit-function-declaration]
#define vdev_bdev_reread_part(bdev) check_disk_change(bdev)
^
/tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/module/zfs/vdev_disk.c:218:17: note: in expansion of macro 'vdev_bdev_reread_part'
int error = vdev_bdev_reread_part(bdev);
^~~~~~~~~~~~~~~~~~~~~
/tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/module/zfs/vdev_disk.c: In function 'vdev_blkg_tryget':
/tmp/guix-build-zfs-0.8.5.drv-0/zfs-0.8.5/module/zfs/vdev_disk.c:506:37: error: 'struct percpu_ref' has no member named 'count'
rc = atomic_long_inc_not_zero(&ref->count);
^~
cc1: some warnings being treated as errors
```
This is using kernel 5.10.2 I believe:
```
downloading from https://ci.guix.gnu.org/nar/lzip/si6ly6im9ih9fpycp5zq1895y2jl4kzm-linux-libre-5.10.2...
linux-libre-5.10.2 76.4MiB
downloading from https://ci.guix.gnu.org/nar/lzip/gw4nybiqbfg7mayvykvrk4vd7jf2liyx-linux-libre-module-builder-5.10.2...
linux-libre-module-builder-5.10.2 17.4MiB
```