[PATCH 0/2] xfsprogs 5.10.0 & libinih

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal

Debbugs page

Vincent Legoll wrote 4 years ago
(name . Guix Patches)(address . guix-patches@gnu.org)
CAEwRq=pXW1vEUGMLsKKDdmXSP-dbR6z_h_Yb9Y61gb0x85WwPw@mail.gmail.com
Hello,

the new xfsprogs version now requires the
inih parser library.

The first patch add that new package and
the second one updates xfsprogs with it.

Please review, as this is my first contact
with the meson build system.

Also the license file contains "new BSD", so
I chose "bsd-4"...

Tchuss

--
Vincent Legoll
Vincent Legoll wrote 4 years ago
[PATCH 2/2] gnu: xfsprogs: Update to 5.10.0.
(address . 45398@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20201223171426.9048-2-vincent.legoll@gmail.com
* gnu/packages/linux.scm (xfsprogs): Update to 5.10.0.
(inputs): Add libinih.
---
gnu/packages/linux.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d177f93502..b260359808 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7028,7 +7028,7 @@ compatible with Python's ConfigParser style of .INI files, including RFC
(define-public xfsprogs
(package
(name "xfsprogs")
- (version "5.9.0")
+ (version "5.10.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -7036,7 +7036,7 @@ compatible with Python's ConfigParser style of .INI files, including RFC
"xfsprogs-" version ".tar.gz"))
(sha256
(base32
- "13xkn9jpmwp4fm9r68vhgznkmxhnv83n2b39mhy2qdaph90w2a1l"))))
+ "1wcvcv9fl955g3zl68057hq7pp9bm7i733vc7j6xr6wnfd8qf6sr"))))
(build-system gnu-build-system)
(outputs (list "out" "python"))
(arguments
@@ -7060,7 +7060,8 @@ compatible with Python's ConfigParser style of .INI files, including RFC
(native-inputs
`(("gettext" ,gettext-minimal)))
(inputs
- `(("libuuid" ,util-linux "lib")
+ `(("libinih" ,libinih)
+ ("libuuid" ,util-linux "lib")
("python" ,python-wrapper)))
(home-page "https://xfs.wiki.kernel.org/")
(synopsis "XFS file system tools")
--
2.29.2
Vincent Legoll wrote 4 years ago
[PATCH 1/2] gnu: Add libinih.
(address . 45398@debbugs.gnu.org)(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20201223171426.9048-1-vincent.legoll@gmail.com
* gnu/packages/linux.scm (libinih): New variable.
---
gnu/packages/linux.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 01f12f77d9..d177f93502 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7000,6 +7000,31 @@ communicate with the kernel. It can be used to add and remove interfaces, set
IP addresses and routes, and configure IPsec.")
(license license:asl2.0)))
+(define-public libinih
+ (package
+ (name "libinih")
+ (version "52")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/benhoyt/inih")
+ (commit (string-append "r" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lsvm34zabvi1xlximybzvgc58zb90mm3b9babwxlqs05jy871m4"))))
+ (build-system meson-build-system)
+ (arguments
+ '(#:configure-flags '("-Ddistro_install=true" "-Ddefault_library=shared")))
+ (home-page "https://github.com/benhoyt/inih")
+ (synopsis "Simple .INI parser library for C")
+ (description "The inih (INI Not Invented Here) library is a simple .INI file
+parser written in C. It's only a couple of pages of code, and it was designed to
+be small and simple, so it's good for embedded systems. It's also more or less
+compatible with Python's ConfigParser style of .INI files, including RFC
+822-style multi-line syntax and name: value entries.")
+ (license license:bsd-4)))
+
(define-public xfsprogs
(package
(name "xfsprogs")
--
2.29.2
Leo Famulari wrote 4 years ago
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 45398-done@debbugs.gnu.org)
X+T4CDnlouoVZNUk@jasmine.lan
On Wed, Dec 23, 2020 at 06:14:25PM +0100, Vincent Legoll wrote:
Toggle quote (2 lines)
> * gnu/packages/linux.scm (libinih): New variable.

Thanks!

Toggle quote (7 lines)
> + (description "The inih (INI Not Invented Here) library is a simple .INI file
> +parser written in C. It's only a couple of pages of code, and it was designed to
> +be small and simple, so it's good for embedded systems. It's also more or less
> +compatible with Python's ConfigParser style of .INI files, including RFC
> +822-style multi-line syntax and name: value entries.")
> + (license license:bsd-4)))

I fixed the issues reported by `guix lint`, corrected the license to
bsd-3, and pushed both patches 9325171df468f6a84ac7cdab01f0c6461ff1c7bc
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45398@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45398
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help