[PATCH] gnu: bitcoin-unlimited: Fix time specific test failure.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
20201223104510.24217-1-mail@cbaines.net
* gnu/packages/finance.scm (bitcoin-unlimited)[arguments]: Patch test to fix
time specific failure.
---
gnu/packages/finance.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index c7a606f3b2..3f1ecb40f1 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1469,6 +1469,12 @@ entity management.")
(modify-phases %standard-phases
(add-after 'unpack 'fix-tests
(lambda _
+ ;; Fix data specific test failure
+ ;; https://reviews.bitcoinabc.org/
+ ;; rABC67bbd3d0aaee2952ff1cb5da51d1fd0b50c2b63a
+ (substitute* "src/test/rpc_tests.cpp"
+ (("1607731200") "9907731200"))
+
;; Disable utilprocess_tests because it never ends.
;; It looks like it tries to start /bin/sleep and waits until it
;; is in the list of running processes, but /bin/sleep doesn't
--
2.29.2
Mathieu Othacehe wrote 4 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 45391@debbugs.gnu.org)
8735zn7eiq.fsf@gnu.org
Hey Chris,

Toggle quote (6 lines)
> + ;; Fix data specific test failure
> + ;; https://reviews.bitcoinabc.org/
> + ;; rABC67bbd3d0aaee2952ff1cb5da51d1fd0b50c2b63a
> + (substitute* "src/test/rpc_tests.cpp"
> + (("1607731200") "9907731200"))

I think you should keep the URL on one single line, otherwise looks
fine!

Thanks,

Mathieu
Christopher Baines wrote 4 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 45391-done@debbugs.gnu.org)
87tus191ss.fsf@cbaines.net
Mathieu Othacehe <othacehe@gnu.org> writes:

Toggle quote (11 lines)
> Hey Chris,
>
>> + ;; Fix data specific test failure
>> + ;; https://reviews.bitcoinabc.org/
>> + ;; rABC67bbd3d0aaee2952ff1cb5da51d1fd0b50c2b63a
>> + (substitute* "src/test/rpc_tests.cpp"
>> + (("1607731200") "9907731200"))
>
> I think you should keep the URL on one single line, otherwise looks
> fine!

Thanks, I've pushed as 94803ec345a1f83ce6fdc446452cb887a7a302a7.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/uL6NfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcQIw/9EHPutxn7gxoShvnkswktH0NAnl8OBCR2
dxHx4EIJIxWhYbRBKzrjCr1oWvJpzPvAMY6X4R/jFVrFoRFlEJ6Vq7fMwoKNx+Dy
Lz0PlmS0Fgj4001HmluTsGRrv8fT4FWpFi5Fqfjd/Baxqem/4owK4Nym++/Hl3zv
Fi9mCSYgFpKsLGTclXhIDYBUxYGiJt8tl5YoYpTBRKJVqAFkKTUiEoBsi8Xt2HLw
mKVL9sE6Ikx6O3y8R0GtQ+tVDMBMZJYSjT0xCnjXFEgej1gW2DTrjZwihs5qjM9C
inyelQxitqR5FhxEeGk1XYPgrBLEeZeKVgXfYdgCZvOg9SHz/+IGkwy6qlY+c3ss
nQuBVhlFClYzfVOTtuDvDSdz404A4bP0VuVZWx2i9k4XqSwqWOso6IuGiENLaake
OjauCeUElfbtDP+3YqWfoACrT9yF5LWMRKZL4/YNliWlpseDf5zTH9G96Be5jxR9
y4fVQlnJGH5oQasXpBA0BMngTrBbKh7iEp87jKkUiaTeaArr8Z1PhCFnzxthmUZr
sBaWvm/nY5o5tace1j929ovVccp1+rXgkcrGHNd13cnx/+ITZZ051zhQBp1z/g04
RbiS3z46DGUNll5rlm2QG5OAC1nud6K3Y0AmJ1xHYH1BxfW5yF1sE07+HSqQ4dg3
N1I3xX+7Pag=
=oRvU
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45391@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45391
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help