[PATCH] gnu: font-google-roboto: Unzip fonts to a directory.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201218033431.10787-1-mike@rohleder.de
* gnu/packages/fonts.scm (font-google-roboto)[arguments]: Add phase to unpack
to a directory and ignore macosx files.
---
After commit e93ee2547ecec152f9a198ccc338c4329cc69a71 this pkg doesn't contain anything.
The difference to the version before is that the upstream zip file doesn't
contain a subfolder anymore, so this patch unpacks to one (and excludes macosx
files while at it).

Maybe the roboto-hinted.zip is better than unhinted? Idk.

gnu/packages/fonts.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 717656d682..72e97d99ea 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -801,6 +801,15 @@ display all Unicode symbols.")
(sha256
(base32 "0a57f957qy49kildqx2lp2paqk9i8kkayakmrzxh39hhhmqlrxkh"))))
(build-system font-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "unzip" (assoc-ref inputs "source")
+ "-x" "__MACOSX/*"
+ "-d" "roboto-unhinted")
+ #t)))))
(home-page "https://github.com/google/roboto")
(synopsis "The Roboto family of fonts")
(description
--
2.29.2
Michael Rohleder wrote 4 years ago
(address . 45309@debbugs.gnu.org)
877dpfadku.fsf@rohleder.de
Now that commit ec4a9cadcb2b44f86917c3ebb17c903149e42883 has reverted
this problem/bug, I'm not sure if the patch is relevant anymore.

--
GNU Emacs is an old-school C program emulating a 1980s Symbolics
Lisp Machine emulating an old-fashioned Motif-style Xt toolkit
emulating a 1970s text terminal emulating a 1960s teletype.
(Daniel Colascione)
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl/cPcERHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyXgGQgAmTCwOK29D7EVSOQT8Psis5BYtP8LyLkt
3ubhlYGi2g4Ev6flIqHcF9PrUJ9dLbT2zzWMm62rHpCdWC+ei6LSPbD1sqUP+G4y
/DWebqUQg9c29eN4yq5SXuKgcMgmj0+tT4xEOhMgx5mUi+ffHeIeEcVUc29RMZ7G
9/gCi4N4jvuolKSHgtSf01ERfXWGrfmhR5/AOOWMA9HHKIEkK/TaGxeo9OJ92IlJ
LqUm7Op4ZL+DYNnAZoWNgRfy4iQwkoXeVTca2UofXkqWcK+qBCr6h4wG1lAwzjld
L5NjedHJFvfYwHMU8jQqqDgK8f1q1SuBFYhVGuuBkfEMPX/qCt3KQg==
=Uy/2
-----END PGP SIGNATURE-----

Michael Rohleder wrote 4 years ago
control message for bug #45309
(address . control@debbugs.gnu.org)
87eejlnm4r.fsf@rohleder.de
close 45309
quit
Nicolas Goaziou wrote 4 years ago
Re: [bug#45309] [PATCH] gnu: font-google-roboto: Unzip fonts to a directory.
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 45309@debbugs.gnu.org)
87h7nmldrq.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (5 lines)
> After commit e93ee2547ecec152f9a198ccc338c4329cc69a71 this pkg doesn't contain anything.
> The difference to the version before is that the upstream zip file doesn't
> contain a subfolder anymore, so this patch unpacks to one (and excludes macosx
> files while at it).

Oops.

Toggle quote (2 lines)
> Maybe the roboto-hinted.zip is better than unhinted? Idk.

There is no roboto-hinted.zip in release v2.138, only
roboto-unhinted.zip and roboto-android.zip. Maybe the latter would be
a better fit?

WDYT?

Regards,
--
Nicolas Goaziou
Michael Rohleder wrote 4 years ago
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 45309@debbugs.gnu.org)
877doiv6uy.fsf@rohleder.de
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
Toggle quote (8 lines)
>> Maybe the roboto-hinted.zip is better than unhinted? Idk.
>
> There is no roboto-hinted.zip in release v2.138, only
> roboto-unhinted.zip and roboto-android.zip. Maybe the latter would be
> a better fit?
>
> WDYT?

I don't know, but I guess the android.zip has the same unzipping problem
(haven't looked).

With the patch everything should be good, no?

--
The use of COBOL cripples the mind; its teaching should, therefore, be
regarded as a criminal offence.
-- Edsger W. Dijkstra, SIGPLAN Notices, Volume 17, Number 5
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl/9bIURHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyXiWwf/TQEkZf5kQ7WGZhmcCDPdfDLjwzC/J6mu
+eex3beAlY3TKeZAGRcMUHYh7ATbNafDM0nNBmqJ184irKVCk313hRVrSfD8UXMu
mFJx/dryPRTyR6fqINelmyiXChDi5Hu0OgALEx7zxAYXa91UrEx2WdWrdaRY+GzK
qpZkE7RRDLL0L/mhQFE8kijAfylccpapiQDeKBPiZLn+Biokd6Y5GtlWWBhcfBXN
czuwxGiiSjKVCc/+QscO6Sbzo0IZK0wnf6EehFVtCsFa4ba4bnLAfebDQ9SaLiBB
zRFCkc4lZYzis0oJTc54jugRtQU3Phsrr3TVDfaDpVelrdndOzVI2w==
=ahEL
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 45309@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45309
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help