Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/fonts.scm (font-google-roboto)[arguments]: Add phase to unpack
to a directory and ignore macosx files.
---
After commit e93ee2547ecec152f9a198ccc338c4329cc69a71 this pkg doesn't contain anything.
The difference to the version before is that the upstream zip file doesn't
contain a subfolder anymore, so this patch unpacks to one (and excludes macosx
files while at it).
Maybe the roboto-hinted.zip is better than unhinted? Idk.
gnu/packages/fonts.scm | 9 +++++++++
1 file changed, 9 insertions(+)
Toggle diff (22 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 717656d682..72e97d99ea 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -801,6 +801,15 @@ display all Unicode symbols.")
(sha256
(base32 "0a57f957qy49kildqx2lp2paqk9i8kkayakmrzxh39hhhmqlrxkh"))))
(build-system font-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda* (#:key inputs #:allow-other-keys)
+ (invoke "unzip" (assoc-ref inputs "source")
+ "-x" "__MACOSX/*"
+ "-d" "roboto-unhinted")
+ #t)))))
(home-page "https://github.com/google/roboto")
(synopsis "The Roboto family of fonts")
(description
--
2.29.2