Christopher Baines wrote 4 years ago
(address . guix-patches@gnu.org)
If there's no explicit SSL configuration, the perl-mozilla-ca library acts as
a fallback. Including this as an input fixes the use of HTTPS in things that
use perl-lwp-protocol-https, for example get-iplayer.
* gnu/packages/web.scm (perl-lwp-protocol-https)[propagated-inputs]: Uncomment
perl-mozilla-ca.
---
gnu/packages/web.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
Toggle diff (16 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 39820f7572..b4ebcc8846 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3874,8 +3874,7 @@ exists it is used instead.")
(propagated-inputs
`(("perl-io-socket-ssl" ,perl-io-socket-ssl)
("perl-libwww" ,perl-libwww)
- ;; Users should instead make sure SSL_ca_path is set properly.
- ;; ("perl-mozilla-ca" ,perl-mozilla-ca)
+ ("perl-mozilla-ca" ,perl-mozilla-ca)
("perl-net-http" ,perl-net-http)))
(home-page "https://metacpan.org/release/LWP-Protocol-https")
(synopsis "HTTPS support for LWP::UserAgent")
--
2.29.2