[PATCH] gnu: Add ark.

  • Done
  • quality assurance status badge
Details
3 participants
  • Z572
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Z572
Severity
normal
Z
(address . guix-patches@gnu.org)
tencent_BA8F4567A79CB4E4A9166A533995362BEF05@qq.com
Toggle quote (7 lines)
> QWARN : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
> QWARN : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
> FAIL! : ExtractTest::testExtraction(extract all entries from a xar archive with path) Compared values are not the same
> Actual (extractedEntriesCount) : 0
> Expected (expectedExtractedEntriesCount): 6
> Loc: [/tmp/guix-build-ark-20.04.1.drv-0/ark-20.04.1/autotests/kerfuffle/extracttest.cpp(469)]

The tests fail.
Toggle diff (69 lines)
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 2718acac9a..cf0305c355 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -41,6 +41,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages apr)
#:use-module (gnu packages audio)
+ #:use-module (gnu packages backup)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages code)
@@ -79,6 +80,56 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public ark
+ (package
+ (name "ark")
+ (version "20.04.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/ark-" version ".tar.xz"))
+
+ (sha256
+ (base32
+ "0g5bfa1lc7mhrc2ngd4ldf33dpwr7gqrj95kp897pf632wwj23iw"))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:tests? #f
+ #:configure-flags
+ (list "-DBUILD_TESTING=OFF")))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("breeze-icons" ,breeze-icons)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kitemmodels" ,kitemmodels)
+ ("kparts" ,kparts)
+ ("kpty" ,kpty)
+ ("karchive" ,karchive)
+ ("kconfig" ,kconfig)
+ ("kcrash" ,kcrash)
+ ("khtml" ,khtml)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("qtbase" ,qtbase)
+ ("libarchive" ,libarchive)
+ ("libzip" ,libzip)
+ ("p7zip" ,p7zip)
+ ("zip" ,zip)
+ ;; ("unar" ,unar)
+ ("unzip" ,unzip)
+ ("lrzip" ,lrzip)
+ ("lzop" ,lzop)
+ ("zstd" ,zstd)
+ ("zlib" ,zlib)))
+ (home-page "https://apps.kde.org/en/ark")
+ (synopsis "Archiving Tool")
+ (description "Graphical file compression/decompression utility with support
+for multiple formats.")
+ (license license:gpl2+)))
+
(define-public baloo-widgets
(package
(name "baloo-widgets")
L
L
Ludovic Courtès wrote on 21 Dec 2020 16:46
(name . Z572)(address . 873216071@qq.com)(address . 45285@debbugs.gnu.org)
87sg7z5fgz.fsf@gnu.org
Hi,

Z572 <873216071@qq.com> skribis:

Toggle quote (9 lines)
>> QWARN : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
>> QWARN : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
>> FAIL! : ExtractTest::testExtraction(extract all entries from a xar archive with path) Compared values are not the same
>> Actual (extractedEntriesCount) : 0
>> Expected (expectedExtractedEntriesCount): 6
>> Loc: [/tmp/guix-build-ark-20.04.1.drv-0/ark-20.04.1/autotests/kerfuffle/extracttest.cpp(469)]
>
> The tests fail.

What you paste above sounds like there could be a real issue with some
archive formats, which may be a core issue for this archiving tool.

Could you investigate a bit and/or get in touch with upstream to see if
they can provide guidance?

Toggle quote (5 lines)
> + (synopsis "Archiving Tool")
> + (description "Graphical file compression/decompression utility with support
> +for multiple formats.")

Please expound a bit and write pull sentences, as explained at:


Could you send an updated patch once you know more about the issue
evidenced by the test suite?

Thanks in advance!

Ludo’.
Z
Re: bug#45285: [PATCH] gnu: Add ark.
(address . 45285@debbugs.gnu.org)
tencent_766A59D6ED9F980E6539408949ADDDA67306@qq.com
Hi,

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (15 lines)
>>> QWARN : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
>>> QWARN : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
>>> FAIL! : ExtractTest::testExtraction(extract all entries from a xar archive with path) Compared values are not the same
>>> Actual (extractedEntriesCount) : 0
>>> Expected (expectedExtractedEntriesCount): 6
>>> Loc: [/tmp/guix-build-ark-20.04.1.drv-0/ark-20.04.1/autotests/kerfuffle/extracttest.cpp(469)]
>>
>> The tests fail.
>
> What you paste above sounds like there could be a real issue with some
> archive formats, which may be a core issue for this archiving tool.
>
> Could you investigate a bit and/or get in touch with upstream to see if
> they can provide guidance?

I think this is guix libarchive's problem, it doesn't support xar format because it
needs to input OpenSSL, EXPAT, And XML2.
See libarchive-3.4.2.tar.xz!libarchive-3.4.2/configure :

-----+------------------------------------------------------------------------------
L1546| --without-openssl Don't build support for mtree and xar hashes through
L1547| openssl
L1548| --without-xml2 Don't build support for xar through libxml2
L1549| --without-expat Don't build support for xar through expat
-----+------------------------------------------------------------------------------

It's new patch.
Attachment: ark.patch
Z572.
M
M
Maxim Cournoyer wrote on 16 Jul 2021 06:09
(name . Z572)(address . 873216071@qq.com)(address . 45285-done@debbugs.gnu.org)
878s26nblj.fsf_-_@gmail.com
Hello,

Z572 <873216071@qq.com> writes:

Toggle quote (32 lines)
> Hi,
>
> Ludovic Courtès <ludo@gnu.org> skribis:
>
>>>> QWARN : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
>>>> QWARN : ExtractTest::testExtraction(extract all entries from a xar archive with path) ark.libarchive: Could not open the archive: Unrecognized archive format
>>>> FAIL! : ExtractTest::testExtraction(extract all entries from a xar archive with path) Compared values are not the same
>>>> Actual (extractedEntriesCount) : 0
>>>> Expected (expectedExtractedEntriesCount): 6
>>>> Loc: [/tmp/guix-build-ark-20.04.1.drv-0/ark-20.04.1/autotests/kerfuffle/extracttest.cpp(469)]
>>>
>>> The tests fail.
>>
>> What you paste above sounds like there could be a real issue with some
>> archive formats, which may be a core issue for this archiving tool.
>>
>> Could you investigate a bit and/or get in touch with upstream to see if
>> they can provide guidance?
>
> I think this is guix libarchive's problem, it doesn't support xar format because it
> needs to input OpenSSL, EXPAT, And XML2.
> See libarchive-3.4.2.tar.xz!libarchive-3.4.2/configure :
>
> -----+------------------------------------------------------------------------------
> L1546| --without-openssl Don't build support for mtree and xar hashes through
> L1547| openssl
> L1548| --without-xml2 Don't build support for xar through libxml2
> L1549| --without-expat Don't build support for xar through expat
> -----+------------------------------------------------------------------------------
>
> It's new patch.

Thanks for the update!

I've moved it to the (gnu packages kde-utils) module, dropped the
unnecessary lz4 input, moved the propagated inputs to inputs and wrapped
the command line tools using wrap-program in a phase, tested that it
could run and open a tarball, and applied as commit 4094d12df1.

Thank you for the contribution!

Closing.

Maxim
Closed
?