(no subject)

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 4 years ago
(address . guix-patches@gnu.org)
955092cf-b234-26a5-88df-7e7d9911a729@mdc-berlin.de

Mădălin Ionel Patrașcu wrote 4 years ago
[PATCH 1/2] gnu: Add r-kegggraph.
(address . 45282@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20201216220342.3133-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-kegggraph): New variable.
---
gnu/packages/bioconductor.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b4a1af4306..3026d1a496 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9247,3 +9247,29 @@ graph with the mapped data. In addition, @code{r-pathview} also seamlessly
integrates with pathway and gene set (enrichment) analysis tools for
large-scale and fully automated analysis.")
(license license:gpl3+)))
+
+(define-public r-kegggraph
+ (package
+ (name "r-kegggraph")
+ (version "1.50.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "KEGGgraph" version))
+ (sha256
+ (base32 "1h293hn02ysm923bh9gxk87xv663xiqchqcvpaxpla9c3yrgkx2v"))))
+ (properties `((upstream-name . "KEGGgraph")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-graph" ,r-graph)
+ ("r-rcurl" ,r-rcurl)
+ ("r-xml" ,r-xml)))
+ (home-page "http://www.nextbiomotif.com") ;;no https
+ (synopsis "Graph approach to Kegg Pathway database in R and Bioconductor")
+ (description
+ "@code{r-kegggraph} is an interface between Kegg Pathway database and graph
+object as well as a collection of tools to analyze, dissect and visualize these
+graphs. It parses the regularly updated kgml (Kegg xml) files into graph models
+maintaining all essential pathway attributes. The package offers
+functionalities including parsing, graph operation, visualization and etc.")
+ (license license:gpl2+)))
--
2.29.2
Mădălin Ionel Patrașcu wrote 4 years ago
[PATCH 2/2] gnu: Add r-pathview.
(address . 45282@debbugs.gnu.org)(address . rekado@elephly.net)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20201216221533.3539-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-pathview): New variable.
---
gnu/packages/bioconductor.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 36274d0b39..b4a1af4306 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9213,3 +9213,37 @@ on KEGG pathways and GO terms for major research species, including human,
mouse, rat and budding yeast. Mapping data between common gene IDs for budding
yeast are also included.")
(license license:gpl2+)))
+
+(define-public r-pathview
+ (package
+ (name "r-pathview")
+ (version "1.30.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "pathview" version))
+ (sha256
+ (base32 "11fisiksw1y64ii9q8p2znyp9w8mlqzgiaacmycw59rngkjlmbs4"))))
+ (properties `((upstream-name . "pathview")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-graph" ,r-graph)
+ ("r-kegggraph" ,r-kegggraph)
+ ("r-keggrest" ,r-keggrest)
+ ("r-org-hs-eg-db" ,r-org-hs-eg-db)
+ ("r-png" ,r-png)
+ ("r-rgraphviz" ,r-rgraphviz)
+ ("r-xml" ,r-xml)))
+ (home-page "https://pathview.uncc.edu/")
+ (synopsis "Tool set for pathway based data integration and visualization")
+ (description
+ "@code{r-pathview} is a tool set for pathway based data integration and
+visualization. It maps and renders a wide variety of biological data on
+relevant pathway graphs. All users need is to supply their data and specify
+the target pathway. This package automatically downloads the pathway graph
+data, parses the data file, maps user data to the pathway, and render pathway
+graph with the mapped data. In addition, @code{r-pathview} also seamlessly
+integrates with pathway and gene set (enrichment) analysis tools for
+large-scale and fully automated analysis.")
+ (license license:gpl3+)))
--
2.29.2
Ricardo Wurmus wrote 4 years ago
Re: [PATCH 1/2] gnu: Add r-kegggraph.
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 45282-done@debbugs.gnu.org)
87lfdwoegw.fsf@elephly.net
I applied these with a few changes (moved the packages around and
reordered the commits).

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45282@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45282
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help