GNOME Builder: Global search, autocompletion, documentation don't work

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Prikler
  • Ludovic Courtès
  • Luis Felipe
Owner
unassigned
Submitted by
Luis Felipe
Severity
normal
L
L
Luis Felipe wrote on 16 Dec 2020 18:24
(name . bug-guix@gnu.org)(address . bug-guix@gnu.org)
n3Ge0-b7PKLcjbr4nbEMFMOeeerdDsEjJ5TBlTduIWBK4Yh91TDevCUtFpNXsHOtqjU3w9T6W79B8UBsAxTorJVKyDWqXtJET4y6wy1WYdU=@protonmail.com
Various features described in GNOME Builder documentation (https://builder.readthedocs.io/en/latest/exploring.html)don't seem to work, even though their corresponding extensions are enabled (in Settings → Extensions).

So far, I've only identified Global search, autocompletion, documentation on hover. I tried these in Python code only.

I assumed these features are failing for the same reason, so I'm reporting them together.


## Steps to reproduce: Search for a function in your Python project

1. Start GNOME Builder
2. Click on the "Select a Folder..." button
3. Locate the folder of your project and click "Open"
4. Press Ctrl + . to focus the search box
5. Start typing the name of a function you know is defined in the project source code

## Expected result

You see the function suggested in the results.

## Unexpected result

The suggested results don't include the function. Searching only seems to suggest filenames that include your search terms; definitions in the source code, like classes and functions, seem to be excluded.



## Steps to reproduce: Autocompletion in a Python file

1. Open a Python file
2. Type "Hello". (that's hello in double quotes, followed by a dot)

## Expected result

A list of methods for string objects is displayed after you type the dot.

## Unexpected result

The list is not displayed at all.



## Steps to reproduce: Documentation on hovering over a Python method

1. Open a Python file
2. Type "Hello {}".format("World")
3. Hover over the "format" method or place the caret on it and press F2

## Expected result

A box appears over the method displaying its documentation.

## Unexpected result

The box is not displayed at all.



## System information

guix 08d8c2d
gnome-builder 3.36.1



## Additional information

I see the following output when I start gnome-builder from a terminal:

```
$ gnome-builder
sh: getent: command not found
11:21:17.5362 ide-application-plugins[ 18651]: CRITICAL: Cannot enable Python 3 plugins: Typelib file for namespace 'Dazzle', version '1.0' not found
11:21:17.5405 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5407 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5407 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5407 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5407 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5408 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5408 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5409 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5409 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5410 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5410 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5410 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5411 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5411 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5411 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5412 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5412 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5412 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5419 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5420 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5480 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5505 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5507 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:17.5507 libpeas[ 18651]: WARNING: The 'python3' plugin loader has not been enabled
11:21:19.8003 ide-device-manager[ 18651]: WARNING: GbpQemuDeviceProvider: binfmt is missing from /proc/mounts
11:21:20.0893 gbp-sysprof-workspace-addin[ 18651]: WARNING: Sysprof-3 is not supported, will not enable profiler: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Sysprof3 was not provided by any .service files
```


---
Luis Felipe López Acevedo
L
L
Leo Prikler wrote on 18 Dec 2020 12:53
(name . Luis Felipe)(address . luis.felipe.la@protonmail.com)(address . 45272@debbugs.gnu.org)
2342003d9ca418f44de27437e41e39b7a85d703d.camel@student.tugraz.at
Hello Luis,

After long trial and error I have failed to find a way of enabling this
feature. Getting the necessary environment variables into GNOME
Builder is doable, albeit not without issues. In particular, naively
setting GI_TYPELIB_PATH from build – which would normally be the sane
thing to do – sets you up for a runtime error. However, even after
you've somehow weasled the correct paths into all the environment
variables, getting them propagated into the IDE workers is a nightmare,
that I wish no one. I tried deleting the line, that unsets the
environment, I tried explicitly setting it to false; nothing works.

If someone else wants to take this bug, go ahead, otherwise I suggest
dropping Python support from our builds of GNOME Builder so as to not
cause confusion in such a manner.

Regards,
Leo

Am Mittwoch, den 16.12.2020, 17:24 +0000 schrieb Luis Felipe:
Toggle quote (147 lines)
> Various features described in GNOME Builder documentation (
> https://builder.readthedocs.io/en/latest/exploring.html) don't seem
> to work, even though their corresponding extensions are enabled (in
> Settings → Extensions).
>
> So far, I've only identified Global search, autocompletion,
> documentation on hover. I tried these in Python code only.
>
> I assumed these features are failing for the same reason, so I'm
> reporting them together.
>
>
> ## Steps to reproduce: Search for a function in your Python project
>
> 1. Start GNOME Builder
> 2. Click on the "Select a Folder..." button
> 3. Locate the folder of your project and click "Open"
> 4. Press Ctrl + . to focus the search box
> 5. Start typing the name of a function you know is defined in the
> project source code
>
> ## Expected result
>
> You see the function suggested in the results.
>
> ## Unexpected result
>
> The suggested results don't include the function. Searching only
> seems to suggest filenames that include your search terms;
> definitions in the source code, like classes and functions, seem to
> be excluded.
>
>
>
> ## Steps to reproduce: Autocompletion in a Python file
>
> 1. Open a Python file
> 2. Type "Hello". (that's hello in double quotes, followed by a dot)
>
> ## Expected result
>
> A list of methods for string objects is displayed after you type the
> dot.
>
> ## Unexpected result
>
> The list is not displayed at all.
>
>
>
> ## Steps to reproduce: Documentation on hovering over a Python method
>
> 1. Open a Python file
> 2. Type "Hello {}".format("World")
> 3. Hover over the "format" method or place the caret on it and press
> F2
>
> ## Expected result
>
> A box appears over the method displaying its documentation.
>
> ## Unexpected result
>
> The box is not displayed at all.
>
>
>
> ## System information
>
> guix 08d8c2d
> gnome-builder 3.36.1
>
>
>
> ## Additional information
>
> I see the following output when I start gnome-builder from a
> terminal:
>
> ```
> $ gnome-builder
> sh: getent: command not found
> 11:21:17.5362 ide-application-plugins[ 18651]:
> CRITICAL: Cannot enable Python 3 plugins: Typelib file for namespace
> 'Dazzle', version '1.0' not found
> 11:21:17.5405 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5407 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5407 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5407 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5407 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5408 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5408 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5409 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5409 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5410 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5410 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5410 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5411 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5411 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5411 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5412 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5412 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5412 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5419 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5420 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5480 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5505 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5507 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:17.5507 libpeas[
> 18651]: WARNING: The 'python3' plugin loader has not been enabled
> 11:21:19.8003 ide-device-manager[
> 18651]: WARNING: GbpQemuDeviceProvider: binfmt is missing from
> /proc/mounts
> 11:21:20.0893 gbp-sysprof-workspace-addin[
> 18651]: WARNING: Sysprof-3 is not supported, will not enable
> profiler: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The
> name org.gnome.Sysprof3 was not provided by any .service files
> ```
>
>
> ---
> Luis Felipe López Acevedo
> https://luis-felipe.gitlab.io/
>
L
L
Leo Prikler wrote on 18 Dec 2020 15:16
[PATCH] gnu: gnome-builder: Disable jedi plugin.
(address . 45272@debbugs.gnu.org)(address . luis.felipe.la@protonmail.com)
20201218141655.31972-1-leo.prikler@student.tugraz.at
As pointed out in #45272, it is broken.

* gnu/packages/gnome.scm (gnome-builder)[#:configure-flags] Add
-Dplugin_jedi=false.
---
gnu/packages/gnome.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5a166d1b86..9f37c605be 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11876,6 +11876,7 @@ libraries. Applications do not need to be recompiled--or even restarted.")
"-Dplugin_clang=false"
"-Dplugin_flatpak=false"
"-Dplugin_glade=false"
+ "-Dplugin_jedi=false"
;; ... except this one.
"-Dplugin_update_manager=false")
#:phases
--
2.29.2
L
L
Ludovic Courtès wrote on 18 Dec 2020 17:49
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)
87o8ir9hzk.fsf@gnu.org
Hi!

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (2 lines)
> As pointed out in #45272, it is broken.

Please add this as a comment above “-Dplugin_jedi=false” (refer to the
bug by URL so there’s no ambiguity).

Toggle quote (3 lines)
> * gnu/packages/gnome.scm (gnome-builder)[#:configure-flags] Add
> -Dplugin_jedi=false.

Otherwise LGTM, thanks!

Ludo’.
L
L
Leo Prikler wrote on 18 Dec 2020 18:01
[PATCH v2] gnu: gnome-builder: Disable jedi plugin.
(address . 45272@debbugs.gnu.org)
20201218170153.17443-1-leo.prikler@student.tugraz.at
As pointed out in #45272, it is broken.

* gnu/packages/gnome.scm (gnome-builder)[#:configure-flags] Add
-Dplugin_jedi=false.
---
gnu/packages/gnome.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5a166d1b86..a533480b42 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11876,6 +11876,7 @@ libraries. Applications do not need to be recompiled--or even restarted.")
"-Dplugin_clang=false"
"-Dplugin_flatpak=false"
"-Dplugin_glade=false"
+ "-Dplugin_jedi=false" ; disabled due to #45272
;; ... except this one.
"-Dplugin_update_manager=false")
#:phases
--
2.29.2
L
L
Leo Prikler wrote on 18 Dec 2020 18:10
Re: bug#45272: [PATCH] gnu: gnome-builder: Disable jedi plugin.
(name . Ludovic Courtès)(address . ludo@gnu.org)
b359cf2c40fe53579725faa5c70def979518de3e.camel@student.tugraz.at
Am Freitag, den 18.12.2020, 17:49 +0100 schrieb Ludovic Courtès:
Toggle quote (9 lines)
> Hi!
>
> Leo Prikler <leo.prikler@student.tugraz.at> skribis:
>
> > As pointed out in #45272, it is broken.
>
> Please add this as a comment above “-Dplugin_jedi=false” (refer to
> the
> bug by URL so there’s no ambiguity).
I feel like a side comment as in v2 would be wiser, so as to not
disrupt the sentence started before and to keep the sentiment, that it
should be enabled once someone has figured out, how to do so.
Of course, the side does not offer enough space for the full URL, so
that's bad. Would it suffice to add the URL to the commit message, so
one could `git blame` me?

Regards,
Leo
L
L
Leo Prikler wrote on 19 Dec 2020 12:50
[PATCH v3] gnu: gnome-builder: Disable jedi plugin.
(address . 45272@debbugs.gnu.org)
20201219115000.8569-1-leo.prikler@student.tugraz.at
As pointed out in #45272, it is broken.

* gnu/packages/gnome.scm (gnome-builder)[#:configure-flags] Add
-Dplugin_jedi=false.
---
gnu/packages/gnome.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5a166d1b86..f90c0b92a6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -11876,6 +11876,9 @@ libraries. Applications do not need to be recompiled--or even restarted.")
"-Dplugin_clang=false"
"-Dplugin_flatpak=false"
"-Dplugin_glade=false"
+ ;; XXX: This one has been shown not to work in
+ ;; <https://issues.guix.gnu.org/45272>
+ "-Dplugin_jedi=false"
;; ... except this one.
"-Dplugin_update_manager=false")
#:phases
--
2.29.2
L
L
Ludovic Courtès wrote on 21 Dec 2020 15:30
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)
87lfdr6xl7.fsf@gnu.org
Hi,

Leo Prikler <leo.prikler@student.tugraz.at> skribis:

Toggle quote (5 lines)
> As pointed out in #45272, it is broken.
>
> * gnu/packages/gnome.scm (gnome-builder)[#:configure-flags] Add
> -Dplugin_jedi=false.

Perfect. :-)

Applied, thanks!

Ludo’.
Closed
?