Using gnome-keyring and LXQt as Desktop Environment

  • Open
  • quality assurance status badge
Details
2 participants
  • Hamzeh Nasajpour
  • Leo Prikler
Owner
unassigned
Submitted by
Hamzeh Nasajpour
Severity
normal
H
H
Hamzeh Nasajpour wrote on 16 Dec 2020 13:01
(address . bug-guix@gnu.org)
a96e8adb-f768-425f-a603-7a9905da43c3@www.fastmail.com
Hi guys,

I want to install `gnome-keyring` service on my system. I'm using the LXQt as Desktop Environment. I had an issue for integrating ssh-agent with `gnome-keyring` and I noticed I should update this line in `desktop` files of `gnome-keyring`:
```
OnlyShowIn=GNOME;Unity;MATE;
```

to

```
OnlyShowIn=GNOME;Unity;MATE;LXQt;
```

So I re-packaged the `gnome-keyring` as follow:
```
(define-public gnome-keyring-modified
(package
(inherit gnome-keyring)
(name "gnome-keyring-modified")
(arguments
(substitute-keyword-arguments (package-arguments gnome-keyring)
((#:phases phases)
`(modify-phases ,phases
(add-after 'unpack 'patch-desktop-files
(lambda _
(substitute* '("daemon/gnome-keyring-secrets.desktop.in.in")
(("OnlyShowIn=GNOME;Unity;MATE;") "OnlyShowIn=GNOME;Unity;MATE;LXQt;"))
(substitute* '("daemon/gnome-keyring-pkcs11.desktop.in.in")
(("OnlyShowIn=GNOME;Unity;MATE;") "OnlyShowIn=GNOME;Unity;MATE;LXQt;"))
(substitute* '("daemon/gnome-keyring-ssh.desktop.in.in")
(("OnlyShowIn=GNOME;Unity;MATE;") "OnlyShowIn=GNOME;Unity;MATE;LXQt;"))
#t))))))))
```

The above package definition is ok and works, but since I want to use the `gnome-keyring` as service I should update `gnome-keyring-configuration` in my system configuration, so I'm using this config:
```
...
(service gnome-keyring-service-type
(gnome-keyring-configuration
(keyring gnome-keyring-modified)
(pam-services '(("passwd" . passwd)
("sddm" . login)))))
...
```

Now I reconfigured the system successfully, but `gnome-keyring` service is using the default `gnome-keyring`, not `gnome-keyring-modified` package, while I set the `keyring` to `gnome-keyring-modified`.

Do you have any idea?


--

Hamzeh Nasajpour
PantherX Team
L
L
Leo Prikler wrote on 18 Dec 2020 14:27
(address . h.nasajpour@pantherx.org)(address . 45267@debbugs.gnu.org)
cf2d08042713b6ca7af18f36e09c9d95c0326f61.camel@student.tugraz.at
Hello Hamzeh,

the gnome-keyring service is not the only place, in which gnome-keyring
is used. As far as I understand, all it does is unlocking your login
keyring; you have to ensure on your own, that the keyring argument
passed to it matches the keyring used by your applications.

I think you have two options going ahead. One would be to mark your
keyring as a replacement to the existing one. That would require the
non-trivial effort of maintaining a Guix fork while the patch is not
upstreamed and lobbying for its inclusion in mainline Guix. Is there
some merit in adding LXQt to this line or even dropping it entirely?
The second would be to replace gnome-keyring in every package using it
through package transformations.

Regards,
Leo
?