[PATCH] gnu: update terminator

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Efraim Flashner
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 4 years ago
(address . guix-patches@gnu.org)
CAJsg1E8GMUHJcLauznc2vu-zm4bEYBTBn9ZUh67hZ7cmm3hxkQ@mail.gmail.com
* gnu/packages/gnome.scm (terminator): update to 1.92
---
gnu/packages/gnome.scm | 43 ++++++++++++++++++++++++++----------------
1 file changed, 27 insertions(+), 16 deletions(-)

Toggle diff (88 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 64fded105a..3244cdd648 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -56,6 +56,7 @@
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
+;;; Copyright © 2020 Andy Tai <atai@atai.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10858,32 +10859,37 @@ advanced image management tool")
(define-public terminator
(package
(name "terminator")
- (version "1.91")
+ (version "1.92")
(source (origin
(method url-fetch)
- (uri (string-append "https://launchpad.net/" name "/"
- "gtk3/" version "/" "+download/"
+ (uri (string-append "https://github.com/gnome-" name "/" name "/"
+ "releases/download/v" version "/"
name "-" version ".tar.gz"))
(sha256
(base32
- "0sdyqwydmdnh7j6mn74vrywz35m416kqsbxbrqcnv5ak08y6xxwm"))))
+ "1wbkfp0nk6x9bcwi681zy30qmrp4h754sdz6b7hi9j22mmvdd50z"))))
(build-system python-build-system)
(native-inputs
- `(("intltool" ,intltool)
+ `(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin") ; for glib-compile-resources
- ("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)))
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("python-psutil" ,python-psutil)
+ ("python-pytest-runner" ,python-pytest-runner)
+ ("python-pytest" ,python-pytest)))
(inputs
`(("cairo" ,cairo)
- ("gobject-introspection" ,gobject-introspection)
+ ("dbus-glib" ,dbus-glib)
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("python2-pycairo" ,python2-pycairo)
- ("python2-pygobject" ,python2-pygobject)
- ("python2-psutil" ,python2-psutil)
+ ("gtk+" ,gtk+)
+ ("python-pycairo" ,python-pycairo)
+ ("python-pygobject" ,python-pygobject)
("vte" ,vte)))
+ (propagated-inputs
+ `(("python-configobj" ,python-configobj)))
(arguments
- `(#:python ,python-2 ; Python 3 isn't supported
- #:imported-modules ((guix build glib-or-gtk-build-system)
+ `(#:imported-modules ((guix build glib-or-gtk-build-system)
,@%python-build-system-modules)
#:modules ((guix build python-build-system)
((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
@@ -10894,14 +10900,19 @@ advanced image management tool")
'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
(let ((prog (string-append (assoc-ref outputs "out")
- "/bin/terminator")))
+ "/bin/terminator"))
+ (pylib (string-append (assoc-ref outputs "out")
+ "/lib/python"
+ ,(version-major+minor
+ (package-version python))
+ "/site-packages")))
(wrap-program prog
- `("PYTHONPATH" = (,(getenv "PYTHONPATH")))
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH") ,pylib))
`("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))
#t)))
(add-after 'wrap-program 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
- (home-page "https://gnometerminator.blogspot.com/")
+ (home-page "https://gnome-terminator.org/")
(synopsis "Store and run multiple GNOME terminals in one window")
(description
"Terminator allows you to run multiple GNOME terminals in a grid and
--
2.26.2
Andy Tai wrote 4 years ago
Re: bug#45251: Acknowledgement ([PATCH] gnu: update terminator)
(address . 45251@debbugs.gnu.org)
CAJsg1E8qW+xsg31nm_V2Zm_qcN07Lp_OXCViXosodKOKyzowtA@mail.gmail.com
ping

On Mon, Dec 14, 2020 at 11:33 PM GNU bug Tracking System <
help-debbugs@gnu.org> wrote:

Toggle quote (24 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 45251@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 45251: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=45251
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
>


--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat:
andytai1010
Year 2019 民國108年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Attachment: file
Efraim Flashner wrote 4 years ago
Re: [bug#45251] [PATCH] gnu: update terminator
(name . Andy Tai)(address . atai@atai.org)(address . 45251-done@debbugs.gnu.org)
X/SKDwG7bp/dRANV@3900XT
I went ahead and finished off the commit message and pushed it. Thanks!

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl/0igwACgkQQarn3Mo9
g1H14w/+LK+N7SI10G4jse0TLIa1rDpzBCg1mOuiVFYTES8qLf7XRUWBCv1sqjxK
p4J3WqzT6YPWRcokG6sPrYBMjaCpILZf+/wbhBfHf59ZUF3ON7YQaN3BtvfxrNrj
MoBIfyHVbKmZfTh0vtoHjn3w07At6CD/T/d7S8Ijij8ucd65LzY2+AAtmlENXXOo
tR1XXTosMVt/WtT+oNB958p0di3vdUrPNiyY8o77DJcexD/Cp/yaPbbMl90eDF3i
ImXdQ3u0On7XXIpLBWVTIwZpy8WlBCL+o2mfuViSn4O3Iqy3kQPChh/14Ej/BYof
6VT89k7L50/mA1dB2764Og53n7fHdvfd5seIwRLo/UkvXbctR5zCS/dY1fpvf/s4
nOIYrh7Wm8xAkDJ4dXSvpUJXI1K41OfbYzl1at4QOf2xSq9/5eafX+McgZkmMNJn
bGnOa6ROehwq+XT+2DxL+ykYLpfCDvTPv6Bef3vCsXzimoSLJvO8kbeFmYbP1nj8
m6sr6u2D4pegbfQ63ya+Zv1GFe1NjnrgJOHOtD9YOwZWhtx5/iklsHD14JxlLAaB
fy5SOYZ6BVuwTWviRxcW9pQyw2fUDRCoPnslqyX5EHY1IgeRMJuCYaI8mRZLnyfM
xArBASUdmNTaeLqwbKFnQctpQLAsNqLdPCpEFaohPdNDEiO2hd8=
=DTpa
-----END PGP SIGNATURE-----


Closed
Andy Tai wrote 4 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 45251-done@debbugs.gnu.org)
CAJsg1E-zbnv3swuUpH6CfH-d436gOjsfYYhrFMH8KY2Wwc=KFQ@mail.gmail.com
Great, thanks!

On Tue, Jan 5, 2021 at 7:48 AM Efraim Flashner <efraim@flashner.co.il>
wrote:

Toggle quote (9 lines)
> I went ahead and finished off the commit message and pushed it. Thanks!
>
> --
> Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
> GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
> Confidentiality cannot be guaranteed on emails sent or received unencrypted
>


--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat:
andytai1010
Year 2019 民國108年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Attachment: file
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45251@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45251
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help