[PATCH] gnu: httpstat: Update to 1.3.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal
M
M
Michael Rohleder wrote on 15 Dec 2020 00:45
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201214234533.18458-1-mike@rohleder.de
* gnu/packages/networking.scm (httpstat): Update to 1.3.0.
[source]: Changed uri from pypi-uri to git-reference.
[arguments]: Add substitution for changed time units of curl.
---
gnu/packages/networking.scm | 17 ++++++++++++-----
1 file changed, 12 insertions(+), 5 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 1226b8606f..4fcdaeef05 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2020 Jesse Dowell <jessedowell@gmail.com>
;;; Copyright © 2020 Hamzeh Nasajpour <h.nasajpour@pantherx.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1555,14 +1556,17 @@ application stack itself.")
(define-public httpstat
(package
(name "httpstat")
- (version "1.2.1")
+ (version "1.3.0")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "httpstat" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/reorx/httpstat")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1chw2nk56vaq87aba012a270k9na06hfx1pfbsrc3jfvlc2kb9hb"))))
+ "18k2glnyzxlmry19ijmndim2vqqn3c86smd7xc3haw6k7qafifx1"))))
(build-system python-build-system)
(inputs `(("curl" ,curl)))
(arguments
@@ -1574,7 +1578,10 @@ application stack itself.")
(("ENV_CURL_BIN.get\\('curl'\\)")
(string-append "ENV_CURL_BIN.get('"
(assoc-ref inputs "curl")
- "/bin/curl')")))
+ "/bin/curl')"))
+ ;; "curl -w time_*" units seems to have
+ ;; changed from seconds to nanoseconds.
+ (("d\\[k\\] \\* 1000") "d[k] / 1000"))
#t)))))
(home-page "https://github.com/reorx/httpstat")
(synopsis "Visualize curl statistics")
--
2.29.2
L
L
Ludovic Courtès wrote on 21 Dec 2020 17:44
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 45247-done@debbugs.gnu.org)
87blen5ct0.fsf@gnu.org
Hi,

Michael Rohleder <mike@rohleder.de> skribis:

Toggle quote (4 lines)
> * gnu/packages/networking.scm (httpstat): Update to 1.3.0.
> [source]: Changed uri from pypi-uri to git-reference.
> [arguments]: Add substitution for changed time units of curl.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45247@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45247
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch