Toggle diff (443 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index a7643deb97..bda7195f1d 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -41,6 +41,7 @@
#:use-module ((gnu packages base) #:prefix base:)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages cross-base)
#:use-module (gnu packages dejagnu)
#:use-module (gnu packages flex)
@@ -1466,7 +1467,7 @@ and Zilog Z80 families, plus many of their variants.")
(define-public sdcc
(package
(name "sdcc")
- (version "3.7.0")
+ (version "4.0.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1474,7 +1475,7 @@ and Zilog Z80 families, plus many of their variants.")
"/" version "/sdcc-src-" version ".tar.bz2"))
(sha256
(base32
- "13llvx0j3v5qa7qd4fh7nix4j3alpd3ccprxvx163c4q8q4lfkc5"))
+ "042fxw5mnsfhpc0z9lxfsw88kdkm32pwrxacp88kj2n2dy0814a8"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1490,7 +1491,8 @@ and Zilog Z80 families, plus many of their variants.")
("boost" ,boost)
("flex" ,flex)
("python-2" ,python-2)
- ("texinfo" ,texinfo)))
+ ("texinfo" ,texinfo)
+ ("zlib" ,zlib)))
(arguments
`(;; GPUTILS is required for the PIC ports, but the licensing status of
;; some of the files contained in its distribution is unclear (see
@@ -1508,9 +1510,9 @@ and Zilog Z80 families, plus many of their variants.")
(home-page "http://sdcc.sourceforge.net")
(synopsis "C compiler suite for 8-bit microcontrollers")
(description "SDCC is a retargetable, optimizing Standard C compiler suite
-that targets 8-bit microcontrollers in the Intel MCS-51 (8051), Motorola
-68HC08, STMicroelectronics STM8, and Zilog Z80 families, plus many of their
-variants.")
+that targets 8-bit microcontrollers in the Intel MCS-51 (8051); Motorola
+68HC08; Padauk PDK13, PDK14 and PDK15; STMicroelectronics STM8; and Zilog Z80
+families, plus many of their variants.")
(license (list license:gpl2+
license:gpl3+
license:lgpl2.0+
diff --git a/gnu/packages/patches/sdcc-disable-non-free-code.patch b/gnu/packages/patches/sdcc-disable-non-free-code.patch
index 545f0cbd69..ad9a3e7a9e 100644
--- a/gnu/packages/patches/sdcc-disable-non-free-code.patch
+++ b/gnu/packages/patches/sdcc-disable-non-free-code.patch
@@ -15,10 +15,10 @@ remove instructions that encourage the use of SDCC with non-free
software.
diff --git a/Makefile.common.in b/Makefile.common.in
-index 4c75cfa..9fa306d 100644
+index 412fd5a..81bbd61 100644
--- a/Makefile.common.in
+++ b/Makefile.common.in
-@@ -65,7 +65,6 @@ OPT_DISABLE_PACKIHX = @OPT_DISABLE_PACKIHX@
+@@ -69,7 +69,6 @@ OPT_DISABLE_PACKIHX = @OPT_DISABLE_PACKIHX@
OPT_DISABLE_SDBINUTILS = @OPT_DISABLE_SDBINUTILS@
OPT_DISABLE_SDCPP = @OPT_DISABLE_SDCPP@
OPT_DISABLE_UCSIM = @OPT_DISABLE_UCSIM@
@@ -27,10 +27,10 @@ index 4c75cfa..9fa306d 100644
SLIB = $(top_builddir)/support/util
diff --git a/Makefile.in b/Makefile.in
-index aac442e..dd73e40 100644
+index f3b028d..cfdf06d 100644
--- a/Makefile.in
+++ b/Makefile.in
-@@ -82,9 +82,6 @@ endif
+@@ -100,9 +100,6 @@ endif
ifeq ($(OPT_DISABLE_DEVICE_LIB), 0)
TARGETS += sdcc-device-lib
PKGS += device/lib
@@ -40,17 +40,17 @@ index aac442e..dd73e40 100644
endif
ifeq ($(OPT_DISABLE_PACKIHX), 0)
-@@ -105,9 +102,6 @@ endif
+@@ -123,9 +120,6 @@ endif
TARGETS += sdcc-libs sdcc-cc sdcc-device-inc sdcc-as sdcc-ld sdcc-scripts
PKGS += $(SDCC_LIBS) src device/include
-ifeq ($(OPT_DISABLE_NON_FREE), 0)
-PKGS += device/non-free/include
-endif
- PKGS += $(SDCC_AS) sdas/linksrc $(SDCC_LIBRARIAN) $(SDCC_SCRIPTS)
+ PKGS += $(SDCC_AS) sdas/linksrc $(SDCC_SCRIPTS)
PORTS = $(shell cat ports.build)
-@@ -156,21 +150,12 @@ sdcc-sdbinutils:
+@@ -171,21 +165,12 @@ sdcc-sdbinutils:
sdcc-device-inc:
$(MAKE) -C device/include
@@ -73,7 +73,7 @@ index aac442e..dd73e40 100644
# doc depends on latex and latex2html
diff --git a/configure b/configure
-index 42b1c7d..00ecb51 100755
+index 43ccb6f..d345f54 100755
--- a/configure
+++ b/configure
@@ -632,7 +632,6 @@ LATEX
@@ -84,7 +84,7 @@ index 42b1c7d..00ecb51 100755
OPT_DISABLE_SDBINUTILS
OPT_DISABLE_SDCDB
OPT_DISABLE_SDCPP
-@@ -654,10 +653,7 @@ OPT_DISABLE_R2K
+@@ -659,10 +658,7 @@ OPT_DISABLE_R2K
OPT_DISABLE_Z180
OPT_DISABLE_Z80
OPT_DISABLE_MCS51
@@ -95,7 +95,7 @@ index 42b1c7d..00ecb51 100755
include_dir_suffix
inclib_dir_suffix
LIB_TYPE
-@@ -771,7 +767,6 @@ enable_packihx
+@@ -780,7 +776,6 @@ enable_packihx
enable_sdcpp
enable_sdcdb
enable_sdbinutils
@@ -103,7 +103,7 @@ index 42b1c7d..00ecb51 100755
enable_doc
enable_libgc
'
-@@ -792,10 +787,7 @@ sdccconf_h_dir_separator
+@@ -801,10 +796,7 @@ sdccconf_h_dir_separator
LIB_TYPE
inclib_dir_suffix
include_dir_suffix
@@ -114,7 +114,7 @@ index 42b1c7d..00ecb51 100755
docdir'
ac_subdirs_all='support/cpp
support/packihx
-@@ -803,9 +795,7 @@ sim/ucsim
+@@ -812,9 +804,7 @@ sim/ucsim
debugger/mcs51
support/sdbinutils
device/lib/pic14
@@ -125,7 +125,7 @@ index 42b1c7d..00ecb51 100755
# Initialize some variables set by options.
ac_init_help=
-@@ -1452,7 +1442,6 @@ Optional Features:
+@@ -1455,7 +1445,6 @@ Optional Features:
--disable-sdcpp Disables building sdcpp
--disable-sdcdb Disables building sdcdb
--disable-sdbinutils Disables configuring and building of sdbinutils
@@ -133,7 +133,7 @@ index 42b1c7d..00ecb51 100755
--enable-doc Enables building the documentation
--enable-libgc Use the Bohem memory allocator. Lower runtime
footprint.
-@@ -1481,16 +1470,8 @@ Some influential environment variables:
+@@ -1484,16 +1473,8 @@ Some influential environment variables:
appended to datadir to define SDCC's include/lib directory
include_dir_suffix
appended to datadir to define SDCC's include directory
@@ -150,7 +150,7 @@ index 42b1c7d..00ecb51 100755
docdir documentation installation directory
Use these variables to override the choices made by `configure' or to help
-@@ -7236,19 +7217,6 @@ if test "${include_dir_suffix}" = ""; then
+@@ -7134,19 +7115,6 @@ if test "${include_dir_suffix}" = ""; then
include_dir_suffix="${inclib_dir_suffix}/include"
fi
@@ -170,7 +170,7 @@ index 42b1c7d..00ecb51 100755
# lib_dir_suffix:
# *nix default: "sdcc/lib"
-@@ -7256,13 +7224,6 @@ if test "${lib_dir_suffix}" = ""; then
+@@ -7154,13 +7122,6 @@ if test "${lib_dir_suffix}" = ""; then
lib_dir_suffix="${inclib_dir_suffix}/lib"
fi
@@ -184,7 +184,7 @@ index 42b1c7d..00ecb51 100755
# docdir:
# *nix default: "${datadir}/sdcc/doc"
-@@ -7429,24 +7390,6 @@ cat >>confdefs.h <<_ACEOF
+@@ -7327,24 +7288,6 @@ cat >>confdefs.h <<_ACEOF
#define INCLUDE_DIR_SUFFIX DIR_SEPARATOR_STRING "${norm_inc_dir_suffix}"
_ACEOF
@@ -209,7 +209,7 @@ index 42b1c7d..00ecb51 100755
norm_lib_dir_suffix=${lib_dir_suffix}
case ":$norm_lib_dir_suffix:" in
-@@ -7466,24 +7409,6 @@ cat >>confdefs.h <<_ACEOF
+@@ -7364,24 +7307,6 @@ cat >>confdefs.h <<_ACEOF
#define LIB_DIR_SUFFIX DIR_SEPARATOR_STRING "${norm_lib_dir_suffix}"
_ACEOF
@@ -234,7 +234,7 @@ index 42b1c7d..00ecb51 100755
# relative paths
for _lcl_i in expanded_bindir:expanded_datadir:bin2data_dir; do
-@@ -8411,28 +8336,6 @@ _ACEOF
+@@ -8439,28 +8364,6 @@ _ACEOF
@@ -263,7 +263,7 @@ index 42b1c7d..00ecb51 100755
# Check whether --enable-doc was given.
if test "${enable_doc+set}" = set; then :
-@@ -8827,20 +8730,12 @@ if test $OPT_DISABLE_PIC14 = 0; then
+@@ -8855,20 +8758,12 @@ if test $OPT_DISABLE_PIC14 = 0; then
test $OPT_DISABLE_DEVICE_LIB = 0 && subdirs="$subdirs device/lib/pic14"
@@ -283,15 +283,15 @@ index 42b1c7d..00ecb51 100755
-
fi
- if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_GBZ80 = 0 || test $OPT_DISABLE_TLCS90 = 0; then
-@@ -8885,15 +8780,9 @@ fi
+ if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_GBZ80 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0; then
+@@ -8945,15 +8840,9 @@ fi
test $OPT_DISABLE_DEVICE_LIB = 0 && ac_config_files="$ac_config_files device/lib/Makefile"
-test $OPT_DISABLE_DEVICE_LIB = 0 && test $OPT_DISABLE_NON_FREE = 0 && ac_config_files="$ac_config_files device/non-free/lib/Makefile"
-
- ac_config_files="$ac_config_files main.mk:main_in.mk src/Makefile device/include/Makefile sdas/linksrc/Makefile support/librarian/Makefile support/makebin/Makefile support/regression/Makefile support/valdiag/Makefile support/scripts/Makefile support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in Makefile Makefile.common:Makefile.common.in"
+ ac_config_files="$ac_config_files main.mk:main_in.mk src/Makefile device/include/Makefile sdas/linksrc/Makefile support/makebin/Makefile support/regression/Makefile support/valdiag/Makefile support/scripts/Makefile support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in Makefile Makefile.common:Makefile.common.in"
-if test $OPT_DISABLE_NON_FREE = 0; then
- ac_config_files="$ac_config_files device/non-free/include/Makefile"
@@ -300,15 +300,15 @@ index 42b1c7d..00ecb51 100755
cat >confcache <<\_ACEOF
# This file is a shell script that caches the results of configure
# tests run on this system so they can be shared between configure
-@@ -9621,7 +9510,6 @@ do
- "sdas/asstm8/Makefile") CONFIG_FILES="$CONFIG_FILES sdas/asstm8/Makefile" ;;
- "device/lib/stm8/Makefile") CONFIG_FILES="$CONFIG_FILES device/lib/stm8/Makefile" ;;
+@@ -9692,7 +9581,6 @@ do
+ "device/lib/pdk15-stack-auto/Makefile") CONFIG_FILES="$CONFIG_FILES device/lib/pdk15-stack-auto/Makefile" ;;
+ "sdas/aspdk16/Makefile") CONFIG_FILES="$CONFIG_FILES sdas/aspdk16/Makefile" ;;
"device/lib/Makefile") CONFIG_FILES="$CONFIG_FILES device/lib/Makefile" ;;
- "device/non-free/lib/Makefile") CONFIG_FILES="$CONFIG_FILES device/non-free/lib/Makefile" ;;
"main.mk") CONFIG_FILES="$CONFIG_FILES main.mk:main_in.mk" ;;
"src/Makefile") CONFIG_FILES="$CONFIG_FILES src/Makefile" ;;
"device/include/Makefile") CONFIG_FILES="$CONFIG_FILES device/include/Makefile" ;;
-@@ -9634,7 +9522,6 @@ do
+@@ -9704,7 +9592,6 @@ do
"support/regression/ports/host/spec.mk") CONFIG_FILES="$CONFIG_FILES support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in" ;;
"Makefile") CONFIG_FILES="$CONFIG_FILES Makefile" ;;
"Makefile.common") CONFIG_FILES="$CONFIG_FILES Makefile.common:Makefile.common.in" ;;
@@ -316,7 +316,7 @@ index 42b1c7d..00ecb51 100755
*) as_fn_error $? "invalid argument: \`$ac_config_target'" "$LINENO" 5;;
esac
-@@ -10443,54 +10330,6 @@ esac
+@@ -10513,54 +10400,6 @@ esac
incPath3=`echo "$incPath3" | sed 's,\\\\\\\\,\\\\,g'`
@@ -371,7 +371,7 @@ index 42b1c7d..00ecb51 100755
libPath1=`echo "/${prefix2data_dir}/${norm_lib_dir_suffix}" | sed 's,/\./,/,g'`
case ":$libPath1:" in
-@@ -10540,54 +10379,6 @@ esac
+@@ -10610,54 +10449,6 @@ esac
libPath3=`echo "$libPath3" | sed 's,\\\\\\\\,\\\\,g'`
@@ -426,15 +426,15 @@ index 42b1c7d..00ecb51 100755
{ $as_echo "$as_me:${as_lineno-$LINENO}: result:
sdcc ${VERSION} is now configured for
-@@ -10618,7 +10409,6 @@ sdcc ${VERSION} is now configured for
- tlcs90 ${enable_tlcs90_port}
- stm8 ${enable_stm8_port}
+@@ -10694,7 +10485,6 @@ sdcc ${VERSION} is now configured for
+ pdk15 ${enable_pdk15_port}
+ pdk16 ${enable_pdk16_port}
- Disable non-free lib: ${OPT_DISABLE_NON_FREE}
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device lib: ${OPT_DISABLE_DEVICE_LIB}
-@@ -10633,9 +10423,6 @@ sdcc ${VERSION} is now configured for
+@@ -10709,9 +10499,6 @@ sdcc ${VERSION} is now configured for
include/library files: ${datadir}/${inclib_dir_suffix}
include files: ${datadir}/${include_dir_suffix}
library files: ${datadir}/${lib_dir_suffix}
@@ -444,7 +444,7 @@ index 42b1c7d..00ecb51 100755
documentation: ${docdir}
prefix: ${prefix}
-@@ -10647,15 +10434,9 @@ sdcc ${VERSION} is now configured for
+@@ -10723,15 +10510,9 @@ sdcc ${VERSION} is now configured for
include files: ${incPath1}
path(argv[0])${incPath2}
${incPath3}
@@ -460,15 +460,15 @@ index 42b1c7d..00ecb51 100755
" >&5
$as_echo "
sdcc ${VERSION} is now configured for
-@@ -10687,7 +10468,6 @@ sdcc ${VERSION} is now configured for
- tlcs90 ${enable_tlcs90_port}
- stm8 ${enable_stm8_port}
+@@ -10769,7 +10550,6 @@ sdcc ${VERSION} is now configured for
+ pdk15 ${enable_pdk15_port}
+ pdk16 ${enable_pdk16_port}
- Disable non-free lib: ${OPT_DISABLE_NON_FREE}
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device lib: ${OPT_DISABLE_DEVICE_LIB}
-@@ -10702,9 +10482,6 @@ sdcc ${VERSION} is now configured for
+@@ -10784,9 +10564,6 @@ sdcc ${VERSION} is now configured for
include/library files: ${datadir}/${inclib_dir_suffix}
include files: ${datadir}/${include_dir_suffix}
library files: ${datadir}/${lib_dir_suffix}
@@ -478,7 +478,7 @@ index 42b1c7d..00ecb51 100755
documentation: ${docdir}
prefix: ${prefix}
-@@ -10716,14 +10493,8 @@ sdcc ${VERSION} is now configured for
+@@ -10798,14 +10575,8 @@ sdcc ${VERSION} is now configured for
include files: ${incPath1}
path(argv[0])${incPath2}
${incPath3}
@@ -494,10 +494,10 @@ index 42b1c7d..00ecb51 100755
" >&6; }
# End of configure/configure.in
diff --git a/configure.ac b/configure.ac
-index 3a16e42..bfba129 100644
+index 2185793..76ab155 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -588,19 +588,6 @@ if test "${include_dir_suffix}" = ""; then
+@@ -544,19 +544,6 @@ if test "${include_dir_suffix}" = ""; then
include_dir_suffix="${inclib_dir_suffix}/include"
fi
@@ -517,7 +517,7 @@ index 3a16e42..bfba129 100644
# lib_dir_suffix:
# *nix default: "sdcc/lib"
AC_ARG_VAR([lib_dir_suffix], [appended to datadir to define SDCC's library root directory])
-@@ -608,13 +595,6 @@ if test "${lib_dir_suffix}" = ""; then
+@@ -564,13 +551,6 @@ if test "${lib_dir_suffix}" = ""; then
lib_dir_suffix="${inclib_dir_suffix}/lib"
fi
@@ -531,7 +531,7 @@ index 3a16e42..bfba129 100644
# docdir:
# *nix default: "${datadir}/sdcc/doc"
AC_ARG_VAR([docdir], [documentation installation directory])
-@@ -655,19 +635,11 @@ norm_inc_dir_suffix=${include_dir_suffix}
+@@ -611,19 +591,11 @@ norm_inc_dir_suffix=${include_dir_suffix}
adl_NORMALIZE_PATH([norm_inc_dir_suffix], [$sdccconf_h_dir_separator])
AC_DEFINE_UNQUOTED(INCLUDE_DIR_SUFFIX,
DIR_SEPARATOR_STRING "${norm_inc_dir_suffix}", [XXX])
@@ -551,7 +551,7 @@ index 3a16e42..bfba129 100644
# relative paths
adl_COMPUTE_RELATIVE_PATHS([expanded_bindir:expanded_datadir:bin2data_dir])
-@@ -836,7 +808,6 @@ AC_DO_DISABLER(packihx, PACKIHX, [Disables building packihx])
+@@ -797,7 +769,6 @@ AC_DO_DISABLER(packihx, PACKIHX, [Disables building packihx])
AC_DO_DISABLER(sdcpp, SDCPP, [Disables building sdcpp])
AC_DO_DISABLER(sdcdb, SDCDB, [Disables building sdcdb])
AC_DO_DISABLER(sdbinutils, SDBINUTILS, [Disables configuring and building of sdbinutils])
@@ -559,7 +559,7 @@ index 3a16e42..bfba129 100644
AC_DO_ENABLER(doc, DOC, [Enables building the documentation])
AC_CHECK_PROG([LYX], [lyx], [lyx], [:])
-@@ -907,16 +878,10 @@ if test $OPT_DISABLE_PIC14 = 0; then
+@@ -868,16 +839,10 @@ if test $OPT_DISABLE_PIC14 = 0; then
AC_CONFIG_FILES(src/pic14/Makefile)
test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_SUBDIRS(device/lib/pic14)
fi
@@ -574,17 +574,17 @@ index 3a16e42..bfba129 100644
- test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_SUBDIRS(device/non-free/lib/pic16)
-fi
- if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_GBZ80 = 0 || test $OPT_DISABLE_TLCS90 = 0; then
+ if test $OPT_DISABLE_Z80 = 0 || test $OPT_DISABLE_Z180 = 0 || test $OPT_DISABLE_R2K = 0 || test $OPT_DISABLE_R3KA = 0 || test $OPT_DISABLE_GBZ80 = 0 || test $OPT_DISABLE_TLCS90 = 0 || test $OPT_DISABLE_EZ80_Z80 = 0; then
AC_CONFIG_FILES([src/z80/Makefile])
-@@ -951,7 +916,6 @@ if test $OPT_DISABLE_STM8 = 0; then
- fi
+@@ -939,7 +904,6 @@ fi
+
test $OPT_DISABLE_DEVICE_LIB = 0 && AC_CONFIG_FILES([device/lib/Makefile])
-test $OPT_DISABLE_DEVICE_LIB = 0 && test $OPT_DISABLE_NON_FREE = 0 && AC_CONFIG_FILES([device/non-free/lib/Makefile])
AC_CONFIG_FILES([main.mk:main_in.mk
src/Makefile
-@@ -966,9 +930,6 @@ support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in
+@@ -953,9 +917,6 @@ support/regression/ports/host/spec.mk:support/regression/ports/host/spec.mk.in
Makefile
Makefile.common:Makefile.common.in
])
@@ -594,7 +594,7 @@ index 3a16e42..bfba129 100644
AC_OUTPUT
# I found no better place
-@@ -986,16 +947,10 @@ adl_NORMALIZE_PATH_MSG(/${prefix2bin_dir}, [binPath], [
+@@ -973,16 +934,10 @@ adl_NORMALIZE_PATH_MSG(/${prefix2bin_dir}, [binPath], [
adl_NORMALIZE_PATH_MSG(/${prefix2data_dir}/${norm_inc_dir_suffix}, [incPath1], [$dirch])
adl_NORMALIZE_PATH_MSG(/${bin2data_dir}/${norm_inc_dir_suffix}, [incPath2], [$dirch])
adl_NORMALIZE_PATH_MSG(${expanded_datadir}/${norm_inc_dir_suffix}, [incPath3], [$dirch])
@@ -611,15 +611,15 @@ index 3a16e42..bfba129 100644
AC_MSG_RESULT([
sdcc ${VERSION} is now configured for
-@@ -1027,7 +982,6 @@ sdcc ${VERSION} is now configured for
- tlcs90 ${enable_tlcs90_port}
- stm8 ${enable_stm8_port}
+@@ -1020,7 +975,6 @@ sdcc ${VERSION} is now configured for
+ pdk15 ${enable_pdk15_port}
+ pdk16 ${enable_pdk16_port}
- Disable non-free lib: ${OPT_DISABLE_NON_FREE}
Disable packihx: ${OPT_DISABLE_PACKIHX}
Disable ucsim: ${OPT_DISABLE_UCSIM}
Disable device lib: ${OPT_DISABLE_DEVICE_LIB}
-@@ -1042,9 +996,6 @@ sdcc ${VERSION} is now configured for
+@@ -1035,9 +989,6 @@ sdcc ${VERSION} is now configured for
include/library files: ${datadir}/${inclib_dir_suffix}
include files: ${datadir}/${include_dir_suffix}
library files: ${datadir}/${lib_dir_suffix}
@@ -629,7 +629,7 @@ index 3a16e42..bfba129 100644
documentation: ${docdir}
prefix: ${prefix}
-@@ -1056,14 +1007,8 @@ sdcc ${VERSION} is now configured for
+@@ -1049,14 +1000,8 @@ sdcc ${VERSION} is now configured for
include files