update gnucash to 4.2

  • Done
  • quality assurance status badge
Details
3 participants
  • Christopher Lam
  • Leo Famulari
  • Ludovic Courtès
Owner
unassigned
Submitted by
Christopher Lam
Severity
normal

Debbugs page

Christopher Lam wrote 4 years ago
(address . guix-patches@gnu.org)
CAKVAZZ+98ktxJWgKok3==ebgfRAd-apdkRMYi_J4+AtoKeKepA@mail.gmail.com

Attachment: file
From 2f64bfe91376065e81c4902444cb47e08e3a66b5 Mon Sep 17 00:00:00 2001
From: Christopher Lam <christopher.lck@gmail.com>
Date: Fri, 11 Dec 2020 21:20:06 +0800
Subject: [PATCH] gnucash.scm: update to 4.2

---
gnu/packages/gnucash.scm | 17 +++++++++--------
1 file changed, 9 insertions(+), 8 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index dcee4dc166..f53a76902b 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -51,6 +51,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages swig)
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
@@ -61,28 +62,28 @@
;; directory.
(package
(name "gnucash")
- (version "3.8")
+ (version "4.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/gnucash/gnucash%20%28stable%29/"
- version "/gnucash-" version "b" ".tar.bz2"))
+ version "/gnucash-" version ".tar.bz2"))
(sha256
(base32
- "0dvzm3bib7jcj685sklpzyy9mrak9mxyvih2k9fk4sl3v21wlphg"))))
+ "020k1mm909dcgs52ls4v7xx3yn8gqazi9awyr81l6y7pkq1spn2n"))))
(build-system cmake-build-system)
(inputs
- `(("guile" ,guile-2.2)
+ `(("guile" ,guile-3.0)
("boost" ,boost)
("icu4c" ,icu4c)
("glib" ,glib)
("gtk" ,gtk+)
("libdbi" ,libdbi)
("libdbi-drivers" ,libdbi-drivers)
- ("libgnomecanvas" ,libgnomecanvas)
("libofx" ,libofx)
("libxml2" ,libxml2)
("libxslt" ,libxslt)
+ ("swig" ,swig)
("webkitgtk" ,webkitgtk)
("aqbanking" ,aqbanking)
("python" ,python)
@@ -134,8 +135,8 @@
;; execute them with perl, so execute them directly instead.
(add-after 'unpack 'fix-finance-quote-check
(lambda _
- (substitute* "libgnucash/scm/price-quotes.scm"
- (("\"perl\" \"-w\" ") ""))
+ (substitute* "gnucash/price-quotes.scm"
+ (("\"perl\" \"-w\" ") ""))
#t))
;; The qof test requires the en_US, en_GB, and fr_FR locales.
(add-before 'check 'install-locales
@@ -230,7 +231,7 @@ installed as well as Yelp, the Gnome help browser.")
version "/gnucash-docs-" version revision ".tar.gz"))
(sha256
(base32
- "19v6kchda724xkkgwlw5rg21jcpirhch12j9sr6ibnv61sd4ql52"))))
+ "1p1rbv0gyi07nh5pzhk3xm46w66kjyaipb6rpaq9yb9gil1nl7q5"))))
(build-system gnu-build-system)
;; These are native-inputs because they are only required for building the
;; documentation.
--
2.27.0
Leo Famulari wrote 4 years ago
(name . Christopher Lam)(address . christopher.lck@gmail.com)(address . 45175-done@debbugs.gnu.org)
X9UbTdRGIkpqOQZz@jasmine.lan
On Fri, Dec 11, 2020 at 01:23:38PM +0000, Christopher Lam wrote:
Toggle quote (5 lines)
> From 2f64bfe91376065e81c4902444cb47e08e3a66b5 Mon Sep 17 00:00:00 2001
> From: Christopher Lam <christopher.lck@gmail.com>
> Date: Fri, 11 Dec 2020 21:20:06 +0800
> Subject: [PATCH] gnucash.scm: update to 4.2

Thank you!

I rewrote the commit message to meet our standards, added a copyright
line for you, and pushed as 6760578c89bfbc32b55f860dc63a0b1513dd95d3.

About the commit message, we write them in the GNU ChangeLog format:


Basically, we describe changes to the code, organized by file and
variable. The chapter in the GNU coding manual that is linked to from
our Submitting Patches guidelines is instructive when combined with `git
log` of the Guix repo.
Closed
Ludovic Courtès wrote 4 years ago
(name . Christopher Lam)(address . christopher.lck@gmail.com)(address . 45175-done@debbugs.gnu.org)
87zh2i24d0.fsf@gnu.org
Hi,

Christopher Lam <christopher.lck@gmail.com> skribis:

Toggle quote (9 lines)
> From 2f64bfe91376065e81c4902444cb47e08e3a66b5 Mon Sep 17 00:00:00 2001
> From: Christopher Lam <christopher.lck@gmail.com>
> Date: Fri, 11 Dec 2020 21:20:06 +0800
> Subject: [PATCH] gnucash.scm: update to 4.2
>
> ---
> gnu/packages/gnucash.scm | 17 +++++++++--------
> 1 file changed, 9 insertions(+), 8 deletions(-)

I moved Swig to ‘native-inputs’ as suggested by ‘guix lint’, tweaked the
commit log to follow our conventions, and applied it.

Thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45175@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45175
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help