[PATCH] gnu: go-github-com-kr-pretty: Update to 0.2.1

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Jack Hill
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
Jack Hill wrote on 11 Dec 2020 06:44
(address . guix-patches@gnu.org)
20201211054416.22115-1-jackhill@jackhill.us
* gnu/packages/golang.scm (go-github-com-kr-pretty): Update to 0.2.1
---
gnu/packages/golang.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3b42bf3c8f..20e1ab7c71 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -434,7 +434,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
,@(package-native-inputs go-1.4)))
(supported-systems %supported-systems)))
-(define-public go go-1.14)
+(define-public go go-1.15)
(define-public go-github-com-alsm-ioprogress
(let ((commit "063c3725f436e7fba0c8f588547bee21ffec7ac5")
@@ -3519,7 +3519,7 @@ format in Go.")
(define-public go-github-com-kr-pretty
(package
(name "go-github-com-kr-pretty")
- (version "0.2.0")
+ (version "0.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3528,7 +3528,7 @@ format in Go.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ywbfzz1h3a3qd8rpkiqwi1dm4w8ls9ijb4x1b7567grns9f0vnp"))))
+ "0vzfz06y9q8gs2nxx0kys0591vzp78k0fvpb8digi5n15h3b25hy"))))
(build-system go-build-system)
(propagated-inputs
`(("go-github-com-kr-text" ,go-github-com-kr-text)))
--
2.29.2
J
J
Jack Hill wrote on 11 Dec 2020 06:56
[PATCH v2] gnu: go-github-com-kr-pretty: Update to 0.2.1
(address . 45171@debbugs.gnu.org)
20201211055605.24401-1-jackhill@jackhill.us
* gnu/packages/golang.scm (go-github-com-kr-pretty): Update to 0.2.1
---
Fixed in this version: removed extraneous go version change that
accidentally got committed.

gnu/packages/golang.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3b42bf3c8f..8748479490 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3519,7 +3519,7 @@ format in Go.")
(define-public go-github-com-kr-pretty
(package
(name "go-github-com-kr-pretty")
- (version "0.2.0")
+ (version "0.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3528,7 +3528,7 @@ format in Go.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ywbfzz1h3a3qd8rpkiqwi1dm4w8ls9ijb4x1b7567grns9f0vnp"))))
+ "0vzfz06y9q8gs2nxx0kys0591vzp78k0fvpb8digi5n15h3b25hy"))))
(build-system go-build-system)
(propagated-inputs
`(("go-github-com-kr-text" ,go-github-com-kr-text)))
--
2.29.2
J
J
Jack Hill wrote on 11 Dec 2020 16:45
[PATCH v3 2/2] gnu: go-github-com-kr-pretty: Improve synopsis.
(address . 45171@debbugs.gnu.org)
20201211154549.5530-2-jackhill@jackhill.us
* gnu/packages/golang.scm (go-github-com-kr-pretty)[synopsis]: Remove leading article.
---
gnu/packages/golang.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8748479490..01cb5d34ae 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3534,7 +3534,7 @@ format in Go.")
`(("go-github-com-kr-text" ,go-github-com-kr-text)))
(arguments
'(#:import-path "github.com/kr/pretty"))
- (synopsis "A pretty printer for Go values")
+ (synopsis "Pretty printer for Go values")
(description "This package provides a pretty printer for Go values.")
(home-page "https://github.com/kr/pretty")
(license license:expat)))
--
2.29.2
J
J
Jack Hill wrote on 11 Dec 2020 16:45
[PATCH v3 1/2] gnu: go-github-com-kr-pretty: Update to 0.2.1
(address . 45171@debbugs.gnu.org)
20201211154549.5530-1-jackhill@jackhill.us
* gnu/packages/golang.scm (go-github-com-kr-pretty): Update to 0.2.1
---
In this version of the patch series, the first commit is the same as in
v2, but a second commit is added that improves the synopsis.

gnu/packages/golang.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3b42bf3c8f..8748479490 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3519,7 +3519,7 @@ format in Go.")
(define-public go-github-com-kr-pretty
(package
(name "go-github-com-kr-pretty")
- (version "0.2.0")
+ (version "0.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3528,7 +3528,7 @@ format in Go.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ywbfzz1h3a3qd8rpkiqwi1dm4w8ls9ijb4x1b7567grns9f0vnp"))))
+ "0vzfz06y9q8gs2nxx0kys0591vzp78k0fvpb8digi5n15h3b25hy"))))
(build-system go-build-system)
(propagated-inputs
`(("go-github-com-kr-text" ,go-github-com-kr-text)))
--
2.29.2
E
E
Efraim Flashner wrote on 17 Dec 2020 21:28
Re: [bug#45171] [PATCH] gnu: go-github-com-kr-pretty: Update to 0.2.1
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 45171-done@debbugs.gnu.org)
X9u/i5rtahm1Frmn@E5400
Updated patches look good. Patches pushed!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl/bv4oACgkQQarn3Mo9
g1FxoBAAiDRSeEu7jH8Hw51hqFHeGT9zFZlnPxMDW6TD0fnJ0WCOmNucKKXkeM8X
B7a7ADaTBkA9lvW1TyooS2SKhc0sZ4tGchdjb/oNxjlUsTp88BnLbPDHZU4v6rUt
b4tOWeeZOYFpFnWn4NGzH/kUK5YueOSZ1+ZeMgQ1Yf/AvFizsSDODppCQbTutoN2
a8qtmGTrAq3IcGryVd3l1JBc6VXrkKXe089cUJWlnBqyg2YMKxjqQVjVvCdA6Ih7
0BrxubUlExq6Cx+qpBtWVC+IBdRD6dGTmefqs0KCYpx8b1TnpGOv+QIFiEF3bwMR
b4M0yiJr8OipLXG2bCrdHTCOEN6+IYoUrA+waeG0ypCW/y2i9pvle4fmDE2Yr1c1
E3q7rJ6cAjwTIjo2BKR4Gl2uW+AFPG9DYisgzVyDYDO1kYyO4QIpMkvG75PiBieG
lZGrLjrNFBTGceOAYzXTH4zoQh3ycHsSfAKl+0il9VCr9d5B/E8NNZb7mVUWJM5B
VJwaeg71MR9R6WPFLeen4hRWvbxp0WaBQBf/HljeT7azrmqKO6nIFhd0iEHadtfA
qKgCeowIPOyNbMgJb499XaVA6jlBLQZqAM1YVgnDA8Zchmy4U5X94pW+dXXe37/z
K0UUnmNNukcyqtU5qrcFzM/Nnvc6wX6+TiuxfguGeIpfXTpt3P8=
=YVEC
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45171@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45171
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch