[PATCH] gnu: Add emacs-org-pretty-table.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
SN4PR0801MB36797A8F11C135C12D76930EC5CC0@SN4PR0801MB3679.namprd08.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/emacs-xyz.scm (emacs-org-pretty-table): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dcf05c909d..3c3d63ab70 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10264,6 +10264,28 @@ lists, and project planning with a fast and effective plain-text system.
This package is equivalent to org-plus-contrib, but only includes additional
files that you would find in @file{contrib/} from the git repository.")))
+(define-public emacs-org-pretty-table
+ (let ((commit "1331c600b83d95b28730b1bfcb48369ac1cf12ef")
+ (revision "0"))
+ (package
+ (name "emacs-org-pretty-table")
+ (version (git-version "0.3.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Fuco1/org-pretty-table")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yvqxh66y400n2n5ykmb1zrzd80bakffpwn6nmf37728x4cj8krh"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Fuco1/org-pretty-table")
+ (synopsis "Makes tables in org-mode and orgtbl-mode prettier")
+ (description "Displays tables in org-mode and orgtbl-mode using unicode
+characters.")
+ (license license:gpl3+))))
+
(define-public emacs-ob-sclang
(package
(inherit emacs-org-contrib)
--
2.29.2
Nicolas Goaziou wrote 4 years ago
(address . Morgan.J.Smith@outlook.com)(address . 45142-done@debbugs.gnu.org)
878sa6i0fl.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-org-pretty-table): New variable.

Thank you.

I fixed the version, added a comment to the package explaining why we
use a commit, tweaked synopsis and description, then applied your patch.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45142@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45142
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help