[PATCH 0/3] Update python-dnspython and b4

  • Done
  • quality assurance status badge
Details
2 participants
  • Kyle Meyer
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 4 years ago
(address . guix-patches@gnu.org)
20201208024309.21231-1-kyle@kyleam.com
The recent release of b4 adds a couple of dependencies, including the latest
version (2.0.0) of python-dnspython. This series updates python-dnspython
from 1.16.0 to 2.0.0, keeping a definition for the older version around for
three packages that don't support the new version. (This includes two
packages that had python2-dnspython as input, as dnspython 2.0.0 dropped
support for Python 2).

[1/3] gnu: python-dnspython: Fix indentation.
[2/3] gnu: python-dnspython: Update to 2.0.0.
[3/3] gnu: b4: Update to 0.6.1.

gnu/packages/ebook.scm | 2 +-
gnu/packages/finance.scm | 2 +-
gnu/packages/python-xyz.scm | 51 ++++++++++++++++++++------------
gnu/packages/version-control.scm | 28 +++++-------------
gnu/packages/web.scm | 2 +-
5 files changed, 43 insertions(+), 42 deletions(-)


base-commit: 608113c083312d31d74a7a395c8537dc32484c3d
--
2.29.2.576.ga3fc446d84
Kyle Meyer wrote 4 years ago
[PATCH 1/3] gnu: python-dnspython: Fix indentation.
(address . 45111@debbugs.gnu.org)
20201208024546.21690-1-kyle@kyleam.com
* gnu/packages/python-xyz.scm (python-dnspython): Fix indentation.
---
gnu/packages/python-xyz.scm | 32 ++++++++++++++++----------------
1 file changed, 16 insertions(+), 16 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d07c91121a..c20e32fd79 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13380,24 +13380,24 @@ (define-public python2-lazy-object-proxy
(define-public python-dnspython
(package
- (name "python-dnspython")
- (version "1.16.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.dnspython.org/kits/"
- version "/dnspython-" version ".tar.gz"))
- (sha256
- (base32
- "1yaw7irazy42n0kdhlk7wyg8ki34rxcnc5xbc1wfwy245b0wbxab"))))
- (build-system python-build-system)
- (arguments '(#:tests? #f)) ; XXX: requires internet access
- (home-page "http://www.dnspython.org")
- (synopsis "DNS toolkit for Python")
- (description
- "dnspython is a DNS toolkit for Python. It supports almost all record
+ (name "python-dnspython")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.dnspython.org/kits/"
+ version "/dnspython-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yaw7irazy42n0kdhlk7wyg8ki34rxcnc5xbc1wfwy245b0wbxab"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; XXX: requires internet access
+ (home-page "http://www.dnspython.org")
+ (synopsis "DNS toolkit for Python")
+ (description
+ "dnspython is a DNS toolkit for Python. It supports almost all record
types. It can be used for queries, zone transfers, and dynamic updates.
It supports TSIG authenticated messages and EDNS0.")
- (license license:expat)))
+ (license license:expat)))
(define-public python2-dnspython
(package-with-python2 python-dnspython))
--
2.29.2.576.ga3fc446d84
Kyle Meyer wrote 4 years ago
[PATCH 2/3] gnu: python-dnspython: Update to 2.0.0.
(address . 45111@debbugs.gnu.org)
20201208024546.21690-2-kyle@kyleam.com
* gnu/packages/python-xyz.scm (python-dnspython): Update to 2.0.0.
[source]: Download from pypi.
[native-inputs]: Add unzip.
[home-page]: Prefer https.
(python-dnspython-1.16):
(python2-dnspython-1.16): New variables.
* gnu/packages/ebook.scm (calibre):
* gnu/packages/web.scm (linkchecker): Use python2-dnspython-1.16.
* gnu/packages/finance.scm (electrum): Use python-dnspython-1.16.
---
gnu/packages/ebook.scm | 2 +-
gnu/packages/finance.scm | 2 +-
gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++--------
gnu/packages/web.scm | 2 +-
4 files changed, 24 insertions(+), 11 deletions(-)

Toggle diff (101 lines)
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index a23c677880..a98fea707b 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -149,7 +149,7 @@ (define-public calibre
("python2-css-parser" ,python2-css-parser)
("python2-dateutil" ,python2-dateutil)
("python2-dbus" ,python2-dbus)
- ("python2-dnspython" ,python2-dnspython)
+ ("python2-dnspython" ,python2-dnspython-1.16)
("python2-dukpy" ,python2-dukpy)
("python2-feedparser" ,python2-feedparser)
("python2-html2text" ,python2-html2text)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index b19d28c123..1f97077fc6 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -524,7 +524,7 @@ (define-public electrum
("python-aiohttp-socks" ,python-aiohttp-socks)
("python-aiorpcx" ,python-aiorpcx)
("python-certifi" ,python-certifi)
- ("python-dnspython" ,python-dnspython)
+ ("python-dnspython" ,python-dnspython-1.16)
("python-jsonrpclib-pelix" ,python-jsonrpclib-pelix)))
(arguments
`(#:tests? #f ; no tests
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c20e32fd79..10b271de21 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2015, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Erik Edrosa <erik.edrosa@gmail.com>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2015, 2017 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2015, 2017, 2020 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015, 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
@@ -13381,17 +13381,17 @@ (define-public python2-lazy-object-proxy
(define-public python-dnspython
(package
(name "python-dnspython")
- (version "1.16.0")
+ (version "2.0.0")
(source (origin
(method url-fetch)
- (uri (string-append "http://www.dnspython.org/kits/"
- version "/dnspython-" version ".tar.gz"))
+ (uri (pypi-uri "dnspython" version ".zip"))
(sha256
(base32
- "1yaw7irazy42n0kdhlk7wyg8ki34rxcnc5xbc1wfwy245b0wbxab"))))
+ "1dyip5ygqqhrgcaiy7qzjpndl9xciip186paxqwkm726fj9z0jh4"))))
(build-system python-build-system)
+ (native-inputs `(("unzip" ,unzip)))
(arguments '(#:tests? #f)) ; XXX: requires internet access
- (home-page "http://www.dnspython.org")
+ (home-page "https://www.dnspython.org")
(synopsis "DNS toolkit for Python")
(description
"dnspython is a DNS toolkit for Python. It supports almost all record
@@ -13399,8 +13399,21 @@ (define-public python-dnspython
It supports TSIG authenticated messages and EDNS0.")
(license license:expat)))
-(define-public python2-dnspython
- (package-with-python2 python-dnspython))
+(define-public python-dnspython-1.16
+ (package
+ (inherit python-dnspython)
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.dnspython.org/kits/"
+ version "/dnspython-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1yaw7irazy42n0kdhlk7wyg8ki34rxcnc5xbc1wfwy245b0wbxab"))))
+ (native-inputs '())))
+
+(define-public python2-dnspython-1.16
+ (package-with-python2 python-dnspython-1.16))
(define-public python-py3dns
(package
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 794e2c919d..4480ab9eb7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6418,7 +6418,7 @@ (define-public linkchecker
"03ihjmc4bqxxqv71bb43r2f23sx0xnbq1k2fsg9fw05qa5s9x187"))))
(build-system python-build-system)
(inputs
- `(("python2-dnspython" ,python2-dnspython)
+ `(("python2-dnspython" ,python2-dnspython-1.16)
("python2-pyxdg" ,python2-pyxdg)
("python2-requests" ,python2-requests)))
(native-inputs
--
2.29.2.576.ga3fc446d84
Kyle Meyer wrote 4 years ago
[PATCH 3/3] gnu: b4: Update to 0.6.1.
(address . 45111@debbugs.gnu.org)
20201208024546.21690-3-kyle@kyleam.com
* gnu/packages/version-control.scm (b4): Update to 0.6.1.
[source]: Download from pypi, which now includes the manpage.
[arguments]: Remove now unnecessary install-manpages phase.
[inputs]: Add python-dkimpy and python-dnspython.
---
gnu/packages/version-control.scm | 28 ++++++++--------------------
1 file changed, 8 insertions(+), 20 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index a3588009c0..f5df1a7a81 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2317,31 +2317,19 @@ (define-public grokmirror
(define-public b4
(package
(name "b4")
- (version "0.5.3")
+ (version "0.6.1")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.kernel.org/pub/scm/utils/b4/b4.git")
- (commit (string-append "v" version))))
- (file-name (string-append name "-" version "-checkout"))
+ (method url-fetch)
+ (uri (pypi-uri "b4" version))
(sha256
- (base32 "0bnjs758blll2i70r4qh3khma7dly5lb8s6kzn5a3p54md91s8v5"))))
+ (base32 "01qid6mvddikcdpf2ihsyn8x3z5j2n64g0ip9pqbx42hrc50pmcz"))))
(build-system python-build-system)
- (arguments
- `(#:tests? #f ; No tests.
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'install-manpages
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((man (string-append (assoc-ref outputs "out")
- "/man/man5/")))
- (mkdir-p man)
- (for-each (lambda (file) (install-file file man))
- (find-files "man" "\\.[1-8]$")))
- #t)))))
+ (arguments '(#:tests? #f)) ; No tests.
(inputs
- `(("python-requests" ,python-requests)))
+ `(("python-dkimpy" ,python-dkimpy)
+ ("python-dnspython" ,python-dnspython)
+ ("python-requests" ,python-requests)))
(home-page "https://git.kernel.org/pub/scm/utils/b4/b4.git")
(synopsis "Tool for working with patches in public-inbox archives")
(description
--
2.29.2.576.ga3fc446d84
Ludovic Courtès wrote 4 years ago
Re: [bug#45111] [PATCH 0/3] Update python-dnspython and b4
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 45111-done@debbugs.gnu.org)
87zh2gsk3q.fsf@gnu.org
Hi,

Kyle Meyer <kyle@kyleam.com> skribis:

Toggle quote (18 lines)
> The recent release of b4 adds a couple of dependencies, including the latest
> version (2.0.0) of python-dnspython. This series updates python-dnspython
> from 1.16.0 to 2.0.0, keeping a definition for the older version around for
> three packages that don't support the new version. (This includes two
> packages that had python2-dnspython as input, as dnspython 2.0.0 dropped
> support for Python 2).
>
> [1/3] gnu: python-dnspython: Fix indentation.
> [2/3] gnu: python-dnspython: Update to 2.0.0.
> [3/3] gnu: b4: Update to 0.6.1.
>
> gnu/packages/ebook.scm | 2 +-
> gnu/packages/finance.scm | 2 +-
> gnu/packages/python-xyz.scm | 51 ++++++++++++++++++++------------
> gnu/packages/version-control.scm | 28 +++++-------------
> gnu/packages/web.scm | 2 +-
> 5 files changed, 43 insertions(+), 42 deletions(-)

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45111@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45111
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help