Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/version-control.scm (gita)[arguments]: Add phase
install-shell-completions.
---
gnu/packages/version-control.scm | 15 ++++++++++++++-
1 file changed, 14 insertions(+), 1 deletion(-)
Toggle diff (35 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index a3588009c0..95d6c220c0 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -31,6 +31,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2947,7 +2948,19 @@ defects faster.")
(add-installed-pythonpath inputs outputs)
(invoke (string-append (assoc-ref inputs "python-pytest")
"/bin/pytest")
- "-vv" "tests"))))))
+ "-vv" "tests")))
+ (add-after 'install 'install-shell-completions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bash-completion (string-append out "/etc/bash_completion.d"))
+ (zsh-completion (string-append out "/etc/zsh/site-functions")))
+ (mkdir-p bash-completion)
+ (copy-file ".gita-completion.bash"
+ (string-append bash-completion "/gita"))
+ (mkdir-p zsh-completion)
+ (copy-file ".gita-completion.zsh"
+ (string-append zsh-completion "/_gita"))
+ #t))))))
(home-page "https://github.com/nosarthur/gita")
(synopsis "Command-line tool to manage multiple Git repos")
(description "This package provides a command-line tool to manage
--
2.29.2