[PATCH] gnu: shadowsocks: Build against openssl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Marius Bakke
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 4 years ago
(address . guix-patches@gnu.org)
20201207202818.12122-1-leo.prikler@student.tugraz.at
This patch allows shadowsocks to be used without supplying libopenssl in its

* gnu/packages/networking.scm (shadowsocks)[inputs]: Add openssl.
[#:phases]: Add patch-crypto-paths.
---
gnu/packages/networking.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 8a84c8476a..1f50c76962 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3024,6 +3024,19 @@ asynchronous model using a modern C++ approach.")
(base32
"1idd9b4f2pnhcpk1bh030hqg5zq25gkwxd53xi3c0cj242w7sp2j"))
(file-name (git-file-name name version))))
+ (inputs
+ `(("openssl" ,openssl)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-crypto-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "shadowsocks/shell.py"
+ (("config\\.get\\('libopenssl', None\\)")
+ (format #f "config.get('libopenssl', ~s)"
+ (string-append
+ (assoc-ref inputs "openssl")
+ "/lib/libssl.so"))))))))))
(build-system python-build-system)
(synopsis "Fast tunnel proxy that helps you bypass firewalls")
(description
--
2.29.2
Marius Bakke wrote 4 years ago
87mtyp41q5.fsf@gnu.org
Leo Prikler <leo.prikler@student.tugraz.at> skriver:

Toggle quote (6 lines)
> This patch allows shadowsocks to be used without supplying libopenssl in its
> configuration. See also https://unix.stackexchange.com/questions/623324/.
>
> * gnu/packages/networking.scm (shadowsocks)[inputs]: Add openssl.
> [#:phases]: Add patch-crypto-paths.

I fixed the syntax error and committed in
403dda2e66dc5c8f23bf66086815133546df1ba0. Thanks!
-----BEGIN PGP SIGNATURE-----

iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl/Ov0IPHG1hcml1c0Bn
bnUub3JnAAoJEKKgbfKjOlT6UwgH/3iYBGQpB5Uw3Ej5jZ43AwxKHmW7Ak+Vn5d0
GSN6CtmGof/CR7KjYEUdhHz6UAaDbCxk/dDYHD6GhM6VKJTC9JUtGjoJUA96aK1a
z5vaeRh3KiFZn4kYiXcPtyjjkoNmeVcqIEjvAVOzVtAZ/k7peyrHCJxKmm9cGBiY
0sb5KaaXSQL3E11CvRextVAMZN4T78wQ5CEI2uaqT27dvwjnUSUsNAiB0PFSTomZ
qIkJsIGQGpdjVUJA2FTJgf2kTpPos+msd614Wo7cxTZINIGzh1TSvZIxPCapq12V
JVarNTXkkfyK7YeW1tiW588uCLteX/HKpahRYg8UNjigs+7w/Zg=
=nynH
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45106@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45106
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help