[PATCH] gnu: emacs-with-editor: Update to 3.0.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201206155616.31378-1-mike@rohleder.de
* gnu/packages/emacs-xyz.scm (emacs-with-editor): Update to 3.0.2.
[propagated-inputs]: Changed emacs-dash to emacs-async.
---
gnu/packages/emacs-xyz.scm | 62 ++++++++++++++++++--------------------
1 file changed, 29 insertions(+), 33 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8a03b2d7a3..d5947cbabc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -362,42 +362,38 @@ configuration files, such as .gitattributes, .gitignore, and .git/config.")
(license license:gpl3+)))
(define-public emacs-with-editor
- ;; This commit fixes an (magit) issue with emacs 28, see
- ;; https://lists.gnu.org/archive/html/help-gnu-emacs/2020-10/msg00211.html
- (let ((commit "c4768f51c7415119519b4626d8643d60e584098c")
- (revision "1"))
- (package
- (name "emacs-with-editor")
- (version (git-version "2.9.4" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/magit/with-editor")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "01ysb9pnscpmingay6njdywkqgj4hn5l5d9igsg3x7p7061jwwix"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'install 'make-info
- (lambda _
- (invoke "makeinfo" "--no-split"
- "-o" "with-editor.info" "with-editor.texi"))))))
- (native-inputs
- `(("texinfo" ,texinfo)))
- (propagated-inputs
- `(("emacs-dash" ,emacs-dash)))
- (home-page "https://github.com/magit/with-editor")
- (synopsis "Emacs library for using Emacsclient as EDITOR")
- (description
- "This package provides an Emacs library to use the Emacsclient as
+ (package
+ (name "emacs-with-editor")
+ (version "3.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magit/with-editor")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hw6i5r3adkm4988badi94825lywkrh3sddiff4z04kj1nj15d0k"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-info
+ (lambda _
+ (invoke "makeinfo" "--no-split"
+ "-o" "with-editor.info" "with-editor.texi"))))))
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (propagated-inputs
+ `(("emacs-async" ,emacs-async)))
+ (home-page "https://github.com/magit/with-editor")
+ (synopsis "Emacs library for using Emacsclient as EDITOR")
+ (description
+ "This package provides an Emacs library to use the Emacsclient as
@code{$EDITOR} of child processes, making sure they know how to call home.
For remote processes a substitute is provided, which communicates with Emacs
on stdout instead of using a socket as the Emacsclient does.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-libgit
(let ((commit "0ef8b13aef011a98b7da756e4f1ce3bb18e4d55a")
--
2.29.2
Nicolas Goaziou wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 45074-done@debbugs.gnu.org)
874kkxzymg.fsf@nicolasgoaziou.fr
Hello,

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-with-editor): Update to 3.0.2.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45074@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45074
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help