[PATCH] gnu: freecad: Fix compilation flags

  • Done
  • quality assurance status badge
Details
2 participants
  • Ekaitz Zarraga
  • Marius Bakke
Owner
unassigned
Submitted by
Ekaitz Zarraga
Severity
normal

Debbugs page

Ekaitz Zarraga wrote 4 years ago
uukVWlWfdHgU2ykwn4t7VL8W2LnsEMneaz6ezoA0HHafPMBpWNLk-0WqMyzJmGYM-vNYBFMN7udZIFZ851kgAitatvvYf-yjE6QhbaK18Og=@elenq.tech
Hi everyone,

I managed to solve the longstanding issue with freecad's compilation (#43448).

I'll submit a new change with the package update to 0.18.5 next.

Thanks



From d4d8a65679406b212c68d5198f239bdd71395541 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Sun, 6 Dec 2020 00:43:36 +0100
Subject: [PATCH] gnu: freecad: Fix compilation flags

* gnu/packages/engineering.scm (freecad)[arguments]: Set correct
search paths in compilation flags. Fixes #43448
---
gnu/packages/engineering.scm | 24 ++++++++++++++++++++++--
1 file changed, 22 insertions(+), 2 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 558541dd5a..5a8977c940 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2496,8 +2496,28 @@ full programmatic control over your models.")
#:configure-flags
(list
"-DBUILD_QT5=ON"
- (string-append "-DCMAKE_INSTALL_LIBDIR="
- (assoc-ref %outputs "out") "/lib"))
+ (string-append "-DCMAKE_INSTALL_LIBDIR=" (assoc-ref %outputs "out") "/lib")
+
+ (string-append "-DPYSIDE2UICBINARY="
+ (assoc-ref %build-inputs "python-pyside-2-tools")
+ "/bin/uic")
+ (string-append "-DPYSIDE2RCCBINARY="
+ (assoc-ref %build-inputs "python-pyside-2-tools")
+ "/bin/rcc")
+
+ "-DPYSIDE_LIBRARY=PySide2::pyside2"
+ (string-append
+ "-DPYSIDE_INCLUDE_DIR="
+ (assoc-ref %build-inputs "python-pyside-2") "/include;"
+ (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2;"
+ (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtCore;"
+ (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtWidgets;"
+ (assoc-ref %build-inputs "python-pyside-2") "/include/PySide2/QtGui;")
+
+ "-DSHIBOKEN_LIBRARY=Shiboken2::libshiboken"
+ (string-append "-DSHIBOKEN_INCLUDE_DIR="
+ (assoc-ref %build-inputs "python-shiboken-2")
+ "/include/shiboken2"))
#:phases
(modify-phases %standard-phases
(add-before 'configure 'restore-pythonpath
--
2.28.0
Ekaitz Zarraga wrote 4 years ago
[PATCH 2/2] gnu: freecad: Update to 0.18.5
(name . 45059@debbugs.gnu.org)(address . 45059@debbugs.gnu.org)
odLtQVk60OIiXGyGn5t6N6gqVkALzcYC2275JMKZhjXAQcsaZUWK7ISRnlWrD8UL0wZDEnjwk3dZgWzBS3WVd31fvPdumMW0S022uk4eRZ8=@elenq.tech
From c223f97e9c00bc8904130199697e41236b8dad1d Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Sun, 6 Dec 2020 00:55:37 +0100
Subject: [PATCH 2/2] gnu: freecad: Update to 0.18.5

* gnu/packages/engineering.scm (freecad): Update to 0.18.5
---
gnu/packages/engineering.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 5a8977c940..e436994492 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2434,7 +2434,7 @@ full programmatic control over your models.")
(define-public freecad
(package
(name "freecad")
- (version "0.18.4")
+ (version "0.18.5")
(source
(origin
(method git-fetch)
@@ -2453,7 +2453,7 @@ full programmatic control over your models.")
(file-name (git-file-name name version))
(sha256
(base32
- "170hk1kgrvsddrwykp24wyj0cha78zzmzbf50gn98x7ngqqs395s"))))
+ "0r31jzzkamf76l19fb175hhv48irk06fpi8ldxdlr31w8c1ix4aa"))))
(build-system qt-build-system)
(native-inputs
`(("doxygen" ,doxygen)
--
2.28.0
Marius Bakke wrote 4 years ago
Re: [bug#45059] [PATCH] gnu: freecad: Fix compilation flags
871rg21v3k.fsf@gnu.org
Ekaitz Zarraga <ekaitz@elenq.tech> skriver:

Toggle quote (6 lines)
> Hi everyone,
>
> I managed to solve the longstanding issue with freecad's compilation (#43448).
>
> I'll submit a new change with the package update to 0.18.5 next.

Thanks a lot for these patches Ekaitz!

I pushed them both with 383f087cd74316d26c5c0f19b73bc620312c5477.
-----BEGIN PGP SIGNATURE-----

iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl/NTU8PHG1hcml1c0Bn
bnUub3JnAAoJEKKgbfKjOlT6yccH/3voaYocMWddD2NEOJCfUiDw5cqvKNjve5Ju
hEZVr5XGnBE9FTz3xobb6fN9YvnWiT1RnXVf6S0Ux1fHojKdJZcDkL06VUSvXD+a
hmWQ/BmZMZIi+rL2Lwao4gP2jQxbu4elLu/edxdJt9G6xaJVV1UEj5RESh4DOOrs
Wo9gaWaBCksrsukVSNuTlDiN3Hj+weQRj4cjvcKWF5ILinb2ystW3Y83/HD6qBzK
KW/bgYzNWuF9Avb/YAbbKbsCe+8Uabrh3PRNYb00vW7ZXcAjl5zgi6jodqalJdqB
BlO6+w/zAlOf7PHeG/snH8bUM6coHtNn70vu7Kqh2BtFpEZMKkI=
=zj9F
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45059@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45059
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help