[PATCH] gnu: Update emacs-guix to temporary repository.

  • Done
  • quality assurance status badge
Details
3 participants
  • John Soo
  • Ludovic Courtès
  • zimoun
Owner
unassigned
Submitted by
John Soo
Severity
normal

Debbugs page

John Soo wrote 4 years ago
(address . guix-patches@gnu.org)
87r1o4lte7.fsf@asu.edu
Hello Guix,

Since 1.2 was released, I can update emacs-guix to use my repository
with patches to make it work again. It should be updated again when
guix.el has a new home.

Kindly,

John
From 28abdd7140c31425f6add54470ad683bc46e8de7 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 12 Nov 2020 23:04:27 -0800
Subject: [PATCH] gnu: Update emacs-guix.

* gnu/packages/emacs-xyz.scm (emacs-guix): Update it, [inputs] Use guile for
guix.
---
gnu/packages/emacs-xyz.scm | 70 ++++++++++++++++++++------------------
1 file changed, 36 insertions(+), 34 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bf2312eb49..9523031095 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2795,41 +2795,43 @@ type, for example: packages, buffers, files, etc.")
(license license:gpl3+)))
(define-public emacs-guix
- (let ((commit "58a840d0671091e3064e36244790ef8839da87d6")
- (revision "2"))
+ (let* ((commit "a694fdbcedb6edd2239a31d326e475c763ee32f8")
+ (revision "1"))
(package
- (name "emacs-guix")
- (version (git-version "0.5.2" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/emacs-guix/emacs-guix")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1qnr5sixmvrhr9rinrhfy7sy20mikjvvwbdixwkbx30qpcdwgwj1"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)
- ("emacs" ,emacs-minimal)))
- (inputs
- `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
- ("guix" ,guix)))
- (propagated-inputs
- `(("geiser" ,emacs-geiser)
- ("guile-gcrypt" ,guile-gcrypt)
- ("dash" ,emacs-dash)
- ("bui" ,emacs-bui)
- ("edit-indirect" ,emacs-edit-indirect)
- ("magit-popup" ,emacs-magit-popup)))
- (home-page "https://emacs-guix.gitlab.io/website/")
- (synopsis "Emacs interface for GNU Guix")
- (description
- "Emacs-Guix provides a visual interface, tools and features for the GNU
+ (name "emacs-guix")
+ (version (git-version "0.5.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; TODO: Use the official version when it has a new home
+ (url "https://github.com/jsoo1/guix.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pqw7zbgxzwpig4xr0izc3z8h80c72i6bl5yi12br0d7aq6dbkvj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)
+ ("emacs" ,emacs-minimal)))
+ (inputs
+ `(("guile"
+ ,@(assoc-ref (package-native-inputs guix) "guile"))
+ ("guix" ,guix)))
+ (propagated-inputs
+ `(("geiser" ,emacs-geiser)
+ ("guile-gcrypt" ,guile-gcrypt)
+ ("dash" ,emacs-dash)
+ ("bui" ,emacs-bui)
+ ("edit-indirect" ,emacs-edit-indirect)
+ ("magit-popup" ,emacs-magit-popup)))
+ (home-page "https://emacs-guix.gitlab.io/website/")
+ (synopsis "Emacs interface for GNU Guix")
+ (description
+ "Emacs-Guix provides a visual interface, tools and features for the GNU
Guix package manager. Particularly, it allows you to do various package
management tasks from Emacs. To begin with, run @code{M-x guix-about} or
@code{M-x guix-help} command.")
--
2.29.2
From 28abdd7140c31425f6add54470ad683bc46e8de7 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 12 Nov 2020 23:04:27 -0800
Subject: [PATCH] gnu: Update emacs-guix.

* gnu/packages/emacs-xyz.scm (emacs-guix): Update it, [inputs] Use guile for
guix.
---
gnu/packages/emacs-xyz.scm | 70 ++++++++++++++++++++------------------
1 file changed, 36 insertions(+), 34 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bf2312eb49..9523031095 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2795,41 +2795,43 @@ type, for example: packages, buffers, files, etc.")
(license license:gpl3+)))
(define-public emacs-guix
- (let ((commit "58a840d0671091e3064e36244790ef8839da87d6")
- (revision "2"))
+ (let* ((commit "a694fdbcedb6edd2239a31d326e475c763ee32f8")
+ (revision "1"))
(package
- (name "emacs-guix")
- (version (git-version "0.5.2" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/emacs-guix/emacs-guix")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1qnr5sixmvrhr9rinrhfy7sy20mikjvvwbdixwkbx30qpcdwgwj1"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)
- ("emacs" ,emacs-minimal)))
- (inputs
- `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
- ("guix" ,guix)))
- (propagated-inputs
- `(("geiser" ,emacs-geiser)
- ("guile-gcrypt" ,guile-gcrypt)
- ("dash" ,emacs-dash)
- ("bui" ,emacs-bui)
- ("edit-indirect" ,emacs-edit-indirect)
- ("magit-popup" ,emacs-magit-popup)))
- (home-page "https://emacs-guix.gitlab.io/website/")
- (synopsis "Emacs interface for GNU Guix")
- (description
- "Emacs-Guix provides a visual interface, tools and features for the GNU
+ (name "emacs-guix")
+ (version (git-version "0.5.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; TODO: Use the official version when it has a new home
+ (url "https://github.com/jsoo1/guix.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pqw7zbgxzwpig4xr0izc3z8h80c72i6bl5yi12br0d7aq6dbkvj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)
+ ("emacs" ,emacs-minimal)))
+ (inputs
+ `(("guile"
+ ,@(assoc-ref (package-native-inputs guix) "guile"))
+ ("guix" ,guix)))
+ (propagated-inputs
+ `(("geiser" ,emacs-geiser)
+ ("guile-gcrypt" ,guile-gcrypt)
+ ("dash" ,emacs-dash)
+ ("bui" ,emacs-bui)
+ ("edit-indirect" ,emacs-edit-indirect)
+ ("magit-popup" ,emacs-magit-popup)))
+ (home-page "https://emacs-guix.gitlab.io/website/")
+ (synopsis "Emacs interface for GNU Guix")
+ (description
+ "Emacs-Guix provides a visual interface, tools and features for the GNU
Guix package manager. Particularly, it allows you to do various package
management tasks from Emacs. To begin with, run @code{M-x guix-about} or
@code{M-x guix-help} command.")
--
2.29.2
John Soo wrote 4 years ago
Oops!
(name . 45050)(address . 45050@debbugs.gnu.org)
3c9105a6-f195-4e27-a6ea-359733e3686d@Johns-iPhone
Just one of those patches is required, sorry!
Attachment: file
zimoun wrote 4 years ago
Re: [bug#45050] [PATCH] gnu: Update emacs-guix to temporary repository.
(name . John Soo)(address . jsoo1@asu.edu)(address . 45050@debbugs.gnu.org)
86sg8h61wm.fsf@gmail.com
Hi John,

On Fri, 04 Dec 2020 at 21:21, John Soo <jsoo1@asu.edu> wrote:
Toggle quote (6 lines)
> Hello Guix,
>
> Since 1.2 was released, I can update emacs-guix to use my repository
> with patches to make it work again. It should be updated again when
> guix.el has a new home.

News about the new home?

Toggle quote (4 lines)
> + (uri (git-reference
> + ;; TODO: Use the official version when it has a new home
> + (url "https://github.com/jsoo1/guix.el")

Is it the most recent version where patches are applied?


Cheers,
simon
John Soo wrote 4 years ago
(name . zimoun)(address . zimon.toutoune@gmail.com)(name . 45050)(address . 45050@debbugs.gnu.org)
f15de0b0-c53d-48eb-92f1-9c16ee8c9413@Johns-iPhone
Hi zimoun,

I still haven’t heard from the original maintainer about moving the sources to savannah. I sent an email maybe a week or two ago.

The source I added here does have patches applied to make it work. My goal is to switch the source again when it ends up wherever it finally finds a new official location.

What do you think?

- John
Attachment: file
zimoun wrote 4 years ago
(name . John Soo)(address . jsoo1@asu.edu)(name . 45050)(address . 45050@debbugs.gnu.org)
86mtyp5zdt.fsf@gmail.com
Hi,

On Mon, 07 Dec 2020 at 08:15, John Soo <jsoo1@asu.edu> wrote:

Toggle quote (4 lines)
> The source I added here does have patches applied to make it work. My
> goal is to switch the source again when it ends up wherever it finally
> finds a new official location.

Sounds good!

Cheers,
simon
Ludovic Courtès wrote 4 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 45050@debbugs.gnu.org)
87zh2k44l6.fsf@gnu.org
Hi!

John Soo <jsoo1@asu.edu> skribis:

Toggle quote (8 lines)
>>From 28abdd7140c31425f6add54470ad683bc46e8de7 Mon Sep 17 00:00:00 2001
> From: John Soo <jsoo1@asu.edu>
> Date: Thu, 12 Nov 2020 23:04:27 -0800
> Subject: [PATCH] gnu: Update emacs-guix.
>
> * gnu/packages/emacs-xyz.scm (emacs-guix): Update it, [inputs] Use guile for
> guix.

If it fixes one of the bugs in the tracker, we can mention it in the
commit log with “Fixes https://bugs.gnu.org/XYZ.”

Toggle quote (6 lines)
> (define-public emacs-guix
> - (let ((commit "58a840d0671091e3064e36244790ef8839da87d6")
> - (revision "2"))
> + (let* ((commit "a694fdbcedb6edd2239a31d326e475c763ee32f8")
> + (revision "1"))

Please increment the revision number rather than decrement it.

Toggle quote (4 lines)
> (package
> - (name "emacs-guix")
> - (version (git-version "0.5.2" revision commit))

Please don’t reindent, the original formatting was fine. :-)

Could you send an updated patch?

I guess it’s fine to use your repo until we hear from Alex Kost.

Thanks for taking care of this!

Ludo’.
John Soo wrote 4 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 45050@debbugs.gnu.org)
87tussw0jc.fsf@asu.edu
Hello!

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (6 lines)
>> * gnu/packages/emacs-xyz.scm (emacs-guix): Update it, [inputs] Use guile for
>> guix.
>
> If it fixes one of the bugs in the tracker, we can mention it in the
> commit log with “Fixes <https://bugs.gnu.org/XYZ>.”

Alright, done.

Toggle quote (8 lines)
>> (define-public emacs-guix
>> - (let ((commit "58a840d0671091e3064e36244790ef8839da87d6")
>> - (revision "2"))
>> + (let* ((commit "a694fdbcedb6edd2239a31d326e475c763ee32f8")
>> + (revision "1"))
>
> Please increment the revision number rather than decrement it.

Ah yes, sorry I thought it would be the "revision at commit". I bumped
it to rev 3.

Toggle quote (6 lines)
>> (package
>> - (name "emacs-guix")
>> - (version (git-version "0.5.2" revision commit))
>
> Please don’t reindent, the original formatting was fine. :-)

Oh oops, sorry. I think I forgot to reindent after a previous revision.

Toggle quote (2 lines)
> I guess it’s fine to use your repo until we hear from Alex Kost.

Hopefully soon :)

Thanks for your review,

John
From 4fd99ba6fa6ef61e1077f1fcad6b5d56bbbbf69a Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 12 Nov 2020 23:04:27 -0800
Subject: [PATCH] gnu: Update emacs-guix.

* gnu/packages/emacs-xyz.scm (emacs-guix): Update it, [inputs] Use guile for
guix.
---
gnu/packages/emacs-xyz.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ceb99f402d..5798af80d6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2795,20 +2795,21 @@ type, for example: packages, buffers, files, etc.")
(license license:gpl3+)))
(define-public emacs-guix
- (let ((commit "58a840d0671091e3064e36244790ef8839da87d6")
- (revision "2"))
+ (let* ((commit "a694fdbcedb6edd2239a31d326e475c763ee32f8")
+ (revision "3"))
(package
(name "emacs-guix")
(version (git-version "0.5.2" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://gitlab.com/emacs-guix/emacs-guix")
+ ;; TODO: Use the official version when it has a new home
+ (url "https://github.com/jsoo1/guix.el")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "1qnr5sixmvrhr9rinrhfy7sy20mikjvvwbdixwkbx30qpcdwgwj1"))))
+ "1pqw7zbgxzwpig4xr0izc3z8h80c72i6bl5yi12br0d7aq6dbkvj"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -2817,7 +2818,8 @@ type, for example: packages, buffers, files, etc.")
("texinfo" ,texinfo)
("emacs" ,emacs-minimal)))
(inputs
- `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
+ `(("guile"
+ ,@(assoc-ref (package-native-inputs guix) "guile"))
("guix" ,guix)))
(propagated-inputs
`(("geiser" ,emacs-geiser)
--
2.29.2
Ludovic Courtès wrote 4 years ago
(name . John Soo)(address . jsoo1@asu.edu)(address . 45050-done@debbugs.gnu.org)
87pn3e3otp.fsf@gnu.org
Hi John,

John Soo <jsoo1@asu.edu> skribis:

Toggle quote (9 lines)
> From 4fd99ba6fa6ef61e1077f1fcad6b5d56bbbbf69a Mon Sep 17 00:00:00 2001
> From: John Soo <jsoo1@asu.edu>
> Date: Thu, 12 Nov 2020 23:04:27 -0800
> Subject: [PATCH] gnu: Update emacs-guix.
>
> * gnu/packages/emacs-xyz.scm (emacs-guix): Update it, [inputs] Use guile for
> guix.
> * Fixes https://bugs.gnu.org/44062

I tweaked the commit log according to our conventions and applied it.
Great to see these fixes land, thanks!

BTW, I think it would be nice to preserve ChangeLog-style commit logs in
Emacs-Guix too, as has been done until now.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 45050@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 45050
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help