John Soo wrote 4 years ago
(address . guix-patches@gnu.org)
Hello Guix,
Since 1.2 was released, I can update emacs-guix to use my repository
with patches to make it work again. It should be updated again when
guix.el has a new home.
Kindly,
John
From 28abdd7140c31425f6add54470ad683bc46e8de7 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 12 Nov 2020 23:04:27 -0800
Subject: [PATCH] gnu: Update emacs-guix.
* gnu/packages/emacs-xyz.scm (emacs-guix): Update it, [inputs] Use guile for
guix.
---
gnu/packages/emacs-xyz.scm | 70 ++++++++++++++++++++------------------
1 file changed, 36 insertions(+), 34 deletions(-)
Toggle diff (84 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bf2312eb49..9523031095 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2795,41 +2795,43 @@ type, for example: packages, buffers, files, etc.")
(license license:gpl3+)))
(define-public emacs-guix
- (let ((commit "58a840d0671091e3064e36244790ef8839da87d6")
- (revision "2"))
+ (let* ((commit "a694fdbcedb6edd2239a31d326e475c763ee32f8")
+ (revision "1"))
(package
- (name "emacs-guix")
- (version (git-version "0.5.2" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/emacs-guix/emacs-guix")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1qnr5sixmvrhr9rinrhfy7sy20mikjvvwbdixwkbx30qpcdwgwj1"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)
- ("emacs" ,emacs-minimal)))
- (inputs
- `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
- ("guix" ,guix)))
- (propagated-inputs
- `(("geiser" ,emacs-geiser)
- ("guile-gcrypt" ,guile-gcrypt)
- ("dash" ,emacs-dash)
- ("bui" ,emacs-bui)
- ("edit-indirect" ,emacs-edit-indirect)
- ("magit-popup" ,emacs-magit-popup)))
- (home-page "https://emacs-guix.gitlab.io/website/")
- (synopsis "Emacs interface for GNU Guix")
- (description
- "Emacs-Guix provides a visual interface, tools and features for the GNU
+ (name "emacs-guix")
+ (version (git-version "0.5.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; TODO: Use the official version when it has a new home
+ (url "https://github.com/jsoo1/guix.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pqw7zbgxzwpig4xr0izc3z8h80c72i6bl5yi12br0d7aq6dbkvj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)
+ ("emacs" ,emacs-minimal)))
+ (inputs
+ `(("guile"
+ ,@(assoc-ref (package-native-inputs guix) "guile"))
+ ("guix" ,guix)))
+ (propagated-inputs
+ `(("geiser" ,emacs-geiser)
+ ("guile-gcrypt" ,guile-gcrypt)
+ ("dash" ,emacs-dash)
+ ("bui" ,emacs-bui)
+ ("edit-indirect" ,emacs-edit-indirect)
+ ("magit-popup" ,emacs-magit-popup)))
+ (home-page "https://emacs-guix.gitlab.io/website/")
+ (synopsis "Emacs interface for GNU Guix")
+ (description
+ "Emacs-Guix provides a visual interface, tools and features for the GNU
Guix package manager. Particularly, it allows you to do various package
management tasks from Emacs. To begin with, run @code{M-x guix-about} or
@code{M-x guix-help} command.")
--
2.29.2
From 28abdd7140c31425f6add54470ad683bc46e8de7 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 12 Nov 2020 23:04:27 -0800
Subject: [PATCH] gnu: Update emacs-guix.
* gnu/packages/emacs-xyz.scm (emacs-guix): Update it, [inputs] Use guile for
guix.
---
gnu/packages/emacs-xyz.scm | 70 ++++++++++++++++++++------------------
1 file changed, 36 insertions(+), 34 deletions(-)
Toggle diff (84 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bf2312eb49..9523031095 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2795,41 +2795,43 @@ type, for example: packages, buffers, files, etc.")
(license license:gpl3+)))
(define-public emacs-guix
- (let ((commit "58a840d0671091e3064e36244790ef8839da87d6")
- (revision "2"))
+ (let* ((commit "a694fdbcedb6edd2239a31d326e475c763ee32f8")
+ (revision "1"))
(package
- (name "emacs-guix")
- (version (git-version "0.5.2" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/emacs-guix/emacs-guix")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1qnr5sixmvrhr9rinrhfy7sy20mikjvvwbdixwkbx30qpcdwgwj1"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)
- ("emacs" ,emacs-minimal)))
- (inputs
- `(("guile" ,@(assoc-ref (package-native-inputs guix) "guile"))
- ("guix" ,guix)))
- (propagated-inputs
- `(("geiser" ,emacs-geiser)
- ("guile-gcrypt" ,guile-gcrypt)
- ("dash" ,emacs-dash)
- ("bui" ,emacs-bui)
- ("edit-indirect" ,emacs-edit-indirect)
- ("magit-popup" ,emacs-magit-popup)))
- (home-page "https://emacs-guix.gitlab.io/website/")
- (synopsis "Emacs interface for GNU Guix")
- (description
- "Emacs-Guix provides a visual interface, tools and features for the GNU
+ (name "emacs-guix")
+ (version (git-version "0.5.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; TODO: Use the official version when it has a new home
+ (url "https://github.com/jsoo1/guix.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pqw7zbgxzwpig4xr0izc3z8h80c72i6bl5yi12br0d7aq6dbkvj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)
+ ("emacs" ,emacs-minimal)))
+ (inputs
+ `(("guile"
+ ,@(assoc-ref (package-native-inputs guix) "guile"))
+ ("guix" ,guix)))
+ (propagated-inputs
+ `(("geiser" ,emacs-geiser)
+ ("guile-gcrypt" ,guile-gcrypt)
+ ("dash" ,emacs-dash)
+ ("bui" ,emacs-bui)
+ ("edit-indirect" ,emacs-edit-indirect)
+ ("magit-popup" ,emacs-magit-popup)))
+ (home-page "https://emacs-guix.gitlab.io/website/")
+ (synopsis "Emacs interface for GNU Guix")
+ (description
+ "Emacs-Guix provides a visual interface, tools and features for the GNU
Guix package manager. Particularly, it allows you to do various package
management tasks from Emacs. To begin with, run @code{M-x guix-about} or
@code{M-x guix-help} command.")
--
2.29.2