(address . bug-guix@gnu.org)
Hi Guix,
I tried to use bpftrace recently and discovered I needed the right
kernel headers compiled in (5.9 being the default now). Perhaps
linux-libre-headers should be upgraded to 5.9 instead?
What do you think?
- John
From bf8d069f70fecc8e24a795efa69252d1cf9b1865 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Fri, 4 Dec 2020 20:36:11 -0800
Subject: [PATCH 1/2] gnu: Use 5.9 kernel headers for bcc.
* gnu/packages/linux.scm (bcc): [inputs] Update dependency.
---
gnu/packages/linux.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3d36468172..ce88ad3348 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7472,7 +7472,7 @@ headers.")
;; archives, only object files.
;; https://github.com/iovisor/bcc/issues/504
("elfutils" ,elfutils)
- ("linux-libre-headers" ,linux-libre-headers)
+ ("linux-libre-headers" ,linux-libre-headers-5.9)
("luajit" ,luajit)
("python-wrapper" ,python-wrapper)))
(arguments
--
2.29.2
From c6f6595d6103f310f5925941edc3696def1826b4 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Fri, 4 Dec 2020 20:37:15 -0800
Subject: [PATCH 2/2] gnu: Use 5.9 kernel headers for bpftrace.
* gnu/packages/linux.scm (bpftrace): [inputs] Update dependency.
---
gnu/packages/linux.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ce88ad3348..dae3efd462 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7552,7 +7552,7 @@ and above.")
("clang-toolchain" ,clang-toolchain)
("elfutils" ,elfutils)
("libbpf" ,libbpf)
- ("linux-libre-headers" ,linux-libre-headers)))
+ ("linux-libre-headers" ,linux-libre-headers-5.9)))
(arguments
`(#:tests? #f ;Tests require googletest sources.
#:configure-flags
--
2.29.2