[PATCH] gnu: Add sbcl-cl-autowrap.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 2 Dec 2020 17:23
(name . Guix Patches)(address . guix-patches@gnu.org)
MNZG0pN--3-2@tuta.io
From de92a49158d1be1afcda9d87c4391f7e1da6fca0 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 2 Dec 2020 19:22:00 +0300
Subject: [PATCH] gnu: Add sbcl-cl-autowrap.

* gnu/packages/lisp-xyz.scm (sbcl-cl-autowrap): New variable.
---
 gnu/packages/lisp-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2bfd1e7..cd6b9b5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5602,6 +5602,41 @@ extension-points via the concept of hooks.")
 (define-public ecl-cl-hooks
   (sbcl-package->ecl-package sbcl-cl-hooks))
 
+(define-public sbcl-cl-autowrap
+  (let ((revision "1")
+        (commit "ae846d6968fc0d000de0c541638929a157f3009e"))
+    ;; no taged branches
+    (package
+      (name "sbcl-cl-autowrap")
+      (version (git-version "1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/rpav/cl-autowrap")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1gisldp2zns92kdcaikghm7c38ldy2d884n8bfg0wcjvbz78p3ar"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)
+     ("cffi" ,sbcl-cffi)
+     ("sbcl-cl-json" ,sbcl-cl-json)
+     ("cl-ppcre" ,sbcl-cl-ppcre)
+     ("sbcl-defpackage-plus" ,sbcl-defpackage-plus)))
+      (home-page "https://github.com/rpav/cl-autowrap")
+      (synopsis "(c-include \"file.h\") => complete FFI wrapper")
+      (description "Using its own facilities, autowrap now includes autowrap/libffi. 
+This allows functions that pass and return structs to be called using autowrap.")
+      (license license:bsd-2))))
+
+(define-public cl-autowrap
+  (sbcl-package->cl-source-package sbcl-cl-autowrap))
+
+(define-public ecl-cl-autowrap
+  (sbcl-package->ecl-package sbcl-cl-autowrap))
+
 (define-public sbcl-s-sysdeps
   ;; No release since 2013.
   (let ((commit "9aa23bbdceb24bcdbe0e7c39fa1901858f823106")
--
2.28.0
G
G
Guillaume Le Vaillant wrote on 5 Dec 2020 16:25
(name . Adam Kandur)(address . rndd@tuta.io)(address . 45008@debbugs.gnu.org)
871rg4qnqb.fsf@yamatai
I have never used this library, but according to the documentation,
cl-autowrap is based on c2ffi, which is not in the inputs of the package
definition (in fact it's not even packaged in Guix yet).

Does the library work without c2ffi? If yes, are there some major
features missing in this case?
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCX8umXA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/EnAD/dSQD3cL+i0Qlq1TjlIqv0AFeC9Oe3oEVSDDW
fFizXHYBAJrCdajtS1TEIsSZBW9x7+poz+aFwTYzddiiYFyLjxos
=FWL2
-----END PGP SIGNATURE-----

G
G
Guillaume Le Vaillant wrote on 11 Dec 2020 19:24
(name . Adam Kandur)(address . rndd@tuta.io)(address . 45008-done@debbugs.gnu.org)
87r1nw42vv.fsf@yamatai
Adam Kandur <rndd@tuta.io> skribis:

Toggle quote (13 lines)
> hi, for me build is fine, when i use "guix environment --ad-hoc sbcl sbcl-cl-autowrap" and then "(require :cl-autowrap)" it returns nil.
>
> Dec 5, 2020, 15:25 by glv@posteo.net:
>
>>
>> I have never used this library, but according to the documentation,
>> cl-autowrap is based on c2ffi, which is not in the inputs of the package
>> definition (in fact it's not even packaged in Guix yet).
>>
>> Does the library work without c2ffi? If yes, are there some major
>> features missing in this case?
>>

Pushed as 703cdbbd33cc7ae4b00f82fc2418317cdec4bd52 with some
modifications. Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCX9O5ZA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j9hYAEAjopfMk2Mqe/9xYy1gwiyoNy+GreEeO5EiwXQ
LqdNYzwBAIcDYqrOmfuhSd3AF0lqW1UEYsKQxCcz8fAKihvdlSaz
=0WYg
-----END PGP SIGNATURE-----

Closed
?