[PATCH] gnu: poetry: Fix a problem with a dependency.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 2 Dec 2020 09:33
(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20201202083354.19350-1-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (poetry)[arguments]: Relax version constraints
for python-packaging.
---
gnu/packages/python-xyz.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bffb643258..67447bdfa5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13227,7 +13227,10 @@ compatible build front-ends to build Poetry managed projects.")
(substitute* "setup.py"
;; Newer versions of keyring produce a package with version "0.0.0"
;; Reported upstream: <https://github.com/jaraco/keyring/issues/469>
- (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0"))
+ (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0")
+ ;; TODO: remove after the next release cycle,
+ ;; when packaging has been updated.
+ (("packaging>=20.4,<21.0") "packaging>=20.0,<21.0"))
#t)))))
(propagated-inputs
`(("python-cachecontrol" ,python-cachecontrol)
--
2.29.2
M
M
Marius Bakke wrote on 3 Dec 2020 22:47
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
87o8jaimtw.fsf@gnu.org
Tanguy Le Carrour <tanguy@bioneland.org> skriver:

Toggle quote (3 lines)
> * gnu/packages/python-xyz.scm (poetry)[arguments]: Relax version constraints
> for python-packaging.

Applied, thanks!

Note: I tried to do this:
Toggle diff (75 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bffb643258..ce4695a956 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16003,17 +16003,15 @@ several utilities, as well as an API for building localization tools.")
(define-public python-packaging
(package
(name "python-packaging")
- (version "20.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "packaging" version))
- ;; XXX: The URL in the patch file is wrong, it should be
- ;; <https://github.com/pypa/packaging/pull/256>.
- (patches (search-patches "python-packaging-test-arch.patch"))
- (sha256
- (base32
- "1y2ip3a4ykkpgnwgn85j6hkspcl0cg3mzms97f40mk57vwqq67gy"))))
+ ;; Note: when updating this, be careful not to change the 'bootstrap'
+ ;; variant below, which can only be updated on 'core-updates'.
+ (version "20.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "packaging" version))
+ (sha256
+ (base32
+ "1y3rc1ams1i25calk6b9jf1gl85ix5a23a146swjvhdr8x7zfms3"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -16046,25 +16044,26 @@ information.")
;; Variants with minimal dependencies, for bootstrapping Pytest.
(define-public python-packaging-bootstrap
(hidden-package
- (package/inherit
- python-packaging
- (name "python-packaging-bootstrap")
- (native-inputs '())
- (propagated-inputs
- `(("python-pyparsing" ,python-pyparsing)))
- (arguments '(#:tests? #f)))))
+ (package
+ (inherit python-packaging)
+ (version "20.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "packaging" version))
+ ;; XXX: The URL in the patch file is wrong, it should be
+ ;; <https://github.com/pypa/packaging/pull/256>.
+ (patches (search-patches "python-packaging-test-arch.patch"))
+ (sha256
+ (base32
+ "1y2ip3a4ykkpgnwgn85j6hkspcl0cg3mzms97f40mk57vwqq67gy"))))
+ (name "python-packaging-bootstrap")
+ (native-inputs '())
+ (propagated-inputs
+ `(("python-pyparsing" ,python-pyparsing)))
+ (arguments '(#:tests? #f)))))
(define-public python2-packaging-bootstrap
- (hidden-package
- (package/inherit
- python2-packaging
- (name "python2-packaging-bootstrap")
- (native-inputs '())
- (propagated-inputs
- `(("python-pyparsing" ,python2-pyparsing)))
- (arguments
- `(#:tests? #f
- ,@(package-arguments python2-packaging))))))
+ (package-with-python2 python-packaging-bootstrap))
(define-public python-relatorio
(package
But the test suite actually picks the 'python-packaging' that is
propagated from 'pytest', and promptly fails.

Updating packaging alone is also a staging-level change, so I did not
dig much further. But there is some room for improvement here. Maybe
by (setenv "PYTHONPATH" (string-append ".:" (getenv "PYTHONPATH"))) ?

I also wonder whether pytest needs to propagate packaging at all, or if
wrapping is enough. Do you know how common it is to "import pytest" or
"from pytest import foo", and whether those code paths would need
'packaging'?

Anyway, future problems! Thanks for maintaining Poetry. :-)
-----BEGIN PGP SIGNATURE-----

iQFDBAEBCgAtFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl/JXOsPHG1hcml1c0Bn
bnUub3JnAAoJEKKgbfKjOlT6ARYIAJNi2/8KUvCDKQVwO1pYEe0LkRFs/9gJtR1b
Vlb3f5wRPLhG2U8sYb8ge93Pp0fNDeE6dxGTGa4ATZ0Z4wTtrLfPU7fXpEk8C+tM
awZ0LVSzv54N7/Z146bcRdkW1cqvKOE0qmZKS6XlRrO6YX/IV0+Kml5CHJ27BmEP
+yellSh/fK+SnQf7hqvmuHyuhFjHIQt8n3nx1PZDKyHsfq/O0HJhXMTvqJr58qDn
fklxQw8QcHozO2wZGFTcUNabmsXIzpwRnZKoHsx9HyvNGcvb7s2hLyixlRY6q4T0
3sLTTE78oT5uIWgK7dCovUBapjJccFU2U0Yx8Ozfdxnqogi6Rb4=
=QILR
-----END PGP SIGNATURE-----

Closed
T
T
Tanguy LE CARROUR wrote on 4 Dec 2020 08:23
1607066408.sa1r45l72s.astroid@melmoth.none
Hi Marius!


Excerpts from Marius Bakke's message of December 3, 2020 10:47 pm:
Toggle quote (7 lines)
> Tanguy Le Carrour <tanguy@bioneland.org> skriver:
>
>> * gnu/packages/python-xyz.scm (poetry)[arguments]: Relax version constraints
>> for python-packaging.
>
> Applied, thanks!

Thanks!


Toggle quote (16 lines)
> Note: I tried to do this:
> […]
> But the test suite actually picks the 'python-packaging' that is
> propagated from 'pytest', and promptly fails.
>
> Updating packaging alone is also a staging-level change, so I did not
> dig much further. But there is some room for improvement here. Maybe
> by (setenv "PYTHONPATH" (string-append ".:" (getenv "PYTHONPATH"))) ?
>
> I also wonder whether pytest needs to propagate packaging at all, or if
> wrapping is enough. Do you know how common it is to "import pytest" or
> "from pytest import foo", and whether those code paths would need
> 'packaging'?
>
> Anyway, future problems! Thanks for maintaining Poetry. :-)

I would hardly call it "maintaining"! It's been more like a struggle! ^_^'
Now that the situation has (hopefully) stabilized, I can spend some time
on the "poetry build system".

Thank you again for your precious help and your time!

--
Tanguy
Closed
T
T
Tanguy LE CARROUR wrote on 4 Dec 2020 08:35
1607066633.9zez5fcynx.astroid@melmoth.none
*Oups*, I sent my message to quickly…


Excerpts from Marius Bakke's message of December 3, 2020 10:47 pm:
Toggle quote (4 lines)
> Updating packaging alone is also a staging-level change, so I did not
> dig much further. But there is some room for improvement here. Maybe
> by (setenv "PYTHONPATH" (string-append ".:" (getenv "PYTHONPATH"))) ?

Actually, I noticed some weird things when using Poetry, that might be
related to PYTHONPATH. Even if it was installed in its own profile, it
was using python packages installed outside of it. Can't remember for
sure, but I think it was `virtualenv`.
I had to unset my PYTHONPATH to make it use the ones installed in the profile.
But, now that the versions are the same in the default profile and in
this dedicated Poetry profile, everything seems to be working just fine.


Toggle quote (5 lines)
> I also wonder whether pytest needs to propagate packaging at all, or if
> wrapping is enough. Do you know how common it is to "import pytest" or
> "from pytest import foo", and whether those code paths would need
> 'packaging'?

Usually, one would only do this in the test suite, or in a package that
extends pytest behaviour. At least it's what I see from the 450,942 results
I've found on Github. But I have to confess that I did not go through
all of them! ^_^'

Regards

--
Tanguy
Closed
?