* gnu/packages/haskell-apps.scm (git-annex): Enable git-annex assistant
webapp.
---
gnu/packages/haskell-apps.scm | 15 ++++++++++++++-
1 file changed, 14 insertions(+), 1 deletion(-)
Toggle diff (60 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index da1bd2128c..2d6fac234f 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -350,7 +350,7 @@ to @code{cabal repl}).")
(build-system haskell-build-system)
(arguments
`(#:configure-flags
- '("--flags=-Android -Webapp")
+ '("--flags=-Android Webapp")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-shell-for-tests
@@ -441,9 +441,11 @@ to @code{cabal repl}).")
("ghc-aeson" ,ghc-aeson)
("ghc-async" ,ghc-async)
("ghc-aws" ,ghc-aws)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)
("ghc-bloomfilter" ,ghc-bloomfilter)
("ghc-byteable" ,ghc-byteable)
("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-clientsession" ,ghc-clientsession)
("ghc-concurrent-output" ,ghc-concurrent-output)
("ghc-crypto-api" ,ghc-crypto-api)
("ghc-cryptonite" ,ghc-cryptonite)
@@ -473,6 +475,7 @@ to @code{cabal repl}).")
("ghc-network-multicast" ,ghc-network-multicast)
("ghc-old-locale" ,ghc-old-locale)
("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-path-pieces" ,ghc-path-pieces)
("ghc-persistent" ,ghc-persistent)
("ghc-persistent-sqlite" ,ghc-persistent-sqlite)
("ghc-persistent-template" ,ghc-persistent-template)
@@ -483,14 +486,24 @@ to @code{cabal repl}).")
("ghc-safesemaphore" ,ghc-safesemaphore)
("ghc-sandi" ,ghc-sandi)
("ghc-securemem" ,ghc-securemem)
+ ("ghc-shakespeare" ,ghc-shakespeare)
("ghc-socks" ,ghc-socks)
("ghc-split" ,ghc-split)
("ghc-stm-chans" ,ghc-stm-chans)
("ghc-tagsoup" ,ghc-tagsoup)
+ ("ghc-template-haskell" ,ghc-template-haskell)
("ghc-unix-compat" ,ghc-unix-compat)
("ghc-unordered-containers" ,ghc-unordered-containers)
("ghc-utf8-string" ,ghc-utf8-string)
("ghc-uuid" ,ghc-uuid)
+ ("ghc-wai" ,ghc-wai)
+ ("ghc-wai-extra" ,ghc-wai-extra)
+ ("ghc-warp" ,ghc-warp)
+ ("ghc-warp-tls" ,ghc-warp-tls)
+ ("ghc-yesod" ,ghc-yesod)
+ ("ghc-yesod-core" ,ghc-yesod-core)
+ ("ghc-yesod-form" ,ghc-yesod-form)
+ ("ghc-yesod-static" ,ghc-yesod-static)
("git" ,git)
("rsync" ,rsync)))
(native-inputs
--
2.29.2