[PATCH 0/7] Update trezord to 2.0.30

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Martin Becze
Owner
unassigned
Submitted by
Martin Becze
Severity
normal
M
M
Martin Becze wrote on 30 Nov 2020 21:17
(address . guix-patches@gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20201130201757.27248-1-mjbecze@riseup.net
This updates trezod to 2.0.30

Martin Becze (7):
gnu: go-github-com-gorilla-mux: Update to 1.8.0.
gnu: Added go-github-com-felixge-httpsnoop.
gnu: Added go-github-com-gorilla-handlers.
gnu: Added go-github-com-gorilla-securecookie.
gnu: Added go-github-com-gorilla-csrf.
gnu: Added go-gopkg-in-natefinch-lumberjack.v2.
gnu: trezord: Updated to 2.0.30.

gnu/packages/finance.scm | 14 ++-
gnu/packages/golang.scm | 186 ++++++++++++++++++++++++++++++++-------
2 files changed, 165 insertions(+), 35 deletions(-)

--
2.29.2
M
M
Martin Becze wrote on 30 Nov 2020 21:24
[PATCH 1/7] gnu: go-github-com-gorilla-mux: Update to 1.8.0.
(address . 44969@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20201130202408.27437-1-mjbecze@riseup.net
* gnu/packages/golang.scm (go-github-com-gorilla-mux): Update to 1.8.0.
---
gnu/packages/golang.scm | 60 ++++++++++++++++++++---------------------
1 file changed, 29 insertions(+), 31 deletions(-)

Toggle diff (86 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 92533cfd50..fed32d65ec 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1307,50 +1307,48 @@ values for the purpose of fuzz testing.")
(license license:bsd-3))))
(define-public go-github-com-gorilla-mux
- (let ((commit "599cba5e7b6137d46ddf58fb1765f5d928e69604")
+ (package
+ (name "go-github-com-gorilla-mux")
+ (version "1.8.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/mux")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18f0q9qxgq1yh4ji07mqhiydfcwvi56z9d775v7dc7yckj33kpdk"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/gorilla/mux"))
+ (home-page "https://github.com/gorilla/mux")
+ (synopsis "URL router and dispatcher for Go")
+ (description
+ "Gorilla/Mux implements a request router and dispatcher for matching
+incoming requests with their respective handler.")
+ (license license:bsd-3)))
+
+(define-public go-github-com-jonboulle-clockwork
+ (let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
(revision "0"))
(package
- (name "go-github-com-gorilla-mux")
+ (name "go-github-com-jonboulle-clockwork")
(version (git-version "0.0.0" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/gorilla/mux")
+ (url "https://github.com/jonboulle/clockwork")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "0wd6jjii1kg5s0nk3ri6gqriz6hbd6bbcn6x4jf8n7ncrb8qsxyz"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/gorilla/mux"))
- (home-page "https://github.com/gorilla/mux")
- (synopsis "URL router and dispatcher for Go")
- (description
- "Gorilla/Mux implements a request router and dispatcher for matching
-incoming requests with their respective handler.")
- (license license:bsd-3))))
-
-(define-public go-github-com-jonboulle-clockwork
- (let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
- (revision "0"))
- (package
- (name "go-github-com-jonboulle-clockwork")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jonboulle/clockwork")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1avzqhks12a8x2yzpvjsf3k0gv9cy7zx2z88hn0scacnxkphisvc"))))
+ "1avzqhks12a8x2yzpvjsf3k0gv9cy7zx2z88hn0scacnxkphisvc"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/jonboulle/clockwork"))
+ '(#:import-path "github.com/jonboulle/clockwork"))
(home-page "https://github.com/jonboulle/clockwork")
(synopsis "Fake clock library for Go")
(description
--
2.29.2
M
M
Martin Becze wrote on 30 Nov 2020 21:24
[PATCH 2/7] gnu: Added go-github-com-felixge-httpsnoop.
(address . 44969@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20201130202408.27437-2-mjbecze@riseup.net
* gnu/packages/golang.scm (go-github-com-felixge-httpsnoop): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fed32d65ec..e72d7026de 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
+;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6039,3 +6040,27 @@ JSON data to the machine.")
systems can import this package to enable running programs as services without
modifying them.")
(license license:zlib)))
+
+(define-public go-github-com-felixge-httpsnoop
+ (package
+ (name "go-github-com-felixge-httpsnoop")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/felixge/httpsnoop")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ncd8lar5zxiwjhsp315s4hsl4bhnm271h49jhyxc66r5yffgmac"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/felixge/httpsnoop"))
+ (home-page "https://github.com/felixge/httpsnoop/")
+ (synopsis "Capture http related metric")
+ (description "Httpsnoop provides an easy way to capture http
+related metrics (i.e. response time, bytes written, and http status
+ code) from your application's http.Handlers.")
+ (license license:expat)))
--
2.29.2
M
M
Martin Becze wrote on 30 Nov 2020 21:24
[PATCH 3/7] gnu: Added go-github-com-gorilla-handlers.
(address . 44969@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20201130202408.27437-3-mjbecze@riseup.net
* gnu/packages/golang.scm (go-github-com-gorilla-handlers): New variable.
---
gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e72d7026de..97becc2a4b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1331,6 +1331,32 @@ values for the purpose of fuzz testing.")
incoming requests with their respective handler.")
(license license:bsd-3)))
+(define-public go-github-com-gorilla-handlers
+ (package
+ (name "go-github-com-gorilla-handlers")
+ (version "1.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/handlers")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "15gycdz9lkjnsvvichsbdf25vf6pi1sfn41khhz53iqf300l0w0s"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ `(("github.com/felixge/httpsnoop" ,go-github-com-felixge-httpsnoop)))
+ (arguments
+ '(#:tests? #f ;Trys to download from the internet
+ #:import-path "github.com/gorilla/handlers"))
+ (home-page "https://github.com/gorilla/handlers")
+ (synopsis "Middleware for Go HTTP services and web applications")
+ (description "A collection of useful middleware for Go HTTP services
+and web applications.")
+ (license license:bsd-3)))
+
(define-public go-github-com-jonboulle-clockwork
(let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
(revision "0"))
--
2.29.2
M
M
Martin Becze wrote on 30 Nov 2020 21:24
[PATCH 4/7] gnu: Added go-github-com-gorilla-securecookie.
(address . 44969@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20201130202408.27437-4-mjbecze@riseup.net
* gnu/packages/golang.scm (go-github-com-gorilla-securecookie): New variable.
---
gnu/packages/golang.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 97becc2a4b..7a2d62a752 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1357,6 +1357,29 @@ incoming requests with their respective handler.")
and web applications.")
(license license:bsd-3)))
+(define-public go-github-com-gorilla-securecookie
+ (package
+ (name "go-github-com-gorilla-securecookie")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/securecookie")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16bqimpxs9vj5n59vm04y04v665l7jh0sddxn787pfafyxcmh410"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/gorilla/securecookie"))
+ (home-page "https://github.com/gorilla/securecookie")
+ (synopsis "Encodes and decodes authenticated and optionally encrypted cookie values")
+ (description "Gorilla/securecookie encodes and decodes authenticated and optionally
+encrypted cookie values for Go web applications.")
+ (license license:bsd-3)))
+
(define-public go-github-com-jonboulle-clockwork
(let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
(revision "0"))
--
2.29.2
M
M
Martin Becze wrote on 30 Nov 2020 21:24
[PATCH 5/7] gnu: Added go-github-com-gorilla-csrf.
(address . 44969@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20201130202408.27437-5-mjbecze@riseup.net
* gnu/packages/golang.scm (go-github-com-gorilla-csrf): New variable.
---
gnu/packages/golang.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7a2d62a752..78bbf2453d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1380,6 +1380,33 @@ and web applications.")
encrypted cookie values for Go web applications.")
(license license:bsd-3)))
+(define-public go-github-com-gorilla-csrf
+ (package
+ (name "go-github-com-gorilla-csrf")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gorilla/csrf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0iryq0z48yi7crfbd8jxyn7lh1gsglpiglvjgnf23bz6xfisssav"))))
+ (build-system go-build-system)
+ (propagated-inputs
+ `(("github.com/gorilla/securecookie" ,go-github-com-gorilla-securecookie)
+ ("github.com/pkg/errors" ,go-github-com-pkg-errors)))
+ (arguments
+ '(#:import-path "github.com/gorilla/csrf"))
+ (home-page "https://github.com/gorilla/csrf")
+ (synopsis "Cross Site Request Forgery (CSRF) prevention middleware")
+ (description
+ "Gorilla/csrf provides Cross Site Request Forgery (CSRF) prevention
+middleware for Go web applications and services.")
+ (license license:bsd-3)))
+
(define-public go-github-com-jonboulle-clockwork
(let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
(revision "0"))
--
2.29.2
M
M
Martin Becze wrote on 30 Nov 2020 21:24
[PATCH 6/7] gnu: Added go-gopkg-in-natefinch-lumberjack.v2.
(address . 44969@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20201130202408.27437-6-mjbecze@riseup.net
* gnu/packages/golang.scm (go-gopkg-in-natefinch-lumberjack.v2): New variable.
---
gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 78bbf2453d..3d1260e15b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6140,3 +6140,28 @@ modifying them.")
related metrics (i.e. response time, bytes written, and http status
code) from your application's http.Handlers.")
(license license:expat)))
+
+(define-public go-gopkg-in-natefinch-lumberjack.v2
+ (package
+ (name "go-gopkg-in-natefinch-lumberjack.v2")
+ (version "2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/natefinch/lumberjack")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l3vlv72b7rfkpy1164kwd3qzrqmmjnb67akzxqp2mlvc66k6p3d"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "gopkg.in/natefinch/lumberjack.v2"))
+ (propagated-inputs
+ `(("github.com/burntsush/toml" ,go-github-com-burntsushi-toml)
+ ("gopkg.in/yaml.v2" ,go-gopkg-in-yaml-v2)))
+ (home-page "https://github.com/natefinch/lumberjack")
+ (synopsis "A rolling logger for go")
+ (description "Lumberjack is a Go package for writing logs to rolling files.")
+ (license license:expat)))
--
2.29.2
M
M
Martin Becze wrote on 30 Nov 2020 21:24
[PATCH 7/7] gnu: trezord: Updated to 2.0.30.
(address . 44969@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20201130202408.27437-7-mjbecze@riseup.net
* gnu/packages/finance.scm (trezord): Updated to 2.0.30.
---
gnu/packages/finance.scm | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index a79c70d1e0..1f8e5f97cf 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -69,6 +69,7 @@
#:use-module (gnu packages dbm)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages graphviz)
@@ -1229,20 +1230,25 @@ trezord as a regular user instead of needing to it run as root.")
(define-public trezord
(package
(name "trezord")
- (version "2.0.29")
+ (version "2.0.30")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/trezor/trezord-go")
- (commit (string-append "v" version))))
+ (url "https://github.com/trezor/trezord-go")
+ (commit (string-append "v" version))))
(sha256
(base32
- "1ks1fa0027s3xp0z6qp0dxmayvrb4dwwscfhbx7da0khp153f2cp"))
+ "1hzvk0wfgg7b4wpqjk3738yqxlv3pj5i7zxwm0jady2h97hmrqrr"))
(file-name (git-file-name name version))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/trezor/trezord-go"))
+ (native-inputs
+ `(("github.com/gorilla-csrf" ,go-github-com-gorilla-csrf)
+ ("github.com/gorilla/handlers" ,go-github-com-gorilla-handlers)
+ ("github.com/gorilla/mux" ,go-github-com-gorilla-mux)
+ ("gopkg.in/natefinch/lumberjack.v2" ,go-gopkg-in-natefinch-lumberjack.v2)))
(home-page "https://trezor.io")
(synopsis "Trezor Communication Daemon aka Trezor Bridge (written in Go)")
(description "This allows a Trezor hardware wallet to communicate to the
--
2.29.2
C
C
Christopher Baines wrote on 8 Dec 2020 09:55
Re: [bug#44969] [PATCH 0/7] Update trezord to 2.0.30
(name . Martin Becze)(address . mjbecze@riseup.net)(address . 44969-done@debbugs.gnu.org)
87wnxsisn0.fsf@cbaines.net
Martin Becze <mjbecze@riseup.net> writes:

Toggle quote (15 lines)
> This updates trezod to 2.0.30
>
> Martin Becze (7):
> gnu: go-github-com-gorilla-mux: Update to 1.8.0.
> gnu: Added go-github-com-felixge-httpsnoop.
> gnu: Added go-github-com-gorilla-handlers.
> gnu: Added go-github-com-gorilla-securecookie.
> gnu: Added go-github-com-gorilla-csrf.
> gnu: Added go-gopkg-in-natefinch-lumberjack.v2.
> gnu: trezord: Updated to 2.0.30.
>
> gnu/packages/finance.scm | 14 ++-
> gnu/packages/golang.scm | 186 ++++++++++++++++++++++++++++++++-------
> 2 files changed, 165 insertions(+), 35 deletions(-)

Thanks Martin! I've tweaked a few patches, and gone ahead and pushed
this to master as 2d8deaa06e8d2d836f0580cad6cac5eb06c4973d.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/PP4NfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeN7hAAiimEEKr0tUXH8JIP8nK5yM7u+tX0+/fb
X13yGBv2gjZHNAllLnGoEEsgeiCGsIeiiBF6xYv4FAQxOQIqK87P7AdppeGCXiEf
n1NS3bIR9cGyUmxoc4ZHcg9Isa7Ijn8syki02nil12ms6UJVNJp3bykZda0nItdG
skyrBKcZU9DPoUZq+TXTAzWIE9gDO7aU95uJfEFZWJHVhAa7SYjXqMhIo7sFR7BR
CYGHpiZWBU5F5ChawzfISgux4B4fqsn+t9yccH5mdxPOIspMm0C+F1YWqDvVg5Gl
6D1qxZt/C9PFQgwCT97sDKjtB+j/sDjoyuDesgiuTO4NapWXQdEToKAT5rUCe3TV
W3BYLeSOwOci/ZS35P+WpFR83yYVSvh9aio9XLTAKSzdU6eWdpjiT/jGNovCUIpt
iRUU6JAeegZ1rIp1iN7gtNEVE9UT9AI1HyqTeM1Mdg3OnuTLbeDkGhgFNlZWXJ5V
fdP0cLfNzBv3NH++J+PqWN0M7/bDj+TdqDD41GbeLmXTk0TmSoY82GrpXpT35sgw
9pEz3y+rLHbs9EfZn1+BvXTpQN04oFRluuxehrPKoF5ZQ4x9u6ocvsBOrewpvCgt
c4ckBcnbE1dMCjuFCSawMg44aDfPnbkF+Kvg3t8GHunPW7V2X1Yfi6ye+kvXNgXY
PonnMFxEBao=
=SOXV
-----END PGP SIGNATURE-----

Closed
C
C
Christopher Baines wrote on 8 Dec 2020 09:59
Re: [bug#44969] [PATCH 1/7] gnu: go-github-com-gorilla-mux: Update to 1.8.0.
(name . Martin Becze)(address . mjbecze@riseup.net)(address . 44969@debbugs.gnu.org)
87tuswisgj.fsf@cbaines.net
Martin Becze <mjbecze@riseup.net> writes:

Toggle quote (90 lines)
> * gnu/packages/golang.scm (go-github-com-gorilla-mux): Update to 1.8.0.
> ---
> gnu/packages/golang.scm | 60 ++++++++++++++++++++---------------------
> 1 file changed, 29 insertions(+), 31 deletions(-)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index 92533cfd50..fed32d65ec 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -1307,50 +1307,48 @@ values for the purpose of fuzz testing.")
> (license license:bsd-3))))
>
> (define-public go-github-com-gorilla-mux
> - (let ((commit "599cba5e7b6137d46ddf58fb1765f5d928e69604")
> + (package
> + (name "go-github-com-gorilla-mux")
> + (version "1.8.0")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/gorilla/mux")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "18f0q9qxgq1yh4ji07mqhiydfcwvi56z9d775v7dc7yckj33kpdk"))))
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/gorilla/mux"))
> + (home-page "https://github.com/gorilla/mux")
> + (synopsis "URL router and dispatcher for Go")
> + (description
> + "Gorilla/Mux implements a request router and dispatcher for matching
> +incoming requests with their respective handler.")
> + (license license:bsd-3)))
> +
> +(define-public go-github-com-jonboulle-clockwork
> + (let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
> (revision "0"))
> (package
> - (name "go-github-com-gorilla-mux")
> + (name "go-github-com-jonboulle-clockwork")
> (version (git-version "0.0.0" revision commit))
> (source
> (origin
> (method git-fetch)
> (uri (git-reference
> - (url "https://github.com/gorilla/mux")
> + (url "https://github.com/jonboulle/clockwork")
> (commit commit)))
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "0wd6jjii1kg5s0nk3ri6gqriz6hbd6bbcn6x4jf8n7ncrb8qsxyz"))))
> - (build-system go-build-system)
> - (arguments
> - '(#:import-path "github.com/gorilla/mux"))
> - (home-page "https://github.com/gorilla/mux")
> - (synopsis "URL router and dispatcher for Go")
> - (description
> - "Gorilla/Mux implements a request router and dispatcher for matching
> -incoming requests with their respective handler.")
> - (license license:bsd-3))))
> -
> -(define-public go-github-com-jonboulle-clockwork
> - (let ((commit "e3653ace2d63753697e0e5b07b9393971c0bba9d")
> - (revision "0"))
> - (package
> - (name "go-github-com-jonboulle-clockwork")
> - (version (git-version "0.0.0" revision commit))
> - (source
> - (origin
> - (method git-fetch)
> - (uri (git-reference
> - (url "https://github.com/jonboulle/clockwork")
> - (commit commit)))
> - (file-name (git-file-name name version))
> - (sha256
> - (base32
> - "1avzqhks12a8x2yzpvjsf3k0gv9cy7zx2z88hn0scacnxkphisvc"))))
> + "1avzqhks12a8x2yzpvjsf3k0gv9cy7zx2z88hn0scacnxkphisvc"))))
> (build-system go-build-system)
> (arguments
> - '(#:import-path "github.com/jonboulle/clockwork"))
> + '(#:import-path "github.com/jonboulle/clockwork"))
> (home-page "https://github.com/jonboulle/clockwork")
> (synopsis "Fake clock library for Go")
> (description

This patch is a little messy, I think the
go-github-com-jonboulle-clockwork indentation isn't great, and you end
up changing it when updating go-github-com-gorilla-mux.

I managed to remove the go-github-com-jonboulle-clockwork indentation
changes from this before committing.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/PQGxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XflbQ/8DZe1/kcw+pbhf7Byp9pHHIgcOlGZqyk9
Tb+rEcey3sDIoj/iKzfrUrKefssEO3xrVOdQbbB1G0pv6aB3V4AgrIy9ytQFJW72
fGxabSzhvVL4YIawMsYzvwXxldpj8pAml6cy/O0H0h50lttUG1eU8XYiAFLjlyLo
oYNAi4ldCKg2qzdMOmQQ3xcW3qKH0zzhdZ66jFWYIZ+gnTG6JKDBsmXvEC2Rrfbc
pjLxP4A6eh8XKrj6qGVXpvG76ifEg3f5jonRROVggp29/ew6harUsbTHPN5of8Tj
JRLKlxLVT+KJe4kmC61Cx9sPnH/O3HIX9YfhYFYUPNE2KZLbgSZQygBzh5AbsmuB
QZJCB+0VmlMJJ4H7J/NFXhJJjK6cMpkNXY2QxGl2k8ljy0HddFsvT3zFifUaGYKT
IXMKAeyyB92Zc8HUVOiw4bogTwRitwY+hQW6KgdtQRX2RpaZSbb31t/Pv2G9eN5s
Pl6fLa/7BlnXsAINSMoWXZcdEPGBDrGYwmHi7FkfqbbWEGb8YmbJvw/EHWCLvyFP
XhbtDgSWvD3uS5ppkqSJzekuaeXRK1BPHjonvJb391zuxYmVzjJs6vOoMVyXrxol
KIraNtiljBRn6D94Es7kzIe9kBk5wSh4eaFH/nzY8ewk+5qiJEA+Apc5yevnUPJl
XJdboIwUVUw=
=lLtq
-----END PGP SIGNATURE-----

C
C
Christopher Baines wrote on 8 Dec 2020 10:01
Re: [bug#44969] [PATCH 2/7] gnu: Added go-github-com-felixge-httpsnoop.
(name . Martin Becze)(address . mjbecze@riseup.net)(address . 44969@debbugs.gnu.org)
87r1o0iscd.fsf@cbaines.net
Martin Becze <mjbecze@riseup.net> writes:

Toggle quote (2 lines)
> * gnu/packages/golang.scm (go-github-com-felixge-httpsnoop): New variable.

So, the commit message should say Add rather than Added. This is both
for consistency, and because it makes more sense for commits to say what
they will do when applied, rather than reading like something's already
happened.

Toggle quote (45 lines)
> ---
> gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index fed32d65ec..e72d7026de 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -22,6 +22,7 @@
> ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
> ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
> ;;; Copyright © 2020 raingloom <raingloom@riseup.net>
> +;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -6039,3 +6040,27 @@ JSON data to the machine.")
> systems can import this package to enable running programs as services without
> modifying them.")
> (license license:zlib)))
> +
> +(define-public go-github-com-felixge-httpsnoop
> + (package
> + (name "go-github-com-felixge-httpsnoop")
> + (version "1.0.1")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/felixge/httpsnoop")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0ncd8lar5zxiwjhsp315s4hsl4bhnm271h49jhyxc66r5yffgmac"))))
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/felixge/httpsnoop"))
> + (home-page "https://github.com/felixge/httpsnoop/")
> + (synopsis "Capture http related metric")
> + (description "Httpsnoop provides an easy way to capture http
> +related metrics (i.e. response time, bytes written, and http status
> + code) from your application's http.Handlers.")
> + (license license:expat)))

Adding packages at the bottom of modules is something to try and
avoid. When other patches do the same thing, it causes merge conflicts.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/PQQJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcS6g/+KpoDmbD/AbY4M2dyKD4gXWrZyi41cMH3
FIDWQ7KRxY2LFjYvfxkgq1VXoH40P4i0JL09mhFz2EafqMakvrHfdQEyhGroqcmB
VF2zhmBElrLAhp0FF/obcEgidmYsySwamzUtInFFsuKqSQ8/3+rhaxH1n1yH8drz
TOwHxlrJ9RiriiNzodFORZE+jp2njmyEKgrUAd+RB/lHpknFbLm1YbHqRnFJOwcx
5zlz3LSn21/5UIn4VF7XN+tXVWb8O5IoIjYy4C5dzMJiLTNN70bN6sB/au/mFab5
epNgI2f0wvXj8qij7hRJV+brNtMtG4W/Rg/mQyHpjIzvbTwi1oc2FTljHXSe0Z6d
pJeFsoVczdyJzgS1IAW9wimwMwTYr7PxPmDf57OkAklVHaf4Q6LeLGrex/voSrgh
3Dzif+0xO8BF6VOKST1k8HdGqD6Ik8AFqr+kl7PpyN0ft3lpmWZSjUpPZdQLpEtb
qZoRHgZROrMoDUDuW2oXj8yNwtGANqhZmWlLE1DJfVNTuEcOJ4NKo/ETEqbE2pxG
qZt/pcgLCAR5exj3cmxZPAmbOyWj2/qHifjc3nmYxnDI6rANAy5jVWh1A4oGjp0W
zLTXH6ZdhOwgC/Hv35ABacrnktKlhVsfo3JknrKxxycycIFjDCsvsAVNgltWGwYw
nSzIPgy79mc=
=GIoc
-----END PGP SIGNATURE-----

?