Morgan.J.Smith wrote 4 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/embedded.scm (openocd)[arguments]: Add "LIBS=-lutil" to allow
it to build
---
So it turns out my pod doesn't need openocd so I'm not actually able to test
this at all. But going from not building to building seems like an improvment
in my eyes.
---
gnu/packages/embedded.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (16 lines)
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 73375a211d..baeb2e3e2a 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -555,7 +555,8 @@ language.")
("libusb-compat" ,libusb-compat)))
(arguments
'(#:configure-flags
- (append (list "--disable-werror"
+ (append (list "LIBS=-lutil"
+ "--disable-werror"
"--enable-sysfsgpio"
"--disable-internal-jimtcl"
"--disable-internal-libjaylink")
--
2.29.2