[PATCH] gnu: Add catfish.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 4 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20201129185446.20701-1-kkebreau@posteo.net
* gnu/packages/xfce.scm (catfish): New variable.
---
gnu/packages/xfce.scm | 61 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 61 insertions(+)

Toggle diff (89 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index fbe06a1c76..9d05da5853 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -53,7 +53,9 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages polkit)
#:use-module (gnu packages popt)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages search)
#:use-module (gnu packages web)
#:use-module (gnu packages wm)
#:use-module (gnu packages xml)
@@ -62,6 +64,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -203,6 +206,64 @@ storage system.")
to share commonly used Xfce widgets among the Xfce applications.")
(license lgpl2.0+)))
+(define-public catfish
+ (package
+ (name "catfish")
+ (version "1.4.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/apps/"
+ "catfish/" (version-major+minor version)
+ "/catfish-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0fg89946z6n8njxn4mv29jksw8yavg8vypsljn9031pjwl3fmh2q"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-command-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "catfish/CatfishSearchEngine.py"
+ (("'which'") (string-append "'" (which "which") "'")))
+ (substitute* "catfish/CatfishWindow.py"
+ (("xdg-mime") (which "xdg-mime"))
+ (("xdg-open") (which "xdg-open")))))
+ ;; setup.py script does not support one of the Python build
+ ;; system's default flags, "--single-version-externally-managed".
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "python" "setup.py" "install"
+ (string-append "--prefix=" (assoc-ref outputs "out"))
+ "--root=/")))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/catfish")
+ `("PYTHONPATH" = (,(getenv "PYTHONPATH")))
+ `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH"))))))))
+ #:tests? #f))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python-distutils-extra" ,python-distutils-extra)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("which" ,which)
+ ("xdg-utils" ,xdg-utils)))
+ (propagated-inputs
+ `(("gtk+" ,gtk+)
+ ("python-dbus" ,python-dbus)
+ ("python-pexpect" ,python-pexpect)
+ ("python-pycairo" ,python-pycairo)
+ ("python-pygobject" ,python-pygobject)))
+ (home-page "https://docs.xfce.org/apps/catfish/start")
+ (synopsis "File searching tool for Xfce")
+ (description
+ "Catfish is a handy file searching tool for Linux and Unix. The interface
+is intentionally lightweight and simple, using only GTK+ 3. You can configure
+it to your needs by using several command line options.")
+ (license gpl2+)))
+
(define-public elementary-xfce-icon-theme
(package
(name "elementary-xfce-icon-theme")
--
2.29.2
Mathieu Othacehe wrote 4 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 44951@debbugs.gnu.org)
87a6uwnyxc.fsf@gnu.org
Hello,

Toggle quote (4 lines)
> + "Catfish is a handy file searching tool for Linux and Unix. The interface
> +is intentionally lightweight and simple, using only GTK+ 3. You can configure
> +it to your needs by using several command line options.")

I would remove "handy" to stay neutral. Otherwise, it looks nice!

Thanks,

Mathieu
Kei wrote 4 years ago
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 44951-done@debbugs.gnu.org)
eec1769a6636b11529969f09e7fbdb366152c5c9.camel@posteo.net
Thanks for reviewing this! It has been pushed to master with the suggested
change as commit 3c2cf75fb3.

Kei
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44951@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44951
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help