[PATCH] Bump version of libgit2 from 1.0.1 -> 1.1.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Holger Peters
  • Leo Famulari
Owner
unassigned
Submitted by
Holger Peters
Severity
normal
H
H
Holger Peters wrote on 29 Nov 2020 14:12
(address . guix-patches@gnu.org)(name . Holger Peters)(address . holger.peters@posteo.de)
20201129131229.570134-1-holger.peters@posteo.de
* gnu/packages/emacs-xyz.scm (libgit2): Bump version.
---
gnu/packages/version-control.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 29de995665..bc5b55b594 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -666,7 +666,7 @@ to GitHub contributions calendar.")
(define-public libgit2
(package
(name "libgit2")
- (version "1.0.1")
+ (version "1.1.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/libgit2/libgit2/"
@@ -674,7 +674,7 @@ to GitHub contributions calendar.")
"/libgit2-" version ".tar.gz"))
(sha256
(base32
- "0nlg35pxhh548nn7aa3y1m81mf81nkbzz86i2psps4f474n497v8"))
+ "1fjdglkh04qv3b4alg621pxa689i0wlf8m7nf2755zawjr2zhwxd"))
(patches (search-patches "libgit2-mtime-0.patch"))
(snippet '(begin
(delete-file-recursively "deps") #t))
--
2.28.0
L
L
Leo Famulari wrote on 29 Nov 2020 19:09
(name . Holger Peters)(address . holger.peters@posteo.de)(address . 44945@debbugs.gnu.org)
X8Pj7JVUH8voEyDD@jasmine.lan
On Sun, Nov 29, 2020 at 02:12:29PM +0100, Holger Peters wrote:
Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (libgit2): Bump version.

Thanks! Did you check if guile-git still works after this?
L
L
Leo Famulari wrote on 29 Nov 2020 19:54
(no subject)
(address . control@debbugs.gnu.org)
X8PuabzIcMmytW9R@jasmine.lan
block 44946 by 44945
H
H
Holger Peters wrote on 1 Dec 2020 17:43
Re: [bug#44945] [PATCH] Bump version of libgit2 from 1.0.1 -> 1.1.0
(name . Leo Famulari)(address . leo@famulari.name)(address . 44945@debbugs.gnu.org)
3218BDCE-92CF-4558-A5AF-3D39F737EDEB@posteo.de
Toggle quote (4 lines)
>> * gnu/packages/emacs-xyz.scm (libgit2): Bump version.
> Thanks! Did you check if guile-git still works after this?


I tried it out. It seems so:

successfully built /gnu/store/3487vk6hs2vlw0sfw75am6m228vdixd7-guile-git-0.4.0.drv
L
L
Leo Famulari wrote on 4 Dec 2020 01:00
(name . Holger Peters)(address . holger.peters@posteo.de)(address . 44945-done@debbugs.gnu.org)
X8l8I88utwyrhliZ@jasmine.lan
On Tue, Dec 01, 2020 at 05:43:22PM +0100, Holger Peters wrote:
Toggle quote (4 lines)
> I tried it out. It seems so:
>
> successfully built /gnu/store/3487vk6hs2vlw0sfw75am6m228vdixd7-guile-git-0.4.0.drv

Great!

I used `guix refresh --list-dependent libgit2` to see which packages
would be rebuilt as a consequence of changing libgit2, and tested
several of them against the update, and found that it caused failures of
packages using python-pygit2:

------
$ ./pre-inst-env guix build --no-grafts stagit rust-libgit2-sys@0.8.2 offlate \
python-pygit2 emacs-evil-magit fritzing kopete kate r-stm jucipp celestia-gtk \
celestia rust-libgit2-sys@0.10 gitg guix emacs-magit gwl gitless guix-build-coordinator \
--keep-going
[... it does a lot of work ...]
gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -fPIC -I/usr/local/include -I/gnu/store/q9rm8h9imazsq2c4qiv2yjpvlvliywqb-python-3.8.2/include/python3.8 -c src/blob.c -o build/temp.linux-x86_64-3.8/src/blob.o
In file included from src/blob.h:34:0,
from src/blob.c:30:
src/types.h:36:2: error: #error You need a compatible libgit2 version (0.99.x or 1.0.x)
#error You need a compatible libgit2 version (0.99.x or 1.0.x)
^~~~~
error: command 'gcc' failed with exit status 1
command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "build" failed with status 1
builder for `/gnu/store/0fvjfybgr66vygz1w5x6739fqsi14f9b-python-pygit2-1.1.0.drv' failed with exit code 1
build of /gnu/store/0fvjfybgr66vygz1w5x6739fqsi14f9b-python-pygit2-1.1.0.drv failed
------

I fixed this by updating python-pygit2 to the latest version, which is
compatible with libgit2 1.1.0.

I also tested the most important libgit2 user: Guix itself. Guix
commands are designed to compose usefully so you can do these arcane
wizard-ish Unix command substitutions:

------
$ $(./pre-inst-env guix build guix)/bin/guix pull
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Authenticating channel 'guix', commits 9edb3f6 to 4496e03 (6 new commits)...
Building from this channel:
Computing Guix derivation for 'x86_64-linux'...
[... it does more work ...]
New in this revision:
105 new packages: catfish, cgoban, chicken-agrep, chicken-datatype, chicken-iset, chicken-srfi-1, chicken-srfi-14, chicken-srfi-69, chicken-test, cl-array-operations,
cl-check-it, cl-clamp, …
135 packages upgraded: altermime@0.3.11, b4@0.5.3, cava@0.7.3, cl-alexandria@1.2, cl-bst@2.0-0.8545aed, cl-ironclad@0.52, cl-simple-parallel-tasks@1.0-1.ce7b60f,
cl-stumpwm@20.11, cl-webkit@2.4-10.5ce3ea1, cpupower@5.9.12, dfu-util@0.10, drbd-utils@9.15.1, …

News for channel 'guix'
Local substitute servers discovery is now supported
Logical Volume Manager (LVM) now supported on Guix System


hint: Run `guix pull --news' to read all the news.
------

It worked for me, so I pushed it as
68fa8fb0cb9f887a6d6069c897a16dc8fce0036d.

Thank you for the contribution!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAl/JfCMACgkQJkb6MLrK
fwjNMA//TEgSd8b46PExNE7W3BfUVXvDeSZdxCWPGD/cUKBkL+b/kkc8tM+eWkHH
eeQmNyty87+vuyQ/rJSQsHqKQze9QGcYvVkRKVP1/v7Rthgo/+wghBKBsQcvx5fC
6u2Mi+b5DfiYwW+80pVnwHHYGjuwUI/lZte0BG4xvo3FRpxYaIzwFBDeZZCnBB4p
fEP5iJShzCHbTNUPWw0D0CkAlscjYrt24oOtwOq7nay8ToOX6NozwJot9hmbXLJB
ljb3PgIVdHAwSlGy9LWbiNDwj7lI1DHd7zvTQqkieOIj//mBXuN3Mj1rthFYTZoE
ypLBt+BHgO4fsk+6Ll6hkSYpjZ/PMEdy+2jCnvxJsTxCcTznukAMsM7G47TyibDp
wZ2aqZZeIK01K5+LfsF5EdvXE++FEBr5zqDDPzoX/kaMC6WEvQtyzRjye57zRfGL
aYb/se0UBvYGq9v6h/a4PTCA5DCxgk3uG3cj0u9a3SFP9OCT4CQ+X8wjChgxOFCm
fpjso4XITS4EvjY9XphBuBHgcjAIkeMjkoLsVCQJPCEkGEn+aLFeyN9z/w93PiT5
xvSwC7QB1Hp4A4C/YO8VtKbDR59gpOD3dviwClUj4j5NVpMAP+k2jVGL//GnTCN+
rpuOZWKjIB5m+9cfyy6Xu+RpWzDjgZ1LJXfAvLQJPmHql/6LIs8=
=VZzz
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44945@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44945
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch