(address . guix-patches@gnu.org)
This is a series of patches, add fcitx5 and its build dependecies.
a qt5 and gtk2/3 plugin, chinese inputmethod addon and a material theme
-----BEGIN PGP SIGNATURE-----
iQFJBAEBCAAzFiEE7NCVzXX6efyusptG1SOVn+xGFqYFAl/B47QVHGFsbF9idXRf
bGFzdEAxNjMuY29tAAoJENUjlZ/sRhamDv0H/R6frvIFOBz70Tyb/pJ5QR6H2RX2
wgpDK1ohZ5errFfFSnGBKgFvChlDc/r7uGg4OC33xd0EW82B+QZSdOfJff2QVq9n
13bPi0oHqKVkjyQ+DFl7xyOZUPCdQ2ysy6sSkC6QYwr8bcPS1/MBCltEOX6T6euU
+PIcL/viNTb8vOTNmwj/GqD4xXyWsAh/6pUmy8jAC5j2knu5pMzVGpYR/L1Fx9le
vcAfD7TskSTpXM5NfHrQDPuIRNz0HrwKr/jJobDiqWEYOjfpOx6tImKyuNP93qsv
ew2sBphiSrqT8zeFM5zBT3QtQf7l7TM3n42V79iHbnBDQf7OgDcdKRToUMc=
=MUcB
-----END PGP SIGNATURE-----
From cbe128e488078b3af8f7d1bdb4bf9dc9f12a2f0b Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 28 Nov 2020 13:16:50 +0800
Subject: [PATCH 1/9] gnu: Add xcb-imdkit.
* gnu/packages/fcitx5.scm: New file.
(xcb-imdkit): New variable.
---
gnu/packages/fcitx5.scm | 84 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 84 insertions(+)
create mode 100644 gnu/packages/fcitx5.scm
Toggle diff (92 lines)
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
new file mode 100644
index 0000000000..171d545ed8
--- /dev/null
+++ b/gnu/packages/fcitx5.scm
@@ -0,0 +1,84 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages fcitx5)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages boost)
+ #:use-module (gnu packages curl)
+ #:use-module (gnu packages datastructures)
+ #:use-module (gnu packages enchant)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages gcc)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages iso-codes)
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages libevent)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages lua)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pretty-print)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages textutils)
+ #:use-module (gnu packages unicode)
+ #:use-module (gnu packages web)
+ #:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg))
+
+(define-public xcb-imdkit
+ (package
+ (name "xcb-imdkit")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.fcitx-im.org/fcitx5/xcb-imdkit/xcb-imdkit-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "0qgbklk5a809asyaxi6v9iasxc19g16fc5rphnamhwrliczlycas"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove bundled uthash.
+ (delete-file-recursively "uthash")
+ #t))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("uthash" ,uthash)
+ ("libxcb" ,libxcb)
+ ("xcb-util" ,xcb-util)
+ ("xcb-util-keysyms" ,xcb-util-keysyms)))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/fcitx/xcb-imdkit")
+ (synopsis "Input method development support for XCB.")
+ (description "Xcb-imdkit is an implementation of xim protocol in XCB,
+comparing with the implementation of IMDkit with Xlib, and xim inside Xlib,
+it has less memory foot print, better performance, and safer on malformed
+client.")
+ (license license:lgpl2.1)))
--
2.29.2
From d1e53ec2239077da96d871900fbb4c6d2d274cc5 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 28 Nov 2020 13:20:51 +0800
Subject: [PATCH 3/9] gnu: Add fcitx5-lua.
* gnu/packages/fcitx5.scm(fcitx5-lua): New variable.
---
gnu/packages/fcitx5.scm | 44 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)
Toggle diff (54 lines)
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index c4ee0c6e3c..c48eafbad5 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -145,3 +145,47 @@ client.")
(description "Fcitx 5 is a generic input method framework, the successor
of Fcitx.")
(license license:lgpl2.1+)))
+
+(define-public fcitx5-lua
+ (package
+ (name "fcitx5-lua")
+ (version "5.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.fcitx-im.org/fcitx5/fcitx5-lua/fcitx5-lua-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "0v4kjx5bargmzfm3v2kys1kzfbpkbd8inzw23y9hslc8h5zazj33"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ (string-append "-DFEM_INCLUDE_INSTALL_DIR=" %output "/include")
+ (string-append "-DFEM_LIB_INSTALL_DIR=" %output "/lib"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-install-prefix
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each
+ (lambda (x)
+ (format #t "patch-install-prefix: Fixing install prefix in ~a~%"
+ x)
+ (substitute* x
+ (("\\$\\{FCITX_INSTALL_PKGDATADIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/fcitx5"))))
+ '("src/addonloader/CMakeLists.txt"
+ "src/imeapi/CMakeLists.txt"))
+ #t)))))
+ (inputs
+ `(("fcitx5" ,fcitx5)
+ ("lua" ,lua)
+ ("gettext" ,gettext-minimal)
+ ("libpthread-stubs" ,libpthread-stubs)))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (home-page "https://github.com/fcitx/fcitx5-lua")
+ (synopsis "Lua support for Fcitx 5")
+ (description "Fcitx5-lua allow user to write Fcitx5 extension in Lua.")
+ (license license:lgpl2.1+)))
--
2.29.2
From 69b4cfc316e81e9c0ebdb307af033bf2e0a5faca Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 28 Nov 2020 13:21:38 +0800
Subject: [PATCH 4/9] gnu: Add libime.
* gnu/packages/fcitx5.scm(libime): New variable.
---
gnu/packages/fcitx5.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Toggle diff (35 lines)
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index c48eafbad5..9f031a1289 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -189,3 +189,28 @@ of Fcitx.")
(synopsis "Lua support for Fcitx 5")
(description "Fcitx5-lua allow user to write Fcitx5 extension in Lua.")
(license license:lgpl2.1+)))
+
+(define-public libime
+ (package
+ (name "libime")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.fcitx-im.org/fcitx5/libime/libime-"
+ version "_dict.tar.xz"))
+ (sha256
+ (base32 "0kymzn0srdmpbn43rg4zpz09baz3bcw18v648jsqsb2j488s2paq"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("fcitx5" ,fcitx5)
+ ("boost" ,boost)))
+ (native-inputs
+ `(("gcc" ,gcc-9) ;for #include <filesystem> and ld support
+ ("extra-cmake-modules" ,extra-cmake-modules)
+ ("python" ,python))) ;needed to run test
+ (home-page "https://github.com/fcitx/libime")
+ (synopsis "Library supports generic input method implmentation")
+ (description "Libime is a library, being used to implment various input
+methods for Fcitx 5.")
+ (license license:lgpl2.1+)))
--
2.29.2
From 8af5ff96d20a5fd2b3faa43b05935f9755880959 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 28 Nov 2020 13:24:20 +0800
Subject: [PATCH 5/9] gnu: Add fcitx5-qt.
* gnu/packages/fcitx5.scm(fcitx5-qt): New variable.
---
gnu/packages/fcitx5.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)
Toggle diff (46 lines)
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 9f031a1289..4e3ba010ef 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -214,3 +214,39 @@ of Fcitx.")
(description "Libime is a library, being used to implment various input
methods for Fcitx 5.")
(license license:lgpl2.1+)))
+
+(define-public fcitx5-qt
+ (package
+ (name "fcitx5-qt")
+ (version "5.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.fcitx-im.org/fcitx5"
+ "/fcitx5-qt/fcitx5-qt-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "0s0spjr8m7dw2f18xxqg6lwn3y575g411j9j9w8xv1cqsm9fm49f"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DCMAKE_INSTALL_QT5PLUGINDIR="
+ %output "/lib/qt5/plugins")
+ "-DENABLE_QT4=Off")))
+ (inputs
+ `(("fcitx5" ,fcitx5)
+ ("libxcb" ,libxcb)
+ ("libxkbcommon" ,libxkbcommon)
+ ("qtbase" ,qtbase)
+ ("gettext" ,gettext-minimal)))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (home-page "https://github.com/fcitx/fcitx5-qt")
+ (synopsis "Qt library and IM module for Fcitx 5")
+ (description "Fcitx5-qt provides Qt library for development and IM module
+for Qt5 based application.")
+ (license (list license:lgpl2.1+
+ ;; Files under qt4/ which include Fcitx5Qt4DBusAddons Library
+ ;; and input context plugin and files under qt5/dbusaddons
+ ;; and qt5/platforminputcontext
+ license:bsd-3))))
--
2.29.2
From 9a4111139bc059fbacc2f6aa8a3d5922d4f837fd Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 28 Nov 2020 13:25:19 +0800
Subject: [PATCH 6/9] gnu: Add fcitx5-gtk.
* gnu/packages/fcitx5.scm(fcitx5-gtk): New variable.
---
gnu/packages/fcitx5.scm | 50 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)
Toggle diff (63 lines)
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 4e3ba010ef..9673ff2c47 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -215,6 +215,56 @@ of Fcitx.")
methods for Fcitx 5.")
(license license:lgpl2.1+)))
+(define-public fcitx5-gtk
+ (package
+ (name "fcitx5-gtk")
+ (version "5.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.fcitx-im.org/fcitx5"
+ "/fcitx5-gtk/fcitx5-gtk-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "0k09f3ca4jm4y33xr642wrbf2zfjqr7gjx1i28z0vwb1rmjn026y"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;No test
+ #:configure-flags
+ (list (string-append "-DGOBJECT_INTROSPECTION_GIRDIR="
+ %output "/share/gir-1.0")
+ (string-append "-DGOBJECT_INTROSPECTION_TYPELIBDIR="
+ %output "/lib/girepository-1.0"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-install-prefix
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gtk3 (assoc-ref outputs "gtk3")))
+
+ (substitute* "gtk3/CMakeLists.txt"
+ (("\\$\\{CMAKE_INSTALL_LIBDIR\\}")
+ (string-append gtk3 "/lib")))))))))
+ (inputs
+ `(("fcitx5" ,fcitx5)
+ ("libxkbcommon" ,libxkbcommon)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk2" ,gtk+-2)
+ ("gtk3" ,gtk+)
+ ("glib" ,glib)
+ ("libx11" ,libx11)
+ ("gettext" ,gettext-minimal)))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin"))) ;for glib-genmarshal
+ (outputs '("out" "gtk3"))
+ (home-page "https://github.com/fcitx/fcitx5-gtk")
+ (synopsis "Glib based D-Bus client and GTK IM module for Fcitx 5")
+ (description "Fcitx5-qt provides a Glib based D-Bus client for development
+and IM module for GTK+2/GTK+3 application.")
+ (license license:lgpl2.1+)))
+
(define-public fcitx5-qt
(package
(name "fcitx5-qt")
--
2.29.2
From f0905307b179d478475a0433cbebf1532ecf6a95 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 28 Nov 2020 13:25:37 +0800
Subject: [PATCH 7/9] gnu: Add fcitx5-chinese-addons.
* gnu/packages/fcitx5.scm(fcitx5-chinese-addons): New variable.
---
gnu/packages/fcitx5.scm | 79 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 79 insertions(+)
Toggle diff (89 lines)
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 9673ff2c47..076a96992d 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -300,3 +300,82 @@ for Qt5 based application.")
;; and input context plugin and files under qt5/dbusaddons
;; and qt5/platforminputcontext
license:bsd-3))))
+
+(define-public fcitx5-chinese-addons
+ (package
+ (name "fcitx5-chinese-addons")
+ (version "5.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.fcitx-im.org/fcitx5"
+ "/fcitx5-chinese-addons/fcitx5-chinese-addons-"
+ version "_dict.tar.xz"))
+ (sha256
+ (base32 "015yx7wwhyjnhbrx2akc90nnzvmyhv1jv2n0mv7x7hsj05m62q8l"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ (string-append "-DFEM_INCLUDE_INSTALL_DIR=" %output "/include")
+ (string-append "-DFEM_LIB_INSTALL_DIR=" %output "/lib")
+ ;; "-DENABLE_GUI=Off"
+ )
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-install-prefix
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each
+ (lambda (x)
+ (format #t "patch-install-prefix: Fixing install prefix in ~a~%"
+ x)
+ (substitute* x
+ (("\\$\\{FCITX_INSTALL_PKGDATADIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/fcitx5"))))
+ (find-files "." "CMakeLists\\.txt$"))
+ #t))
+ (add-before 'configure 'split-outputs
+ ;; Build with GUI supports requires Qt and increase package closure
+ ;; by 800M on x86_64, so place it under another output.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "gui/pinyindictmanager/CMakeLists.txt"
+ (("\\$\\{CMAKE_INSTALL_LIBDIR\\}" _)
+ (string-append (assoc-ref outputs "gui") "/lib"))))))))
+ (inputs
+ `(("fcitx5" ,fcitx5)
+ ("fcitx5-lua" ,fcitx5-lua)
+ ("boost" ,boost)
+ ("libime",libime)
+ ("curl" ,curl)
+ ("gettext" ,gettext-minimal)
+ ("fmt" ,fmt)
+ ("libpthread-stubs" ,libpthread-stubs)
+ ("opencc" ,opencc)
+ ("qtbase" ,qtbase)
+ ("fcitx5-qt" ,fcitx5-qt)
+ ("qtwebkit" ,qtwebkit)))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (outputs '("out" "gui"))
+ (home-page "https://github.com/fcitx/fcitx5-chinese-addons")
+ (synopsis "Chinese related addons for Fcitx 5")
+ (description "Fcitx5-chinese-addons provides Chinese related addons,
+including input methods previous bundled inside Fcitx 4:
+
+@itemize
+@item Bingchan
+@item Cangjie
+@item Erbi
+@item Pinyin
+@item Shuangpin
+@item Wanfeng
+@item Wubi
+@item Wubi Pinyin
+@item Ziranma
+@end itemize\n")
+ (license (list license:lgpl2.1+
+ license:gpl2+
+ ;; im/pinyin/emoji.txt
+ license:unicode))))
--
2.29.2
From 95c20d878565cb3ff7870187e1806743d7e526f3 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 28 Nov 2020 13:25:55 +0800
Subject: [PATCH 8/9] gnu: Add fcitx5-configtool.
* gnu/packages/fcitx5.scm(fcitx5-configtool): New variable.
---
gnu/packages/fcitx5.scm | 42 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)
Toggle diff (52 lines)
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 076a96992d..bc8fa5d7dc 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -379,3 +379,45 @@ including input methods previous bundled inside Fcitx 4:
license:gpl2+
;; im/pinyin/emoji.txt
license:unicode))))
+
+(define-public fcitx5-configtool
+ (let ((revision "0")
+ (commit "9c01bfc7477c203443ed073397670df52d1a6fc0"))
+ (package
+ (name "fcitx5-configtool")
+ (version (git-version "5.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fcitx/fcitx5-configtool")
+ (commit commit)))
+ (sha256
+ (base32 "03hfbr97953alxax3db1x16h17cgqx30xvqs070iz8rj232iiaia"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ ;; KDE is currently not working on Guix, KCM supports doesn't make sense.
+ '("-DENABLE_KCM=Off")))
+ (inputs
+ `(("fcitx5" ,fcitx5)
+ ("fcitx5-qt" ,fcitx5-qt)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
+ ("kitemviews" ,kitemviews)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("libx11" ,libx11)
+ ("xkeyboard-config" ,xkeyboard-config)
+ ("libxkbfile" ,libxkbfile)
+ ("gettext" ,gettext-minimal)
+ ("iso-codes" ,iso-codes)))
+ (native-inputs
+ `(("gcc" ,gcc-9)
+ ("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/fcitx/fcitx5-configtool")
+ (synopsis "Graphical configuration tool for Fcitx 5")
+ (description "Fcitx5-configtool is a graphical configuration tool
+written in Qt, design for managing different input methods running under
+Fcitx 5.")
+ (license license:gpl2+))))
--
2.29.2
From 32f4fef151807a0620fec7654094ed3945a02bcf Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Sat, 28 Nov 2020 13:27:08 +0800
Subject: [PATCH 9/9] gnu: Add fcitx5-material-color-theme.
* gnu/packages/fcitx5.scm(fcitx5-material-color-theme): New variable.
---
gnu/packages/fcitx5.scm | 70 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 70 insertions(+)
Toggle diff (80 lines)
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index bc8fa5d7dc..80fb989408 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -421,3 +421,73 @@ including input methods previous bundled inside Fcitx 4:
written in Qt, design for managing different input methods running under
Fcitx 5.")
(license license:gpl2+))))
+
+(define-public fcitx5-material-color-theme
+ (package
+ (name "fcitx5-material-color-theme")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hosxy/Fcitx5-Material-Color")
+ (commit version)))
+ (sha256
+ (base32 "1mgc722521jmfx0xc3ibmiycd3q2w7xg2956xcpc07kz90gcdjaa"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (use-modules (srfi srfi-26))
+
+ (let* ((out (assoc-ref outputs "out"))
+ (assets-dir (string-append
+ out "/share/fcitx5-material-color-theme"))
+ (themes-prefix (string-append out "/share/fcitx5/themes")))
+
+ (define (install-theme-variant variant target)
+ (let ((dir (string-append themes-prefix "/" target))
+ (png (string-append "panel-" variant ".png"))
+ (conf (string-append "theme-" variant ".conf")))
+ (format #t "install: Installing color variant \"~a\" to ~a~%"
+ variant dir)
+ (substitute* conf
+ (("^Name=.*")
+ (string-append "Name=" target "\n")))
+ (mkdir-p dir)
+ (install-file png dir)
+ (copy-file conf (string-append dir "/theme.conf"))
+ (symlink (string-append assets-dir "/arrow.png")
+ (string-append dir "/arrow.png"))))
+
+ (mkdir-p assets-dir)
+ (install-file "arrow.png" assets-dir)
+ (for-each
+ (lambda (x)
+ (install-theme-variant
+ x (string-append "Material-Color-" (string-capitalize x))))
+ '("black" "blue" "brown" "indigo"
+ "orange" "pink" "red" "teal"))
+
+ (install-theme-variant
+ "deepPurple" "Material-Color-DeepPurple")
+ #t))))))
+ (home-page "https://github.com/hosxy/Fcitx5-Material-Color")
+ (synopsis "Fcitx 5 theme use Material Design")
+ (description "Fcitx5-material-color-theme contains Material Design theme
+with following color variants:
+
+@itemize
+@item Black
+@item Blue
+@item Brown
+@item Indigo
+@item Orange
+@item Pink
+@item Red
+@item teal
+@item DeepPurple
+@end itemize\n")
+ (license license:asl2.0)))
--
2.29.2