[PATCH] gnu: Add sbcl-make-hash.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 25 Nov 2020 15:55
(name . Guix Patches)(address . guix-patches@gnu.org)
MMztk1f--3-2@tuta.io
From af99a12dda37a9bfd9b07f3c8d8015d694f31699 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 25 Nov 2020 17:54:12 +0300
Subject: [PATCH] gnu: Add sbcl-make-hash.

* gnu/packages/lisp-xyz.scm (sbcl-make-hash): New variable.
---
 gnu/packages/lisp-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fe2af3e..e05fdc0 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6045,6 +6045,28 @@ neat APIs and connection-pooling.  It is meant to supersede Drakma.")
 (define-public ecl-dexador
   (sbcl-package->ecl-package sbcl-dexador))
 
+(define-public sbcl-make-hash
+  ;; no tagged branch
+  (let ((revision "1")
+        (commit "ae0909cd8e697520a1085fac6f54ac2b448ebd21"))
+    (package
+      (name "sbcl-make-hash")
+      (version (git-version "1.0.2" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/genovese/make-hash")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1qa4mcmb3pv44py0j129dd8hjx09c2akpnds53b69151mgwv5qz8"))))
+      (build-system asdf-build-system/sbcl)
+      (home-page "https://github.com/genovese/make-hash")
+      (synopsis "A Common Lisp package for hash table creation with flexible, extensible initializers")
+      (description "A Common Lisp package for hash table creation with flexible, extensible initializers.")
+      (license license:giftware))))
+
 (define-public sbcl-lisp-namespace
   (let ((commit "28107cafe34e4c1c67490fde60c7f92dc610b2e0")
         (revision "1"))
--
2.28.0
G
G
Guillaume Le Vaillant wrote on 29 Nov 2020 15:45
(name . Adam Kandur)(address . rndd@tuta.io)(address . 44868-done@debbugs.gnu.org)
87im9ob4rc.fsf@yamatai
Pushed as e3d5a20605a1541f363518e3e4c5eb9351d1a846 with some
modifications. Thanks.
Closed
?