[PATCH] gnu: Add sbcl-deploy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Adam Kandur
Owner
unassigned
Submitted by
Adam Kandur
Severity
normal
A
A
Adam Kandur wrote on 25 Nov 2020 15:43
(name . Guix Patches)(address . guix-patches@gnu.org)
MMzr037--3-2@tuta.io
From fea395c75af129e46c99847b4a38c1ddb396f1a2 Mon Sep 17 00:00:00 2001
From: Adam Kandur <rndd@tuta.io>
Date: Wed, 25 Nov 2020 17:40:55 +0300
Subject: [PATCH] gnu: Add sbcl-deploy.

* gnu/packages/lisp-xyz.scm (sbcl-deploy): New variable.
---
 gnu/packages/lisp-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index fe2af3e..1a5c1bf 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6031,6 +6031,32 @@ cookie headers, cookie creation, cookie jar creation and more.")
 neat APIs and connection-pooling.  It is meant to supersede Drakma.")
       (license license:expat))))
 
+(define-public sbcl-deploy
+  ;; tagged branch is outdated
+  (let ((revision "1")
+        (commit "59fd49719ef651a8fc11750bcfb337f132cff75f"))
+    (package
+      (name "sbcl-deploy")
+      (version (git-version "1.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Shinmera/deploy")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1vl2116z4kw2pd3qd3n6mmg8g0mnwxr9dgddk86g7j1bis1z8k9a"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("cffi" ,sbcl-cffi)
+     ("documentation-utils" ,sbcl-documentation-utils)))
+      (home-page "https://shinmera.github.io/deploy/")
+      (synopsis "Tools to aid in the deployment of a fully standalone application.")
+      (description "This is a system to help you easily and quickly deploy standalone common lisp applications as binaries. 
+Specifically it is geared towards applications with foreign library dependencies that run some kind of GUI.")
+      (license license:artistic2.0))))
+
 (define-public cl-dexador
   (package
     (inherit (sbcl-package->cl-source-package sbcl-dexador))
--
2.28.0
G
G
Guillaume Le Vaillant wrote on 29 Nov 2020 15:42
(name . Adam Kandur)(address . rndd@tuta.io)(address . 44866-done@debbugs.gnu.org)
87o8jgb4wy.fsf@yamatai
Pushed as 0fac1f259196d8c7e238e0a88e51a9bf462638d0 with some
modifications. Thanks.
Closed
?