Christopher Lemmer Webber wrote 4 years ago
(address . bug-guix@gnu.org)
Seems strange... the message I get:
guix deploy: error: failed to deploy tulsi: ~A: ~S
Errors upon errors! Formatting this time, apparently. :)
Looking at the relevant code:
(define (deploy-machine* store machine)
"Deploy MACHINE, taking care of error handling."
(info (G_ "deploying to ~a...~%")
(machine-display-name machine))
(guard (c ((message-condition? c)
(report-error (G_ "failed to deploy ~a: ~a~%")
(machine-display-name machine)
(condition-message c)))
((deploy-error? c)
(when (deploy-error-should-roll-back c)
(info (G_ "rolling back ~a...~%")
(machine-display-name machine))
(run-with-store store (roll-back-machine machine)))
(apply throw (deploy-error-captured-args c))))
(run-with-store store (deploy-machine machine))
(info (G_ "successfully deployed ~a~%")
(machine-display-name machine))))
I looked at other examples of report-error, they seemed similar.. can't
see why this one wouldn't be formatting correctly. Any idea?