[PATCH 1/2] gnu: Add elementary-xfce-icon-theme.

  • Done
  • quality assurance status badge
Details
One participant
  • Kei Kebreau
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 4 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20201122172002.14697-1-kkebreau@posteo.net
* gnu/packages/xfce.scm (elementary-xfce-icon-theme): New variable.
---
gnu/packages/xfce.scm | 38 +++++++++++++++++++++++++++++++++++++-
1 file changed, 37 insertions(+), 1 deletion(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 02e8093ddf..0d3328af3c 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Florian Paul Schmidt <mista.tapas@gmx.net>
-;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2017 Nikita <nikita@n0.is>
@@ -64,6 +64,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix gexp)
#:use-module ((guix licenses) #:hide (freetype))
#:use-module (guix packages)
@@ -202,6 +203,41 @@ storage system.")
to share commonly used Xfce widgets among the Xfce applications.")
(license lgpl2.0+)))
+(define-public elementary-xfce-icon-theme
+ (package
+ (name "elementary-xfce-icon-theme")
+ (version "0.15.1")
+ (source (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/shimmerproject/elementary-xfce.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rl15kh9c7qxw4pvwmw44fb4v3vwh6zin4wpx55bnvm5j76y6p3f"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t)))))
+ (native-inputs
+ `(("gtk+" ,gtk+)
+ ("optipng" ,optipng)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://shimmerproject.org/")
+ (synopsis "Elementary icons extended and maintained for Xfce")
+ (description "This is a fork of the upstream elementary project. This
+icon-theme is supposed to keep everything working, but gets updates from
+upstream occasionally.")
+ (license gpl2+)))
+
(define-public exo
(package
(name "exo")
--
2.29.2
Kei Kebreau wrote 4 years ago
[PATCH 2/2] gnu: Add greybird-gtk-theme.
(address . 44803@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20201122172432.15384-1-kkebreau@posteo.net
* gnu/packages/gnome-xyz.scm (greybird-gtk-theme): New variable.
---
gnu/packages/gnome-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index d69f14ba0e..bdf80ae2ac 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
@@ -42,6 +43,7 @@
#:use-module (gnu packages ssh)
#:use-module (gnu packages tls)
#:use-module (gnu packages ruby)
+ #:use-module (gnu packages web)
#:use-module (gnu packages xml))
(define-public matcha-theme
@@ -515,6 +517,34 @@ scrollable tiling of windows and per monitor workspaces. It's inspired by paper
notebooks and tiling window managers.")
(license license:gpl3)))
+(define-public greybird-gtk-theme
+ (package
+ (name "greybird-gtk-theme")
+ (version "3.22.12")
+ (source (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/shimmerproject/Greybird.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j66ddvl3pmwh2v8ajm8r5g5nbsr7r262ff1qn2nf3i0gy8b3lq8"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("gtk+" ,gtk+)
+ ("glib:bin" ,glib "bin") ; for "glib-compile-resources"
+ ("librsvg" ,librsvg)
+ ("pkg-config" ,pkg-config)
+ ("ruby-sass" ,ruby-sass)
+ ("sassc" ,sassc)))
+ (home-page "https://shimmerproject.org/")
+ (synopsis "Grey GTK+ theme based on Bluebird")
+ (description "Greybird is a grey derivative of the Bluebird theme by the
+Shimmer Project. It supports GNOME, Unity, and Xfce.")
+ (license (list license:gpl2+ license:cc-by-sa3.0))))
+
(define-public numix-gtk-theme
(package
(name "numix-gtk-theme")
--
2.29.2
Kei Kebreau wrote 4 years ago
(address . 44803@debbugs.gnu.org)
87blfitvpl.fsf@posteo.net
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (61 lines)
> * gnu/packages/gnome-xyz.scm (greybird-gtk-theme): New variable.
> ---
> gnu/packages/gnome-xyz.scm | 30 ++++++++++++++++++++++++++++++
> 1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index d69f14ba0e..bdf80ae2ac 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -4,6 +4,7 @@
> ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
> ;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
> ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
> +;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
> ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
> ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
> ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
> @@ -42,6 +43,7 @@
> #:use-module (gnu packages ssh)
> #:use-module (gnu packages tls)
> #:use-module (gnu packages ruby)
> + #:use-module (gnu packages web)
> #:use-module (gnu packages xml))
>
> (define-public matcha-theme
> @@ -515,6 +517,34 @@ scrollable tiling of windows and per monitor workspaces. It's inspired by paper
> notebooks and tiling window managers.")
> (license license:gpl3)))
>
> +(define-public greybird-gtk-theme
> + (package
> + (name "greybird-gtk-theme")
> + (version "3.22.12")
> + (source (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/shimmerproject/Greybird.git")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "1j66ddvl3pmwh2v8ajm8r5g5nbsr7r262ff1qn2nf3i0gy8b3lq8"))))
> + (build-system meson-build-system)
> + (native-inputs
> + `(("gtk+" ,gtk+)
> + ("glib:bin" ,glib "bin") ; for "glib-compile-resources"
> + ("librsvg" ,librsvg)
> + ("pkg-config" ,pkg-config)
> + ("ruby-sass" ,ruby-sass)
> + ("sassc" ,sassc)))
> + (home-page "https://shimmerproject.org/")
> + (synopsis "Grey GTK+ theme based on Bluebird")
> + (description "Greybird is a grey derivative of the Bluebird theme by the
> +Shimmer Project. It supports GNOME, Unity, and Xfce.")
> + (license (list license:gpl2+ license:cc-by-sa3.0))))
> +
> (define-public numix-gtk-theme
> (package
> (name "numix-gtk-theme")

Pushed to master as commits 213be7c5e4 and f43e7462d8.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAl/BWzYACgkQ5qXuPBlG
eg1gGA//QotLUglUqAPb3dJw31O7+oGMkJkEjz0aUlAx8D41ISzQHGLwhfep837s
SLUd5haMT3mpSseoTXSz30cipmB4wt4r0z3hNfRCxUEI2Ys2GgVnbDLwqvvg/jvG
TexLg1n5ITuxhe5mpnUt1uCv7Cy2ZsPaINVCBdIMWiOsu2Fi2HiJmC5ug77+0XSW
yUW97qdtckImMgUDWDdS55fYs73bh0bKuSTPdH2gXuu0NunfSzk+K/nsDbDAZHjo
MtYXyCCkHDjNa5LQnWxd/XffPFzchx2JCjOWQeSqCexCEU0iPQnm1YJC2L5twh2d
/or3iHXm3PmQ/PNtzRgYhWHrkRjVSfiZkOllttNo5sK1X2hZ0WxFAO9mhJqMYQEq
gwnstSfE3FJFOGDAKxiDtCORbSqHGE+D+2DVdAbWyEs+4WPDCYKm9Zjv/Oxs+szL
VQVqf3/buy6HfttB9pLFgDe7pnEHyr79+4i2bJo2hIu9iwDIHu5WDgO5VzNxMvDB
YmQ+p5nSsXZIP0dCI7tFLTVuAvGuUQjUXgwvy426FkLcsY+dJqKYtXYScQb6/7Rq
9ETDHUmYUh62jvWOWBo1XQukDxwD8K769PYoSEpvgAymF0gugSz5azUftlJowP7y
OPbAgCcFTNNhxTg+fn41Iwdsjv7uq5QiTx3B6mAN8sjMeEPLAqs=
=gXTU
-----END PGP SIGNATURE-----

Kei Kebreau wrote 4 years ago
(address . 44803-done@debbugs.gnu.org)
877dq6tvm4.fsf@posteo.net
Toggle quote (1 lines)
> Pushed to master as commits 213be7c5e4 and f43e7462d8.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAl/BW7MACgkQ5qXuPBlG
eg2H4Q//e8BSL1oYJs/AJMj5aHmp8TChNxl5+BT75VCQP5e3SssP/74E4p3iiYka
X+ur89ND47rzmTRCl5d6S/YroGqfX7YXcuX8mbgvGC5zJ6NgPzLJfeh28dlYQPWC
Zz35G587kxGQkPsuuJyLlCxFDzs8jpqfZdhR0J1aT967eSFslvTQ59sNwLRWsaPW
zBtU2G0S54fJGFLzAxI+yzKivimPm0M60bS/6iGF926hfSQ4vPlHp1Q/bENgxVbe
wAM7J36Kdgcm96VquatmJ7sH/D8QGJKWfb9Uidq6aLFQyHD7fbBtilxSNWHKz14+
JhMmzB1oWjYNR4SrtYtEKhw1W3dGg9JHfkpH9TpO5uW6yjMu00ye9G/GR/r/rH1c
KFp5pe/XcFQqnaKbblXBJcQ0k6pNgXBnrjOsafYzFA014NSqHZP/wvYqiSCS+S09
W0r3vuQs7JE4JbrHaijdtMbQ9kKu+TVt33BdBvaKOOyAlvCksp2eRA7kk8AXFwMo
mqVzAcqrX9bKVbLzIP6kMEawIjI0ps1JljTIY6u1/YMTHUCmZlSlqxoYgFvV+HpO
Zfhw4csttVw+Q2vo8dhpNJr66q90+k9id3H7X3krE3yX+sFItAuK432Azl67oQej
7IdNHQD/Yk3CNBm5MAnCbZRKGurAz5KuPpiSIv8gHkwPx738j3E=
=bQ4Q
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44803@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44803
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help