[PATCH] gnu: Add python-commonmark.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 22 Nov 2020 03:48
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20201122024818.51128-1-monego@posteo.net
* gnu/packages/python-xyz.scm (python-commonmark): New variable.
---
gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b53cb25c59..82ce037fde 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8831,6 +8831,32 @@ Supported netlink families and protocols include:
(define-public python2-wrapt
(package-with-python2 python-wrapt))
+(define-public python-commonmark
+ (package
+ (name "python-commonmark")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "commonmark" version))
+ (sha256
+ (base32 "0q7d39lm8kcingpmykk5r959hrwwj6v2icyw3mihczxyb749sbs5"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "setup.py" "test"))))))
+ (home-page "https://github.com/readthedocs/commonmark.py")
+ (synopsis "Python parser for the CommonMark Markdown spec")
+ (description
+ "This module is a pure Python port of jgm's @code{commonmark.js}, a
+Markdown parser and renderer for the CommonMark specification, using only
+native modules.")
+ (license license:bsd-3)))
+
(define-public python-xlrd
(package
(name "python-xlrd")
--
2.20.1
N
N
Nicolas Goaziou wrote on 24 Nov 2020 13:57
(name . Vinicius Monego)(address . monego@posteo.net)(address . 44787-done@debbugs.gnu.org)
87y2iqq5ds.fsf@nicolasgoaziou.fr
Hello,

Vinicius Monego <monego@posteo.net> writes:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm (python-commonmark): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?