Python and Gajim-OMEMO

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
R
R
Raghav Gururajan wrote on 21 Nov 2020 19:55
(address . bug-guix@gnu.org)
afe85397-5db8-7f5a-a550-bae34e99af93@raghavgururajan.name
Hello Guix!

It appears that our python is incorrectly compiled or compiled with
missing component. Due to this, OMEMO plugin in gajim does not work.

Here is the output for `gajim -l gajim.p.omemo=DEBUG`:

*** START ***
Traceback (most recent call last):
File
"/gnu/store/5h0xfqysfddzc4283wcyr0j8jj2zaz9c-gajim-1.2.2/bin/..gajim-real-real",
line 4, in <module>
import re
File
"/gnu/store/09a5iq080g9b641jyl363dr5jkkvnhcn-python-3.8.2/lib/python3.8/re.py",
line 143, in <module>
class RegexFlag(enum.IntFlag):
AttributeError: module 'enum' has no attribute 'IntFlag'
*** END ***

Also, I am flagging this issue as 'important' as it affects
security/privacy of messaging in gajim application.

Regards,
RG.
Attachment: OpenPGP_signature
R
R
Raghav Gururajan wrote on 21 Nov 2020 19:57
(no subject)
(address . control@debbugs.gnu.org)
659ac587-923f-ce7a-b1db-627e0d986c65@raghavgururajan.name
severity 44782 important
Attachment: OpenPGP_signature
M
M
Maxim Cournoyer wrote on 29 Dec 2020 05:09
control message for bug #44782
(address . control@debbugs.gnu.org)
871rf9w8wu.fsf@gmail.com
severity 44782 normal
quit
M
M
Maxim Cournoyer wrote on 29 Dec 2020 05:12
Re: bug#44782: Python and Gajim-OMEMO
(name . Raghav Gururajan)(address . rg@raghavgururajan.name)(address . 44782@debbugs.gnu.org)
87wnx1uu72.fsf@gmail.com
Hello Raghav,

Raghav Gururajan <rg@raghavgururajan.name> writes:

Toggle quote (26 lines)
> Hello Guix!
>
> It appears that our python is incorrectly compiled or compiled with
> missing component. Due to this, OMEMO plugin in gajim does not work.
>
> Here is the output for `gajim -l gajim.p.omemo=DEBUG`:
>
> *** START ***
> Traceback (most recent call last):
> File
> "/gnu/store/5h0xfqysfddzc4283wcyr0j8jj2zaz9c-gajim-1.2.2/bin/..gajim-real-real",
> line 4, in <module>
> import re
> File
> "/gnu/store/09a5iq080g9b641jyl363dr5jkkvnhcn-python-3.8.2/lib/python3.8/re.py",
> line 143, in <module>
> class RegexFlag(enum.IntFlag):
> AttributeError: module 'enum' has no attribute 'IntFlag'
> *** END ***
>
> Also, I am flagging this issue as 'important' as it affects
> security/privacy of messaging in gajim application.
>
> Regards,
> RG.

It's not a problem with Python but with Gaijim or one of its dependency:

Toggle snippet (4 lines)
$ guix environment --pure --ad-hoc python -- python3 -c 'import enum;print(enum.IntFlag)'
<enum 'IntFlag'>

Summarily searching on the interwebs it seems that python-enum34 may be
at cause. You should look if it's being propagated by any of the
dependencies of gajim or gajim-omemo, and probably get rid of those as
this package exists for backward compatibility for Python versions older
than our 3.8.2 on master.

Maxim
M
M
Maxim Cournoyer wrote on 29 Dec 2020 05:31
(name . Raghav Gururajan)(address . rg@raghavgururajan.name)(address . 44782@debbugs.gnu.org)
87sg7putbj.fsf@gmail.com
Hello again,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

Toggle quote (41 lines)
> Hello Raghav,
>
> Raghav Gururajan <rg@raghavgururajan.name> writes:
>
>> Hello Guix!
>>
>> It appears that our python is incorrectly compiled or compiled with
>> missing component. Due to this, OMEMO plugin in gajim does not work.
>>
>> Here is the output for `gajim -l gajim.p.omemo=DEBUG`:
>>
>> *** START ***
>> Traceback (most recent call last):
>> File
>> "/gnu/store/5h0xfqysfddzc4283wcyr0j8jj2zaz9c-gajim-1.2.2/bin/..gajim-real-real",
>> line 4, in <module>
>> import re
>> File
>> "/gnu/store/09a5iq080g9b641jyl363dr5jkkvnhcn-python-3.8.2/lib/python3.8/re.py",
>> line 143, in <module>
>> class RegexFlag(enum.IntFlag):
>> AttributeError: module 'enum' has no attribute 'IntFlag'
>> *** END ***
>>
>> Also, I am flagging this issue as 'important' as it affects
>> security/privacy of messaging in gajim application.
>>
>> Regards,
>> RG.
>
> It's not a problem with Python but with Gaijim or one of its dependency:
>
> $ guix environment --pure --ad-hoc python -- python3 -c 'import enum;print(enum.IntFlag)'
> <enum 'IntFlag'>
>
> Summarily searching on the interwebs it seems that python-enum34 may be
> at cause. You should look if it's being propagated by any of the
> dependencies of gajim or gajim-omemo, and probably get rid of those as
> this package exists for backward compatibility for Python versions older
> than our 3.8.2 on master.

Actually, I can't seem to reproduce, using:

guix environment --pure --ad-hoc gajim gajim-omemo -- gajim -l
gajim.p.omemo=DEBUG

Then I tried signing up with some random account, enabled the plugin and
I could see:

12/28/20 23:28:16 (I) gajim.p.omemo ($some-server) Generating OMEMO keys
12/28/20 23:28:21 (I) gajim.p.omemo ($some-server) Our device id: 1816266738
12/28/20 23:28:21 (I) gajim.p.omemo ($some-server) 100 PreKeys available

It seems like you may have 'pip3 install enum34' or have other things in
your environment that cause the issue?

If you can't reproduce in a clean environment, let's close it.

Thanks,

Maxim
R
R
Raghav Gururajan wrote on 29 Dec 2020 19:20
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 44782@debbugs.gnu.org)
31e0e157-ac42-d277-e6ad-514b4db254c6@raghavgururajan.name
Hi Maxim!

Toggle quote (17 lines)
> Actually, I can't seem to reproduce, using:
>
> guix environment --pure --ad-hoc gajim gajim-omemo -- gajim -l
> gajim.p.omemo=DEBUG
>
> Then I tried signing up with some random account, enabled the plugin and
> I could see:
>
> 12/28/20 23:28:16 (I) gajim.p.omemo ($some-server) Generating OMEMO keys
> 12/28/20 23:28:21 (I) gajim.p.omemo ($some-server) Our device id: 1816266738
> 12/28/20 23:28:21 (I) gajim.p.omemo ($some-server) 100 PreKeys available
>
> It seems like you may have 'pip3 install enum34' or have other things in
> your environment that cause the issue?
>
> If you can't reproduce in a clean environment, let's close it.

Oh, I sent an email to debbugs-control long ago to close this bug. It
seems like the email didn't go through. I'll retry.

After discussing with cbaines in IRC, the issue was resolved. It was
python2-enum in the environment that was messing with python-enum.

Regards,
RG.
M
M
Maxim Cournoyer wrote on 29 Dec 2020 19:23
(name . Raghav Gururajan)(address . rg@raghavgururajan.name)(address . 44782-done@debbugs.gnu.org)
87k0t0v5cr.fsf@gmail.com
Hello Raghav,

Raghav Gururajan <rg@raghavgururajan.name> writes:

Toggle quote (20 lines)
> Hi Maxim!
>
>> Actually, I can't seem to reproduce, using:
>> guix environment --pure --ad-hoc gajim gajim-omemo -- gajim -l
>> gajim.p.omemo=DEBUG
>> Then I tried signing up with some random account, enabled the plugin
>> and
>> I could see:
>> 12/28/20 23:28:16 (I) gajim.p.omemo ($some-server)
>> Generating OMEMO keys
>> 12/28/20 23:28:21 (I) gajim.p.omemo ($some-server) Our device id: 1816266738
>> 12/28/20 23:28:21 (I) gajim.p.omemo ($some-server) 100 PreKeys available
>> It seems like you may have 'pip3 install enum34' or have other
>> things in
>> your environment that cause the issue?
>> If you can't reproduce in a clean environment, let's close it.
>
> Oh, I sent an email to debbugs-control long ago to close this bug. It
> seems like the email didn't go through. I'll retry.

It seems your message hadn't reached Debbugs.

No worries, I'm closing it now, by replying in Cc: to
44782-done@debbugs.gnu.org.

Thanks for the report!

Maxim
Closed
?