[PATCH] gnu: Properly use $QTWEBENGINEPROCESS_PATH

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal

Debbugs page

Sergey Trofimov wrote 4 years ago
(address . guix-patches@gnu.org)
20201120211907.23975-1-sarg@sarg.org.ru
I've noticed that installing supercollider breaks qutebrowser. It happens
because QTWEBENGINEPROCESS_PATH is not a search path, but rather a full path
to a file. So supercollider puts this var into the user profile and then
qutebrowser's wrapper incorrectly concatenates it with the path coming from
the qtwebengine dependency. Calibre package has the same defect.
Sergey Trofimov wrote 4 years ago
(address . 44771@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
20201121101102.25373-1-sarg@sarg.org.ru
---
gnu/packages/ebook.scm | 2 +-
gnu/packages/web-browsers.scm | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 1609a631b7..e80ad45383 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -281,7 +281,7 @@
(lambda (binary)
(wrap-program binary
;; Make QtWebEngineProcess available.
- `("QTWEBENGINEPROCESS_PATH" ":" =
+ `("QTWEBENGINEPROCESS_PATH" =
,(list (string-append
qtwebengine
"/lib/qt5/libexec/QtWebEngineProcess")))))
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 51af66ef54..bf1d45e5cc 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -538,7 +538,7 @@ interface.")
(assoc-ref inputs "qtwebengine")
"/lib/qt5/libexec/QtWebEngineProcess")))
(wrap-program bin
- `("QTWEBENGINEPROCESS_PATH" ":" prefix (,qt-process-path)))
+ `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
#t))))))
(home-page "https://qutebrowser.org/")
(synopsis "Minimal, keyboard-focused, vim-like web browser")
--
2.29.2
Christopher Baines wrote 4 years ago
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 44771-done@debbugs.gnu.org)
87360ttp71.fsf@cbaines.net
Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (32 lines)
> ---
> gnu/packages/ebook.scm | 2 +-
> gnu/packages/web-browsers.scm | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
> index 1609a631b7..e80ad45383 100644
> --- a/gnu/packages/ebook.scm
> +++ b/gnu/packages/ebook.scm
> @@ -281,7 +281,7 @@
> (lambda (binary)
> (wrap-program binary
> ;; Make QtWebEngineProcess available.
> - `("QTWEBENGINEPROCESS_PATH" ":" =
> + `("QTWEBENGINEPROCESS_PATH" =
> ,(list (string-append
> qtwebengine
> "/lib/qt5/libexec/QtWebEngineProcess")))))
> diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
> index 51af66ef54..bf1d45e5cc 100644
> --- a/gnu/packages/web-browsers.scm
> +++ b/gnu/packages/web-browsers.scm
> @@ -538,7 +538,7 @@ interface.")
> (assoc-ref inputs "qtwebengine")
> "/lib/qt5/libexec/QtWebEngineProcess")))
> (wrap-program bin
> - `("QTWEBENGINEPROCESS_PATH" ":" prefix (,qt-process-path)))
> + `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
> #t))))))
> (home-page "https://qutebrowser.org/")
> (synopsis "Minimal, keyboard-focused, vim-like web browser")

Thanks, I split this in to two commits, wrote commit messages and pushed
to master in f4d139d02f0b0404540b74f3249de050b519b880.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/CfDNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XehfBAAl8CfRhuVd2nhcU19w6bQwKbDp2tXug5s
moLCHkfrtId67Eg1ieMo1FEhnl4T+OfRyKZy0UnYfjAXngw/2ky9ZPxd+2IwvcSn
uNmP/+g6HQI9sYkHjz/pTZBYdblDqBBMzTQhZOByu/zzETELL6JG3HJ91zjeOcea
luIbpBrgcTlG44tc9uv3BVyhX1ucBMCyArXQ9beNmpchoplwUvOOaJfOVxs5uX31
Wt9JAuducUry8b9BmBiAYCnllKeV8PqP1EAPxiwKBhyYDQN8iIetPswlJnpZG2XH
2QvGeqH3zqTLrppjX7pTKUDPztYTU5roZYZ3xh0TGrHspvyr3OkIXvzoIN12deMr
6WZfNlPU4PoKAoXqEab4GUAVQBax3B3yCBe2c4CMQ22Gy29OKjg5xvcgupruOLyf
avCanhTqPDF7Il5LII55PajxRioAh68NtQjNgDB28wmCPpWcIlRj2IKConnyu616
5FlpVAa62i1l1GfM7wqQcpq+aldoMfUBt4EusJZ3wEp4wkLuMEiqClSV5leAZ88g
6/w489QNjVPs3uHifnKVNs6AviRf0nQRBqQwSgjLSJmnKloPHlEFhtfKO5GC6tn/
/WEirqoHriCCDkn7GK3ICgP0BYrLDP1cp0E862e8VcBRBNh9XTOx4saZSvfV47Bw
9p3TyGrNgVc=
=JsJH
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44771@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44771
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help