tests/swh.scm hangs building guix with guile-2.2

  • Open
  • quality assurance status badge
Details
2 participants
  • Vagrant Cascadian
  • zimoun
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal
V
V
Vagrant Cascadian wrote on 20 Nov 2020 02:52
(address . bug-guix@gnu.org)
87v9e0vlpm.fsf@yucca
I'm exploring building with guile 2.2 because guile-gnutls built with
guile 3.0 is only available in experimental, and even there, missing for
arm64.

FAIL: tests/swh.scm - lookup-origin

And then hangs indefinitely. I've seen it run for hours at a time. Works
fine with guile 3.0.


In tests/swh.log, there is not much there, though obviously seems
problematic:

warning: cannot run Web server for tests: Address already in use
In thread:
In procedure listen: Wrong type argument in position 1 (expecting open
file port): #f


I don't have any debian patches applied to tests/swh.scm and do not
think any other patches are likely to affect this here, but you never
know. :)


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCX7chVQAKCRDcUY/If5cW
qgrLAP9AHoIfyQQCoBMLTceqbeWkp+vdqODVUUwV6ebSQ8OIZgEAlghL7GeYSKnX
rVvDtlelgPACP3gD8KQSXEs1tcrYWgs=
=YMRh
-----END PGP SIGNATURE-----

Z
Z
zimoun wrote on 20 Nov 2020 10:36
863614xtcf.fsf@gmail.com
Hi Vagrant,

On Thu, 19 Nov 2020 at 17:52, Vagrant Cascadian <vagrant@debian.org> wrote:

Toggle quote (6 lines)
> I'm exploring building with guile 2.2 because guile-gnutls built with
> guile 3.0 is only available in experimental, and even there, missing for
> arm64.
>
> FAIL: tests/swh.scm - lookup-origin

I remember issues fixed by 722ad41c44a499d2250c79527ef7d069ca728de0
which maybe introduce a regression for Guile 2.2.

Toggle snippet (8 lines)
+;; XXX: Work around a bug in Guile 3.0.2 where #:verify-certificate? would
+;; be ignored (<https://bugs.gnu.org/40486>).
+(define* (http-get* uri #:rest rest)
+ (apply http-request uri #:method 'GET rest))
+(define* (http-post* uri #:rest rest)
+ (apply http-request uri #:method 'POST rest))

Maybe it is related.

All the best,
simon
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 44751@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44751
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch