(address . bug-guix@gnu.org)
I'm exploring building with guile 2.2 because guile-gnutls built with
guile 3.0 is only available in experimental, and even there, missing for
arm64.
From tests/lint.log:
test-name: archival: missing content
location: /build/guix-EdK9LP/guix-1.2.0~rc2/tests/lint.scm:921
source:
+ (test-assert
+ "archival: missing content"
+ (let* ((origin
+ (origin
+ (method url-fetch)
+ (uri "http://example.org/foo.tgz")
+ (sha256 (make-bytevector 32))))
+ (warnings
+ (with-http-server
+ '((404 "Not archived."))
+ (parameterize
+ ((%swh-base-url (%local-url)))
+ (check-archival
+ (dummy-package "x" (source origin)))))))
+ (warning-contains? "not archived" warnings)))
actual-value: #f
actual-error:
+ (keyword-argument-error
+ #<procedure http-request (uri #:key body port method version keep-alive? headers decode-body? streaming? request)>
+ "Unrecognized keyword"
+ ()
+ (#:verify-certificate?))
result: FAIL
I haven't tried reproducing this without the Debian patches applied
which liberally sprinkle the test suites with:
(unless (network-reachable? (test-skip 1))
... but if you can spot a likely issue, I'd be happy to test it. :)
live well,
vagrant
-----BEGIN PGP SIGNATURE-----
iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCX7cPXgAKCRDcUY/If5cW
qrp/AQD/8lkMtonIhZwWBN+MSp/Am3BP+JlDk8Ix+RJbsmw2sQD+MKcC8TambTi8
SyhWF/aH/fnBMIY5Cj7Bi6wH3Fu2gQM=
=g6eo
-----END PGP SIGNATURE-----