[PATCH] gnu: gnubg: Prevent building with avx instructions.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Michael Rohleder
Owner
unassigned
Submitted by
Michael Rohleder
Severity
normal

Debbugs page

Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
20201116121737.22825-1-mike@rohleder.de
* gnu/packages/games.scm (gnubg): Prevent building with avx instructions.
[arguments]: Add configure-flags for Intel systems.
---
gnu/packages/games.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 97b0cb976d..12cc64fefa 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1605,7 +1605,14 @@ such as chess or stockfish.")
(native-inputs `(("python-2" ,python-2)
("pkg-config" ,pkg-config)))
(arguments
- `(#:phases
+ `(#:configure-flags
+ ;; SSE instructions are available on Intel systems only.
+ (list ,@(if (any (cute string-prefix? <> (or (%current-target-system)
+ (%current-system)))
+ '("x86_64" "i686"))
+ '("--enable-simd=sse2") ; prevent avx instructions
+ '()))
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'install-desktop-file
(lambda* (#:key outputs #:allow-other-keys)
--
2.29.2
Kei Kebreau wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 44681@debbugs.gnu.org)
87pn4bv1qa.fsf@posteo.net
Hi Michael!

Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (3 lines)
> * gnu/packages/games.scm (gnubg): Prevent building with avx instructions.
> [arguments]: Add configure-flags for Intel systems.

I'd modify the commit message to be a bit shorter, like so:

gnu: gnubg: Prevent building with AVX instructions.

* gnu/packages/games.scm (gnubg)[arguments]: Add configure-flags for Intel
systems to build without AVX instructions.

Toggle quote (25 lines)
> ---
> gnu/packages/games.scm | 9 ++++++++-
> 1 file changed, 8 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 97b0cb976d..12cc64fefa 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -1605,7 +1605,14 @@ such as chess or stockfish.")
> (native-inputs `(("python-2" ,python-2)
> ("pkg-config" ,pkg-config)))
> (arguments
> - `(#:phases
> + `(#:configure-flags
> + ;; SSE instructions are available on Intel systems only.
> + (list ,@(if (any (cute string-prefix? <> (or (%current-target-system)
> + (%current-system)))
> + '("x86_64" "i686"))
> + '("--enable-simd=sse2") ; prevent avx instructions
> + '()))
> + #:phases
> (modify-phases %standard-phases
> (add-after 'install 'install-desktop-file
> (lambda* (#:key outputs #:allow-other-keys)

Otherwise, the patch looks and works fine. I didn't even know that GNU
Backgammon didn't work on my machine until I tested this patch!

Please let me know whether you're okay with the commit message
modification, and I'll push this for you.

Thanks,
Kei
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAl+0hn0ACgkQ5qXuPBlG
eg0Kug//UkPC2JuAb8V0SiL5CwlyRyNHiIG9I9h+nxkWqLTExzlLUPndJAZi8mf1
PBi8vSfgtb6mMPzkP5ulBxOpW/EeVwJsDojfXKct/OCXg5k5PDaKOKwIuz2u5k0f
qoI87zjWaqJWEgr2t+QKK1gIgGDQ6tWSBWp3Pul9T/is7Qom1WpRrBGvTpmJAVOc
WtlhsmSn1Wg/OgualelVZLrA0j2bCfvfWIl95MNHpXnc4iQWaWybv7u0fNiYdoMa
uENlk3DYkrojat1ydhgR033z0BhFmhDqEUkdOklETQRf3l3NXCT8FtkceKKLDRRx
Bs0JyBGVEdzKiVJWE7/HLxqMHmyGyj8kX1Wpcb829exhSNrrRbLRqnFV/NNHynLd
oxJ5uFeVlwkMjpjXhQ7mnWEDi0NmwBsherzk3+pZiJ4xTvG/3eSq51EQVfVd4bQn
sTCZxK+E0G7lVCaakug4VtUZvPRDiXL+HlgeT/T4DzKy2SNB4E7EsvJxT4HS96DF
H/nspRq0/23wuYyEsgerFx6saRJwdlJZPEL90Nqb4+JjoM48c5xw3yv6P3DHBTuU
yQKjg+DRq1eK/91utzSRI77ZxpuKwQoFv5IhCZMbvEq+Eb/4XrPVWhQcLaMo9kZu
0oKT/LYzt4qyI5hEC40kBGZ5nM30F5KB6BtveoMVpRdOX3TVQ88=
=VjAT
-----END PGP SIGNATURE-----

Michael Rohleder wrote 4 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 44681@debbugs.gnu.org)
87sg976tq9.fsf@rohleder.de
Hi Kei!

Kei Kebreau <kkebreau@posteo.net> writes:
Toggle quote (3 lines)
> Please let me know whether you're okay with the commit message
> modification, and I'll push this for you.

This is perfectly fine!
Thank you very much for reviewing, testing, rewriting, asking and
pushing ;)

--
Some people claim that the UNIX learning curve is steep, but at least you
only have to climb it once.
-----BEGIN PGP SIGNATURE-----

iQFFBAEBCAAvFiEEdV4t5dDVhcUueCgwfHr/vv7yyyUFAl+0xP4RHG1pa2VAcm9o
bGVkZXIuZGUACgkQfHr/vv7yyyVC3Qf/Y34Z2wKPGegj/pB01BO0QzFCHQpwE5xK
a3gJNrmhry2yVTjE6S+ZcLwsRUAZzU3rXTFph4ptdN2zI0jsAcTCGWZSLSLIp8gK
tzqRjz/jq9icxH1qAe2B4HIBPjTcjNDoWc6eqqpMZEJAdra/lojvx1yyxEPUi9B/
UgaMCEjqKaI2qPWwhJQ2brlkWDyr1uKSwqP3cJImJrKz0hZhQ7JYolsSjdjYAyO1
ICFimxlKH11P0+RhoOW6N6JzBmlIniaj82cZRtyV4RyGJLHGglHba0X/BwcX/mrt
1daf74tVxG6RTSZ429DzRvhtqmgbEQ8sCl9BBvgYslBZCZsw2aQn2g==
=g0PY
-----END PGP SIGNATURE-----

Kei Kebreau wrote 4 years ago
(name . Michael Rohleder)(address . mike@rohleder.de)(address . 44681-done@debbugs.gnu.org)
87lfeyvjy4.fsf@posteo.net
Michael Rohleder <mike@rohleder.de> writes:

Toggle quote (10 lines)
> Hi Kei!
>
> Kei Kebreau <kkebreau@posteo.net> writes:
>> Please let me know whether you're okay with the commit message
>> modification, and I'll push this for you.
>
> This is perfectly fine!
> Thank you very much for reviewing, testing, rewriting, asking and
> pushing ;)

You're welcome! This patch has been pushed to master as commit
82df93e27c.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAl+1KkMACgkQ5qXuPBlG
eg1uVxAAsAePytQ+IC4/jy16PqUgq7H5WDQun09ZvKb3qnLtQIZtAJiXEiqxozoe
BHpFWd49kVIYtDB6tKKPip3ZMn/jbzQ/ErWj3wRKfp8QzGazuo3/YrpSJvE1rX6d
P6THkhvQJ3kv1sfTaie3B6FaMX0x17pn/xS5jVZJX+Ms2fhF403tbzo+jnR4Lksi
5N8enurgYwE/U/Db5GuChUec+jU6w3XN6t9pLGHOWAQZVvdJr78DqyiY6wYwMhts
2FQoE/j9Gm5NbjYHDw6cZl8RbZJDN471BDwKZ8ZS+UqWe+h9VO/funntuF22Er8E
Tya1ItkcmG+U5/2kwwWng7fwN2p+UxLb4JYc9ldNmjV8HDfMMCqPc8x/dGA9nQoB
zJKJCJEBp9zip3cB7ONSD+l/v1d9nA8OcSRo9I6x/nEasmFHhFRYhBV2qpBEMeZC
Jvo16rMjPejFCpONGt6dxFQbaKLQWD3Rm5NSwXFd3N+dETu41j+wH4cKEW0IwAVv
Mkq90zcUH8nesGu60Oo/oF7v/Vu5hlLs39dUrCJj0c6fieyFtsUiXkBPtWtu1LfX
nvnEvc0Loqm4Rbx3Rw+zSQAiyk77iVP8vs1h90s7I4l4PeZq5+pw4MziCCAwySLr
i0bL3SbEmw0dKXdNCL2PWaOJaVAN1ZTXO/lB7XWozWWgoGL5B5Y=
=MSQo
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44681@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44681
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help