Michael Rohleder wrote 4 years ago
(address . guix-patches@gnu.org)(name . Michael Rohleder)(address . mike@rohleder.de)
* gnu/packages/games.scm (gnubg): Prevent building with avx instructions.
[arguments]: Add configure-flags for Intel systems.
---
gnu/packages/games.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
Toggle diff (22 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 97b0cb976d..12cc64fefa 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1605,7 +1605,14 @@ such as chess or stockfish.")
(native-inputs `(("python-2" ,python-2)
("pkg-config" ,pkg-config)))
(arguments
- `(#:phases
+ `(#:configure-flags
+ ;; SSE instructions are available on Intel systems only.
+ (list ,@(if (any (cute string-prefix? <> (or (%current-target-system)
+ (%current-system)))
+ '("x86_64" "i686"))
+ '("--enable-simd=sse2") ; prevent avx instructions
+ '()))
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'install-desktop-file
(lambda* (#:key outputs #:allow-other-keys)
--
2.29.2