[PATCH] gnu: Add uuid support (back?) to recutils.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Soo
  • Ludovic Courtès
Owner
unassigned
Submitted by
John Soo
Severity
normal
J
J
John Soo wrote on 14 Nov 2020 21:46
(address . bug-guix@gnu.org)
87v9e7wtt5.fsf@asu.edu
Hi Guix,

I've been getting into some recutils recently and I found out ours is
not configured with uuid support. Perhaps there are other optional
things we could add?

- John
From ad122b175d798ab3d50e7b41337694538043a218 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sat, 14 Nov 2020 12:42:10 -0800
Subject: [PATCH] gnu: Add uuid support to recutils.

* gnu/packages/databases.scm (recutils): [inputs] Add lib output of
util-linux.
---
gnu/packages/databases.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index c3fb9b5c5f..c011bd398e 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1144,12 +1144,13 @@ organized in a hash table or B+ tree.")
(native-inputs `(("bc" ,bc)
("bash:include" ,bash "include")
("check" ,check)
- ("libuuid" ,util-linux)
+ ("libuuid:out" ,util-linux)
("pkg-config" ,pkg-config)))
;; TODO: Add more optional inputs.
(inputs `(("curl" ,curl)
- ("libgcrypt" ,libgcrypt)))
+ ("libgcrypt" ,libgcrypt)
+ ("libuuid:lib" ,util-linux "lib")))
(synopsis "Manipulate plain text files as databases")
(description
"GNU Recutils is a set of tools and libraries for creating and
--
2.29.1
L
L
Ludovic Courtès wrote on 16 Nov 2020 12:32
(name . John Soo)(address . jsoo1@asu.edu)(address . 44646@debbugs.gnu.org)
87ima5zgen.fsf@gnu.org
Hi,

John Soo <jsoo1@asu.edu> skribis:

Toggle quote (8 lines)
> From ad122b175d798ab3d50e7b41337694538043a218 Mon Sep 17 00:00:00 2001
> From: John Soo <jsoo1@asu.edu>
> Date: Sat, 14 Nov 2020 12:42:10 -0800
> Subject: [PATCH] gnu: Add uuid support to recutils.
>
> * gnu/packages/databases.scm (recutils): [inputs] Add lib output of
> util-linux.

[...]

Toggle quote (6 lines)
> (native-inputs `(("bc" ,bc)
> ("bash:include" ,bash "include")
> ("check" ,check)
> - ("libuuid" ,util-linux)
> + ("libuuid:out" ,util-linux)

Is this one even necessary? (The label is misleading.)

Toggle quote (8 lines)
> ("pkg-config" ,pkg-config)))
>
> ;; TODO: Add more optional inputs.
> (inputs `(("curl" ,curl)
> - ("libgcrypt" ,libgcrypt)))
> + ("libgcrypt" ,libgcrypt)
> + ("libuuid:lib" ,util-linux "lib")))

Thanks,
Ludo’.
J
J
John Soo wrote on 16 Nov 2020 17:16
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 44646@debbugs.gnu.org)
874klpqnt5.fsf@asu.edu
Hi,


Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (19 lines)
>> (native-inputs `(("bc" ,bc)
>> ("bash:include" ,bash "include")
>> ("check" ,check)
>> - ("libuuid" ,util-linux)
>> + ("libuuid:out" ,util-linux)
>
> Is this one even necessary? (The label is misleading.)
>
>> ("pkg-config" ,pkg-config)))
>>
>> ;; TODO: Add more optional inputs.
>> (inputs `(("curl" ,curl)
>> - ("libgcrypt" ,libgcrypt)))
>> + ("libgcrypt" ,libgcrypt)
>> + ("libuuid:lib" ,util-linux "lib")))
>
> Thanks,
> Ludo’.

It seems to build OK without the native-input, so I removed it.

Thanks,

John
From c7eee6d96ea4ce6516f6a528e3d2110f96fb44ec Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sat, 14 Nov 2020 12:42:10 -0800
Subject: [PATCH] gnu: Add uuid support to recutils.

* gnu/packages/databases.scm (recutils): [inputs] Add lib output of
util-linux.
---
gnu/packages/databases.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index c3fb9b5c5f..a36a43e188 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1144,12 +1144,12 @@ organized in a hash table or B+ tree.")
(native-inputs `(("bc" ,bc)
("bash:include" ,bash "include")
("check" ,check)
- ("libuuid" ,util-linux)
("pkg-config" ,pkg-config)))
;; TODO: Add more optional inputs.
(inputs `(("curl" ,curl)
- ("libgcrypt" ,libgcrypt)))
+ ("libgcrypt" ,libgcrypt)
+ ("libuuid" ,util-linux "lib")))
(synopsis "Manipulate plain text files as databases")
(description
"GNU Recutils is a set of tools and libraries for creating and
--
2.29.1
L
L
Ludovic Courtès wrote on 18 Nov 2020 23:04
(name . John Soo)(address . jsoo1@asu.edu)(address . 44646-done@debbugs.gnu.org)
87ima2jp93.fsf@gnu.org
Hi,

John Soo <jsoo1@asu.edu> skribis:

Toggle quote (8 lines)
> From c7eee6d96ea4ce6516f6a528e3d2110f96fb44ec Mon Sep 17 00:00:00 2001
> From: John Soo <jsoo1@asu.edu>
> Date: Sat, 14 Nov 2020 12:42:10 -0800
> Subject: [PATCH] gnu: Add uuid support to recutils.
>
> * gnu/packages/databases.scm (recutils): [inputs] Add lib output of
> util-linux.

Perfect. Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44646@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44646
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch