(address . bug-guix@gnu.org)
Hi Guix,
I've been getting into some recutils recently and I found out ours is
not configured with uuid support. Perhaps there are other optional
things we could add?
- John
From ad122b175d798ab3d50e7b41337694538043a218 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Sat, 14 Nov 2020 12:42:10 -0800
Subject: [PATCH] gnu: Add uuid support to recutils.
* gnu/packages/databases.scm (recutils): [inputs] Add lib output of
util-linux.
---
gnu/packages/databases.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
Toggle diff (22 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index c3fb9b5c5f..c011bd398e 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1144,12 +1144,13 @@ organized in a hash table or B+ tree.")
(native-inputs `(("bc" ,bc)
("bash:include" ,bash "include")
("check" ,check)
- ("libuuid" ,util-linux)
+ ("libuuid:out" ,util-linux)
("pkg-config" ,pkg-config)))
;; TODO: Add more optional inputs.
(inputs `(("curl" ,curl)
- ("libgcrypt" ,libgcrypt)))
+ ("libgcrypt" ,libgcrypt)
+ ("libuuid:lib" ,util-linux "lib")))
(synopsis "Manipulate plain text files as databases")
(description
"GNU Recutils is a set of tools and libraries for creating and
--
2.29.1