[PATCH 0/3] Add python-git-hammer

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Leo Prikler
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal
L
L
Leo Prikler wrote on 14 Nov 2020 17:56
(address . guix-patches@gnu.org)
2cdcf2f7975096d33638d6a95db090909718d1fd.camel@student.tugraz.at
Hi Guix,

I wanted to print out some git statistics for recreational purposes,
but then I noticed, that Guix lacks gitstats [1] and upon further
research it became clear, that it hasn't been too well maintained. The
last commit appears to have been made in 2016 (see [2]) and there is
also a lack of Python 3 support. Not ideal at all.
So I instead set out in search for a different tool to package and
stumbled upon [3]. Packaging that does required a bit of manual
tweaking of the `guix import' output, but it's still rather small and
served its purpose. I'll be sending the patches shortly.

Regards,
Leo

L
L
Leo Prikler wrote on 14 Nov 2020 18:00
[PATCH 1/3] gnu: Add python-beautifultable.
(address . 44640@debbugs.gnu.org)
20201114170047.949-1-leo.prikler@student.tugraz.at
* gnu/packages/python-xyz.scm (python-beautifultable): New variable.
---
gnu/packages/python-xyz.scm | 39 +++++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (59 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e5b8db02e0..57371f05c7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -89,6 +89,7 @@
;;; Copyright © 2020 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2020 Bonface Munyoki Kilyungi <bonfacemunyoki@gmail.com>
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18232,6 +18233,44 @@ gevent-powered application.")
(define-public python2-gipc
(package-with-python2 python-gipc))
+(define-public python-beautifultable
+ (package
+ (name "python-beautifultable")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "beautifultable" version))
+ (sha256
+ (base32
+ "0wwlbifcbpzy3wfv6yzsxncarsngzizmmxbn6cy5gazlcq7h4k5x"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-wcwidth" ,python-wcwidth)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-setup.py
+ (lambda _
+ (substitute* "setup.py"
+ (("setup\\(")
+ "setup(\n test_suite=\"test\",")))))))
+ (home-page "https://github.com/pri22296/beautifultable")
+ (synopsis "Print ASCII tables for terminals")
+ (description "@code{python-beautifultable} provides a class for easily
+printing tabular data in a visually appealing ASCII format to a terminal.
+
+Features include, but are not limited to:
+@itemize
+@item Full customization of the look and feel of the table
+@item Row and column accessors.
+@item Full support for colors using ANSI sequences or any library.
+@item Plenty of predefined styles and option to create custom ones.
+@item Support for Unicode characters.
+@item Supports streaming table when data is slow to retrieve.
+@end itemize")
+ (license license:expat)))
+
(define-public python-fusepy
(package
(name "python-fusepy")
--
2.29.2
L
L
Leo Prikler wrote on 14 Nov 2020 18:00
[PATCH 2/3] gnu: Add python-globber.
(address . 44640@debbugs.gnu.org)
20201114170047.949-2-leo.prikler@student.tugraz.at
* gnu/packages/python-xyz.scm (python-globber): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 57371f05c7..7b9ab21671 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18271,6 +18271,31 @@ Features include, but are not limited to:
@end itemize")
(license license:expat)))
+(define-public python-globber
+ (package
+ (name "python-globber")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "globber" version))
+ (sha256
+ (base32
+ "0w7gaqpfc9j9l6hgm0cl7hrlf3lr0w7ifns035cksa1r16mhlwlr"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; missing from distribution
+ (home-page "https://github.com/asharov/globber")
+ (synopsis
+ "Library for string matching with glob patterns")
+ (description
+ "Globber is a Python library for matching file names against glob patterns.
+In contrast to other glob-matching libraries, it matches arbitrary strings and
+doesn't require the matched names to be existing files. In addition, it
+supports the globstar @code{**} operator to match an arbitrary number of
+path components.")
+ (license license:asl2.0)))
+
(define-public python-fusepy
(package
(name "python-fusepy")
--
2.29.2
L
L
Leo Prikler wrote on 14 Nov 2020 18:00
[PATCH 3/3] gnu: Add python-git-hammer.
(address . 44640@debbugs.gnu.org)
20201114170047.949-3-leo.prikler@student.tugraz.at
* gnu/packages/python-xyz.scm (python-git-hammer): New variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7b9ab21671..c5da6b24d6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18296,6 +18296,37 @@ supports the globstar @code{**} operator to match an arbitrary number of
path components.")
(license license:asl2.0)))
+(define-public python-git-hammer
+ (package
+ (name "python-git-hammer")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "git-hammer" version))
+ (sha256
+ (base32
+ "16kcijngd3v6f0ym1j4qb6sp08cqb3iprqn080k3yqgd0b17dfc6"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; missing from distribution
+ (propagated-inputs
+ `(("python-beautifultable" ,python-beautifultable)
+ ("python-dateutil" ,python-dateutil)
+ ("python-gitpython" ,python-gitpython)
+ ("python-globber" ,python-globber)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-sqlalchemy" ,python-sqlalchemy)
+ ("python-sqlalchemy-utils"
+ ,python-sqlalchemy-utils)))
+ (home-page "https://github.com/asharov/git-hammer")
+ (synopsis "Provide statistics for git repositories")
+ (description
+ "Git Hammer is a statistics tool for projects in git repositories.
+Its major feature is tracking the number of lines authored by each person for every
+commit, but it also includes some other useful statistics.")
+ (license license:asl2.0)))
+
(define-public python-fusepy
(package
(name "python-fusepy")
--
2.29.2
E
E
Efraim Flashner wrote on 17 Nov 2020 11:48
Re: [bug#44640] [PATCH 2/3] gnu: Add python-globber.
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 44640@debbugs.gnu.org)
20201117104814.GU987@E5400
Not a full review (currently building other packages...)

On Sat, Nov 14, 2020 at 06:00:47PM +0100, Leo Prikler wrote:
Toggle quote (28 lines)
> * gnu/packages/python-xyz.scm (python-globber): New variable.
> ---
> gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 57371f05c7..7b9ab21671 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -18271,6 +18271,31 @@ Features include, but are not limited to:
> @end itemize")
> (license license:expat)))
>
> +(define-public python-globber
> + (package
> + (name "python-globber")
> + (version "0.2.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "globber" version))
> + (sha256
> + (base32
> + "0w7gaqpfc9j9l6hgm0cl7hrlf3lr0w7ifns035cksa1r16mhlwlr"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:tests? #f)) ; missing from distribution

Can we build from a git checkout then? It's better to have the tests and
run them.

Toggle quote (4 lines)
> + (synopsis
> + "Library for string matching with glob patterns")

Can you put this on the previous line? It triggers something inside me
to have it on its own line when it's not approaching 80 characters :/

Toggle quote (18 lines)
> + (description
> + "Globber is a Python library for matching file names against glob patterns.
> +In contrast to other glob-matching libraries, it matches arbitrary strings and
> +doesn't require the matched names to be existing files. In addition, it
> +supports the globstar @code{**} operator to match an arbitrary number of
> +path components.")
> + (license license:asl2.0)))
> +
> (define-public python-fusepy
> (package
> (name "python-fusepy")
> --
> 2.29.2
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl+zqmkACgkQQarn3Mo9
g1EvCA//XExkjSl2z286UJrZVD5tVXa7PFhBVYqEG/GO1TYdlDSQLEU4/at69XWj
CkImuHUBxvoEKo/uJ459o2QaCKrkFLhC4vZQ2mId29n3/4yBGrYNlBhDLfDkaOUp
jusA8O7XqOSiuYZRxARAXwMmMNedXyb/bpQdhDbHgnEpIDWsEca2F86QoaLFhhHj
mA+qLtaGG6ZdMAWc8KaMv4mkMleCuCx4MQxTRJossZS6mZLUtT/AwNJE4BzyuyuE
q1v0RFUO4UDHE1TOdFjEnVvIMphL/fYoBgtTJMTYlQnEVDD+10FAA47JlbZSZupK
yGR9k41ItRAiRJq4dFgm7NJL4+/VEH1cKqknFvjL1g+KYWY12fkZnx1MAu9+84m5
HA+9JpOMkCLrDAWvYuCs7Si7klTeNZmd2tVi3xK2bWl3O912mM7L2c/+ujayv5kN
WVqtWna2PK+N3vQRT5yf+kwWLSEQKQWi/fbhnlByMFuJrj/9To+8gIPm8r971RN7
fyQ7kf0u7mEnQCzJK9Y3ik3IXAhhlcTR1lm5bYoWZb3f1h1LLUhSU/UeQe3vwWMU
yf9O52sr/5kY7J1Mhm2y9m5Trqu7iTT62OmQGwOdAPivcOUwAcZkSVsusmt4nizX
1x1uiGDu51W/LzRTwYL/gETKro9p95WW/IN+raa+ifawexrUdcc=
=cqwb
-----END PGP SIGNATURE-----


E
E
Efraim Flashner wrote on 17 Nov 2020 11:50
Re: [bug#44640] [PATCH 3/3] gnu: Add python-git-hammer.
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 44640@debbugs.gnu.org)
20201117105051.GV987@E5400
Not a full review, building other packages atm

On Sat, Nov 14, 2020 at 06:00:48PM +0100, Leo Prikler wrote:
Toggle quote (14 lines)
> * gnu/packages/python-xyz.scm (python-git-hammer): New variable.
> ---
> gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 7b9ab21671..c5da6b24d6 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -18296,6 +18296,37 @@ supports the globstar @code{**} operator to match an arbitrary number of
> path components.")
> (license license:asl2.0)))
>

Does it make more sense to put this in version-control than in
python-xyz? Can it be used as a library or is it really just a program
run on its own?

Toggle quote (15 lines)
> +(define-public python-git-hammer
> + (package
> + (name "python-git-hammer")
> + (version "0.3.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (pypi-uri "git-hammer" version))
> + (sha256
> + (base32
> + "16kcijngd3v6f0ym1j4qb6sp08cqb3iprqn080k3yqgd0b17dfc6"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:tests? #f)) ; missing from distribution

Let's build this one from git also, then we can run the tests

Toggle quote (2 lines)
> + (propagated-inputs

These don't need to be propagated if this is an "application" and not a
"library". They can just be regular inputs.

Toggle quote (26 lines)
> + `(("python-beautifultable" ,python-beautifultable)
> + ("python-dateutil" ,python-dateutil)
> + ("python-gitpython" ,python-gitpython)
> + ("python-globber" ,python-globber)
> + ("python-matplotlib" ,python-matplotlib)
> + ("python-sqlalchemy" ,python-sqlalchemy)
> + ("python-sqlalchemy-utils"
> + ,python-sqlalchemy-utils)))
> + (home-page "https://github.com/asharov/git-hammer")
> + (synopsis "Provide statistics for git repositories")
> + (description
> + "Git Hammer is a statistics tool for projects in git repositories.
> +Its major feature is tracking the number of lines authored by each person for every
> +commit, but it also includes some other useful statistics.")
> + (license license:asl2.0)))
> +
> (define-public python-fusepy
> (package
> (name "python-fusepy")
> --
> 2.29.2
>
>
>
>

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl+zqwsACgkQQarn3Mo9
g1Hiiw/+O2plx/Bx0vMa43tRD1MZpq02S1TeOWvKO9WF0DxIzfpRI5jJmwkcpYJC
klT+htDVeoDVwdmnyOl4Pagta35tJMKg2jdxAU0BNj/6KGhRlxknN/zzVLJx+Yyy
xsWyJrnJngSmIJkPsn7gy4Z8tIfDv8Bzvl6g7rzPMkWdWjwc7igQ68+nwu0xGtUT
LIJnSdSy+B6ASv5TXMrlC+li8905gTr22bQqnvf7Q+4HuXSYrpQdW2lDGXmETf6g
5VXA3sa+DKXVfWiLgfUDLI2GMFfJVcl5WU+dlGDNBYZGreORASR9jMfpCWG1JG5L
+gSVW49GDK0dRovTJVkVwUiN7Lj0gvPH44SMwhpeHDjrZEUa4GsjdEOAW7rHMSCp
nqHgrIix7L2SyMr13l4IjsX6Vmh/+5qVCL8tLVv878XKGwij9r5L6pLuuxocGz9w
lr5ij94RTO+dUu0Av05MveXjsDvDcgaQ1DuPms/7PxkhM5n2OrKdhKdMnHOamKOH
11Hy3F2gJfBKQuU3Psl+xXmjxv8hYWcGQ54Wf++tsNNVLZyiCeiQh+vXY+Au42kM
pXXlJslVXF8xHQCfeoi7eXrLmBALQw/jGvONXfGSS/7W1v7Vyq20Ts0SdwQpUfgw
k05C96+gWB5D3qwoUZsKe59idKKMq0c9bZkWz5M64n8UwadlE9o=
=icdY
-----END PGP SIGNATURE-----


L
L
Leo Prikler wrote on 17 Nov 2020 12:01
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 44640@debbugs.gnu.org)
12e66a141b28fcc6c4151b48928b25de1c8988a1.camel@student.tugraz.at
Hello,

Am Dienstag, den 17.11.2020, 12:50 +0200 schrieb Efraim Flashner:
Toggle quote (23 lines)
> Not a full review, building other packages atm
>
> On Sat, Nov 14, 2020 at 06:00:48PM +0100, Leo Prikler wrote:
> > * gnu/packages/python-xyz.scm (python-git-hammer): New variable.
> > ---
> > gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
> > 1 file changed, 31 insertions(+)
> >
> > diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-
> > xyz.scm
> > index 7b9ab21671..c5da6b24d6 100644
> > --- a/gnu/packages/python-xyz.scm
> > +++ b/gnu/packages/python-xyz.scm
> > @@ -18296,6 +18296,37 @@ supports the globstar @code{**} operator
> > to match an arbitrary number of
> > path components.")
> > (license license:asl2.0)))
> >
>
> Does it make more sense to put this in version-control than in
> python-xyz? Can it be used as a library or is it really just a
> program
> run on its own?
I suppose it can. To begin with, there is not even an executable,
you're supposed to run it using `python -m githammer`.

Toggle quote (17 lines)
> > +(define-public python-git-hammer
> > + (package
> > + (name "python-git-hammer")
> > + (version "0.3.1")
> > + (source
> > + (origin
> > + (method url-fetch)
> > + (uri (pypi-uri "git-hammer" version))
> > + (sha256
> > + (base32
> > + "16kcijngd3v6f0ym1j4qb6sp08cqb3iprqn080k3yqgd0b17dfc6")))
> > )
> > + (build-system python-build-system)
> > + (arguments
> > + `(#:tests? #f)) ; missing from distribution
>
> Let's build this one from git also, then we can run the tests
I'm on it, same for 2/3.

Toggle quote (5 lines)
> > + (propagated-inputs
>
> These don't need to be propagated if this is an "application" and not
> a
> "library". They can just be regular inputs.
See my comment above.

Toggle quote (24 lines)
> > + `(("python-beautifultable" ,python-beautifultable)
> > + ("python-dateutil" ,python-dateutil)
> > + ("python-gitpython" ,python-gitpython)
> > + ("python-globber" ,python-globber)
> > + ("python-matplotlib" ,python-matplotlib)
> > + ("python-sqlalchemy" ,python-sqlalchemy)
> > + ("python-sqlalchemy-utils"
> > + ,python-sqlalchemy-utils)))
> > + (home-page "https://github.com/asharov/git-hammer")
> > + (synopsis "Provide statistics for git repositories")
> > + (description
> > + "Git Hammer is a statistics tool for projects in git
> > repositories.
> > +Its major feature is tracking the number of lines authored by each
> > person for every
> > +commit, but it also includes some other useful statistics.")
> > + (license license:asl2.0)))
> > +
> > (define-public python-fusepy
> > (package
> > (name "python-fusepy")
> > --
> > 2.29.2

Regards, Leo
L
L
Leo Prikler wrote on 17 Nov 2020 13:36
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 44640@debbugs.gnu.org)
fddc55034c17332c2445e525f013f503812fb00c.camel@student.tugraz.at
Attached are the revised patches 0002 and 0003.
From f6005737208cf634b0f981f4b8c9d02bf1b77046 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Tue, 17 Nov 2020 13:22:02 +0100
Subject: [PATCH 2/3] gnu: Add python-globber.

* gnu/packages/python-xyz.scm (python-globber): New variable.
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b1d6005a8e..02ec4aec64 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18273,6 +18273,31 @@ Features include, but are not limited to:
@end itemize")
(license license:expat)))
+(define-public python-globber
+ (package
+ (name "python-globber")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asharov/globber.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "055xf7ja7zjhxis0ab5fnfsx16fsvr5fvc6mixqybanwxh8sgfjk"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/asharov/globber")
+ (synopsis "Library for string matching with glob patterns")
+ (description
+ "Globber is a Python library for matching file names against glob patterns.
+In contrast to other glob-matching libraries, it matches arbitrary strings and
+doesn't require the matched names to be existing files. In addition, it
+supports the globstar @code{**} operator to match an arbitrary number of
+path components.")
+ (license license:asl2.0)))
+
(define-public python-fusepy
(package
(name "python-fusepy")
--
2.29.2
From c4f64923fafab6585ab7d6858d9e44dc59fb31e7 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Tue, 17 Nov 2020 13:22:22 +0100
Subject: [PATCH 3/3] gnu: Add python-git-hammer.

* gnu/packages/python-xyz.scm (python-git-hammer): New variable.
---
gnu/packages/python-xyz.scm | 40 +++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 02ec4aec64..11e0570253 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18298,6 +18298,46 @@ supports the globstar @code{**} operator to match an arbitrary number of
path components.")
(license license:asl2.0)))
+(define-public python-git-hammer
+ (package
+ (name "python-git-hammer")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asharov/git-hammer")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0f9xlk86ijzpdj25hr1q4wcy8k72v3w470ngwm9mpdkfj8ng84wr"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-setup.py
+ (lambda _
+ (substitute* "setup.py"
+ (("setup\\(")
+ "setup(\n test_suite=\"test\",")))))))
+ (propagated-inputs
+ `(("python-beautifultable" ,python-beautifultable)
+ ("python-dateutil" ,python-dateutil)
+ ("python-gitpython" ,python-gitpython)
+ ("python-globber" ,python-globber)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-sqlalchemy" ,python-sqlalchemy)
+ ("python-sqlalchemy-utils"
+ ,python-sqlalchemy-utils)))
+ (home-page "https://github.com/asharov/git-hammer")
+ (synopsis "Provide statistics for git repositories")
+ (description
+ "Git Hammer is a statistics tool for projects in git repositories.
+Its major feature is tracking the number of lines authored by each person for every
+commit, but it also includes some other useful statistics.")
+ (license license:asl2.0)))
+
(define-public python-fusepy
(package
(name "python-fusepy")
--
2.29.2
E
E
Efraim Flashner wrote on 18 Nov 2020 09:40
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 44640-done@debbugs.gnu.org)
20201118084002.GZ987@E5400
Looks good! Patches pushed.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl+03eEACgkQQarn3Mo9
g1EQWRAAuA1z49e4iX6izXc+AsX2tKPHda5MNmF+89D7Fu5risnfDapKGbV1GlKX
94b8eznJHlbrNdqhczmfBSpMassRsrB+Uotc61pOL2yDI0gsKQ1iJlnnqRWHC/Y6
uRypWbDMTV0Et5/7FnSK2vG5JGNry/S40QtHzPLLdT0ddwmsppkMmmP9LEwk3+N7
wHtWRcNoWFuFbtlPH68eiKjBlWvjHSPsDhrevnnu64XEw2KqK0yPh9a18KcId7P1
B0XMYdG53IuZe1jMevrUerrSrd+1hjPQgVPcjmcyMGHP/KrRkX1tBUtiPhRTgS27
vKCA3inBflEJgRmadE8oSNGAx9Ghap6tuQ4VvYP0oOtLbhjfCD+EscSLQXYv/DA0
sSHeBaQFvPCVF5OCbztZXUBr3/u4/dQxyOXDRoRWJ3kP5xAETGjTnRcySru5yO3b
mn0qXXeLVIMeq2W4xYL/XTpOTI6QLqhetfqp+LbyptSkgTAKF+OYWeGLe5e1nj4Y
xOi2ZnYwEL5tP+xP3Aa85F9ddgo796viNHm9lXR019ggbcZ8hBvif/34WTLOxctZ
PxjrcHHPVpSZdbBhZZWSvYNkzKD5+RDDs8iJGj+1WPKhUuDIocPSBfCm9ecuevaM
yt8CuubcSwL3R2LFPx8wKdRJeQPXpqNFlepiMWeQxNtPttkEvM0=
=5W02
-----END PGP SIGNATURE-----


Closed
?