[PATCH] gnu: Add gmni.

  • Done
  • quality assurance status badge
Details
3 participants
  • Alexandru-Sergiu Marton
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Alexandru-Sergiu Marton
Severity
normal
A
A
Alexandru-Sergiu Marton wrote on 13 Nov 2020 17:51
(address . guix-patches@gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)
20201113165152.4811-1-brown121407@posteo.ro
* gnu/packages/web-browsers.scm (gmni): New variable.
---
gnu/packages/web-browsers.scm | 44 +++++++++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 5cb5185a31..b959825464 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,6 +61,7 @@
#:use-module (gnu packages lisp)
#:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages man)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -584,6 +586,48 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
(define-public sbcl-next
(deprecated-package "sbcl-next" nyxt))
+(define-public gmni
+ (let ((commit "4a6172f1bf9cb41eb1ce3a5f720f9ebe4febc62b")
+ (revision "0"))
+ (package
+ (name "gmni")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/gmni")
+ (commit commit)))
+ (sha256
+ (base32
+ "1nznkk1ccm5l09glalkv8bmhspqhvmh74ca18cfpdpbwkbzdzc7i"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-variables
+ (lambda _
+ (setenv "CC" "gcc")
+ #t)))))
+ (inputs
+ `(("openssl" ,openssl)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (home-page "https://sr.ht/~sircmpwn/gmni")
+ (synopsis "Gemini client")
+ (description "This is a Gemini client. Included are:
+
+@itemize
+@item A CLI utility (like curl): gmni
+@item A line-mode browser: gmnlm
+@end itemize")
+ (license (list license:gpl3+
+ (license:non-copyleft
+ "https://curl.se/docs/copyright.html"
+ "Used only for files taken from curl."))))))
+
(define-public bombadillo
(package
(name "bombadillo")
--
2.29.1
A
A
Alexandru-Sergiu Marton wrote on 13 Nov 2020 18:02
[PATCH v2] gnu: Add gmni.
(address . 44620@debbugs.gnu.org)(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)
20201113170201.5680-1-brown121407@posteo.ro
* gnu/packages/web-browsers.scm (gmni): New variable.
---
This second version simplifies the arguments section by using #:make-flags to
set CC, rather than using an environment variable.

gnu/packages/web-browsers.scm | 39 +++++++++++++++++++++++++++++++++++
1 file changed, 39 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 5cb5185a31..b652e8d472 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,6 +61,7 @@
#:use-module (gnu packages lisp)
#:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages man)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -584,6 +586,43 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
(define-public sbcl-next
(deprecated-package "sbcl-next" nyxt))
+(define-public gmni
+ (let ((commit "4a6172f1bf9cb41eb1ce3a5f720f9ebe4febc62b")
+ (revision "0"))
+ (package
+ (name "gmni")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/gmni")
+ (commit commit)))
+ (sha256
+ (base32
+ "1nznkk1ccm5l09glalkv8bmhspqhvmh74ca18cfpdpbwkbzdzc7i"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:make-flags (list "CC=gcc")))
+ (inputs
+ `(("openssl" ,openssl)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (home-page "https://sr.ht/~sircmpwn/gmni")
+ (synopsis "Gemini client")
+ (description "This is a Gemini client. Included are:
+
+@itemize
+@item A CLI utility (like curl): gmni
+@item A line-mode browser: gmnlm
+@end itemize")
+ (license (list license:gpl3+
+ (license:non-copyleft
+ "https://curl.se/docs/copyright.html"
+ "Used only for files taken from curl."))))))
+
(define-public bombadillo
(package
(name "bombadillo")
--
2.29.1
C
C
Christopher Baines wrote on 15 Nov 2020 20:23
(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)(address . 44620@debbugs.gnu.org)
874klqctkq.fsf@cbaines.net
Alexandru-Sergiu Marton <brown121407@posteo.ro> writes:

Toggle quote (2 lines)
> * gnu/packages/web-browsers.scm (gmni): New variable.

Hi,

Thanks for the patch :) I've made some comments below.

Toggle quote (50 lines)
> ---
> This second version simplifies the arguments section by using #:make-flags to
> set CC, rather than using an environment variable.
>
> gnu/packages/web-browsers.scm | 39 +++++++++++++++++++++++++++++++++++
> 1 file changed, 39 insertions(+)
>
> diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
> index 5cb5185a31..b652e8d472 100644
> --- a/gnu/packages/web-browsers.scm
> +++ b/gnu/packages/web-browsers.scm
> @@ -13,6 +13,7 @@
> ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
> ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
> ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
> +;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -60,6 +61,7 @@
> #:use-module (gnu packages lisp)
> #:use-module (gnu packages lisp-xyz)
> #:use-module (gnu packages lua)
> + #:use-module (gnu packages man)
> #:use-module (gnu packages ncurses)
> #:use-module (gnu packages perl)
> #:use-module (gnu packages pkg-config)
> @@ -584,6 +586,43 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
> (define-public sbcl-next
> (deprecated-package "sbcl-next" nyxt))
>
> +(define-public gmni
> + (let ((commit "4a6172f1bf9cb41eb1ce3a5f720f9ebe4febc62b")
> + (revision "0"))
> + (package
> + (name "gmni")
> + (version (git-version "0" revision commit))
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://git.sr.ht/~sircmpwn/gmni")
> + (commit commit)))
> + (sha256
> + (base32
> + "1nznkk1ccm5l09glalkv8bmhspqhvmh74ca18cfpdpbwkbzdzc7i"))
> + (file-name (git-file-name name version))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f

I'm guessing there are no tests to run, but a comment saying that would
be good.

Toggle quote (2 lines)
> + #:make-flags (list "CC=gcc")))

I think it would be better to put something like:

(string-append "CC=" ,(cc-for-target))

As I believe that helps when compiling for other architectures. I copied
that from the f3 package if you want an example in context.

Toggle quote (8 lines)
> + (inputs
> + `(("openssl" ,openssl)))
> + (native-inputs
> + `(("pkg-config" ,pkg-config)
> + ("scdoc" ,scdoc)))
> + (home-page "https://sr.ht/~sircmpwn/gmni")
> + (synopsis "Gemini client")

Is there some way of making this more descriptive, like saying it's a
command line client?

Toggle quote (7 lines)
> + (description "This is a Gemini client. Included are:
> +
> +@itemize
> +@item A CLI utility (like curl): gmni
> +@item A line-mode browser: gmnlm
> +@end itemize")

I'd probably change the start of this to "The gmni package includes:",
as that repeats the synopsis less.

Toggle quote (9 lines)
> + (license (list license:gpl3+
> + (license:non-copyleft
> + "https://curl.se/docs/copyright.html"
> + "Used only for files taken from curl."))))))
> +
> (define-public bombadillo
> (package
> (name "bombadillo")

Would you be able to send an updated patch?

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl+xgEVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcuZBAAmyghRehKi/RXkPhHSYHrN/M8YmGk/uu3
Ujsxar5yg84Y9BceE5xoGePdAE4mZXjp5RubFfJ6VDK6I7SrW4YVHuRsN8n4M4iG
X4Yr1cGF+SXM5b9z7FOIVnx9G9W3g5IAUA1QpvJ9Zgyz58E5hsHSC7Q/G9qNaLoq
f/RZswdbqyambxR8m5jnt4U+0y+5Mx9PZ7MLvh+L0htUgXzUT6PhrUXRyaWfae7H
o8LvOramKFpGJ5MJ4GTUSM9mOD8tFsVoFiC6maxkX0B7K9x8UFQs4O4dYIOJfwGT
pTSxUXxcBdiJE5C5vohzfJ9deMcgtFusis7EhqRBdbJyf2YCCqB0qXqb7t/XlOEB
J17Xkiyq8m/ALKlGArApIfhWpXgm7u+z6tlzl9XTjc13Scnme/4+n3yREgvLUhlX
aVpN/SHhq7hTaNpp9jyzdbrUCKZtvXBfosDkQEbPB0EzSTd35CcFe+flqrpMHNtS
8f/GSQBCbWi/3kW6A49eh8W/YsSd58Jq+RpOMqG87J2tqSpnRwhoFbdXm639pSDI
dDDJ/NblWhhSyJUMgigpjDe8zHc5EDcsgGosFYFKUfMVrzSOE9etLMDP1qAABjRG
C7w7QA0K3t4hLo6fHfG1H04+zJJpoRNnlYsCvBHTcqLAv6ToZSMwBLm6nIlqqw7n
CDJTng0WO2Q=
=ZUTH
-----END PGP SIGNATURE-----

A
A
Alexandru-Sergiu Marton wrote on 16 Nov 2020 22:55
(name . Christopher Baines)(address . mail@cbaines.net)(address . 44620@debbugs.gnu.org)
4f785125-f553-4b56-83fa-e0b09a591801@posteo.ro
Hi Chris,
Thank you for all the tips!
15 Nov 2020 21:24:02 Christopher Baines <mail@cbaines.net>:
Toggle quote (1 lines)
> Would you be able to send an updated patch?
I will, but probably sometime later this week, as I'm currently caught in
other stuff.
Cheers,
Sergiu
Attachment: signature.asc
L
L
Ludovic Courtès wrote on 29 Nov 2020 23:30
(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)
87czzvpzhs.fsf@gnu.org
Hi Sergiu,

Did you have a chance to look into it?

Thanks in advance,
Ludo’.

Alexandru-Sergiu Marton <brown121407@posteo.ro> skribis:

Toggle quote (13 lines)
> Hi Chris,
>
> Thank you for all the tips!
>
> 15 Nov 2020 21:24:02 Christopher Baines <mail@cbaines.net>:
>
>> Would you be able to send an updated patch?
>
> I will, but probably sometime later this week, as I'm currently caught
> in other stuff.
>
> Cheers,
> Sergiu
A
A
Alexandru-Sergiu Marton wrote on 30 Nov 2020 10:50
[PATCH v3] gnu: Add gmni.
(address . 44620@debbugs.gnu.org)
20201130095041.11111-1-brown121407@posteo.ro
* gnu/packages/web-browsers.scm (gmni): New variable.
---
This new patch version should take into account the comments provided by
Christopher. It also uses a newer commit for gmni and should fix some
conflicts when applying it to the guix repository.

Sorry for the delay!

gnu/packages/web-browsers.scm | 40 +++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (74 lines)
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 7fe890502e..b101b78008 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@posteo.ro>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,6 +42,7 @@
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages backup)
#:use-module (gnu packages compression)
@@ -62,6 +64,7 @@
#:use-module (gnu packages lisp)
#:use-module (gnu packages lisp-xyz)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages man)
#:use-module (gnu packages markup)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
@@ -706,6 +709,43 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
(define-public sbcl-next
(deprecated-package "sbcl-next" nyxt))
+(define-public gmni
+ (let ((commit "d8f0870446c471a42612d6a8e853ad9b723a6d39")
+ (revision "0"))
+ (package
+ (name "gmni")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/gmni")
+ (commit commit)))
+ (sha256
+ (base32
+ "1h0iqm7l0i06glf5b2872w656s1mjdiqva14zh6sl4f5yp7zmvwr"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:make-flags (list (string-append "CC=" ,(cc-for-target)))))
+ (inputs
+ `(("openssl" ,openssl)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (home-page "https://sr.ht/~sircmpwn/gmni")
+ (synopsis "Minimalist command line Gemini client")
+ (description "The gmni package includes:
+
+@itemize
+@item A CLI utility (like curl): gmni
+@item A line-mode browser: gmnlm
+@end itemize")
+ (license (list license:gpl3+
+ (license:non-copyleft
+ "https://curl.se/docs/copyright.html"
+ "Used only for files taken from curl."))))))
+
(define-public bombadillo
(package
(name "bombadillo")
--
2.29.2
C
C
Christopher Baines wrote on 30 Nov 2020 10:34
(name . Alexandru-Sergiu Marton)(address . brown121407@posteo.ro)
87mtyzrxw7.fsf@cbaines.net
Alexandru-Sergiu Marton <brown121407@posteo.ro> writes:

Toggle quote (8 lines)
> * gnu/packages/web-browsers.scm (gmni): New variable.
> ---
> This new patch version should take into account the comments provided by
> Christopher. It also uses a newer commit for gmni and should fix some
> conflicts when applying it to the guix repository.
>
> Sorry for the delay!

No problem! The patch looks good, I've pushed to master as
6e4f62ad8fe0a1bafee4b318ad81152b7e425d4f.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl/EvKlfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfbYw/+NlpHuSviLbt7Z1Gmstg2xrEb/8CapycW
JPQd2/MJJwVTg3BM/d0gAcUduWJxtBYGIBIGJNAXbGzJWOog1SEPu9mGLr30yMZd
vz9MOD6zkxQLtg61yDCZM95WBg52EaG16LgjWp/PY1D36GadJEdOqzd+3eRXTTCU
9g92EPTYjHU8B3MBobS4SLgfoJjqn4cjQntSdfEZueE30K0KoIhLAwEQXiX4fHz1
Idc1geCFlZOS2vOo92+5UBvkxyA0y5SyAbsswmOCEDXQkKLmrWRjr+zo7eiHPtbh
mVIfVRmJbwzJ0sIliXvCoO5d6FGWtfGQwW6BBaeEzx3J84DDoJ4249FUGTQaaDdl
jS37xLt1nzni4fP7TVogVk8Gv/CKgwJZah6UG49gIOE3m3pcAmUXElQnCoTnVu6o
8Uaoz7i/yVsTCef4gRDC/70iIVwtC27IlxrTDETyV6+Euy+beHEcMKqRQunQnb9X
G8/lX+HAVIeWrgRMYfg1/IPSPMDZNnd64LHgJx4F0aFNXUnACCUkZj8pPoc+7HCe
ROqikx0RvDd6H7vTfncbqcH5pmEVjXGJYVDfzK5cQe8zDDz5CSKDblSaAYdaYX3O
lHnSuzmyQ129obX/cgFNAnPDqht4mvtkW8eFns9vHRcLquFplvPuCpG2dPyypcXF
ZFyoW7YrrfY=
=fnbG
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 44620@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 44620
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch