(address . bug-guix@gnu.org)
Hi Guix,
guix.el Has been broken for quite some time because it depends on @@ for
some modules. After some review, I came to the conclusion that all of
the bindings it uses can be safely exposed.
In general, it uses mostly bindings from guix scripts (pack, build,
etc). Those bindings seem reasonable to expose since they give
programmatic access to "API"s that the CLI user is most likely familiar
with.
Thanks!
John
From af50f2d398096f7f8bd4efd9255b5713f39104b2 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 12 Nov 2020 21:47:36 -0800
Subject: [PATCH 1/2] guix pack: Expose some bindings for third-party use.
* guix/scripts/pack.scm (compressor-name, %compressors, %formats):
Expose them.
---
guix/scripts/pack.scm | 3 +++
1 file changed, 3 insertions(+)
Toggle diff (21 lines)
diff --git a/guix/scripts/pack.scm b/guix/scripts/pack.scm
index 8e694edbbe..b6dfcb5f6a 100644
--- a/guix/scripts/pack.scm
+++ b/guix/scripts/pack.scm
@@ -58,11 +58,14 @@
#:use-module (srfi srfi-37)
#:use-module (ice-9 match)
#:export (compressor?
+ compressor-name
+ %compressors
lookup-compressor
self-contained-tarball
docker-image
squashfs-image
+ %formats
guix-pack))
;; Type of a compression tool.
--
2.29.1
From 17344a2a6f68146c51368788dcdf3dd9193155e6 Mon Sep 17 00:00:00 2001
From: John Soo <jsoo1@asu.edu>
Date: Thu, 12 Nov 2020 21:54:45 -0800
Subject: [PATCH 2/2] guix build: Expose log-url for third parties.
* guix/scripts/build.scm (log-url): Expose it.
---
guix/scripts/build.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
Toggle diff (17 lines)
diff --git a/guix/scripts/build.scm b/guix/scripts/build.scm
index f4a8af035b..41f21fa81d 100644
--- a/guix/scripts/build.scm
+++ b/guix/scripts/build.scm
@@ -57,7 +57,9 @@
#:use-module ((guix status) #:select (with-status-verbosity))
#:use-module ((guix progress) #:select (current-terminal-columns))
#:use-module ((guix build syscalls) #:select (terminal-columns))
- #:export (%standard-build-options
+ #:export (log-url
+
+ %standard-build-options
set-build-options-from-command-line
set-build-options-from-command-line*
show-build-options-help
--
2.29.1